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General

This user guide contains neither instructions about basic operation of computers nor about basic functions of 
operating systems Windows®  or Mac OS®.
For more detailed information about how to operate your computer, please refer to the manuals of the computer and 
its operating system. 

Copyright

This user guide as well as translations hereof are property of cab Produkttechnik GmbH & Co. KG.
The replication, conversion, duplication or divulgement of the whole user guide or parts of it for other intentions than 
its original intended purpose - in particular the procurement of spare parts for products sold by cab - demand the 
previous written authorization by cab.
Each possible software that represents part of this system is made available under license and may become use or 
copies only in agreement with the license conditions.

Trademark

Microsoft® is a registered trademark of the Microsoft Corporation.
Windows 2000®, Windows 7®, Windows 8®, Windows XP® and Windows Vista® are registered trademarks of the 
Microsoft Corporation.
TrueTypeTM is a registered trademark of Apple Computer, Inc.
All other itemized company names and product names and its trademark are protected property of the respective 
proprietors.

Editor

For any question or comments please contact cab Produkttechnik GmbH & Co. KG, Germany.

Topicality

Due to further development of our products, discrepancies between user guide and product may occur. Please refer 
to www.cab.de for the current issue.

Terms and Conditions

Deliveries and performances are effected according to the cab General Conditions of sale. 

Technical Support

If you are experiencing problems using cabLase Editor 5 and you need help, you should:

•	 Retry the action, carefully following the instructions given for that task in this manual

•	 Check the troubleshooting section of this manual for troubleshooting information

•	 Try to reproduce the problem and document the exact scenario in which it occurs. If possible, save screen 
captures of all error/event messages

•	 Try to determine the nature of the problem. By eliminating variables, the problem can be narrowed down. If it 
appears to be hardware problems, check the documentation that came with your hardware for maintenance or 
hardware-related issues. Contact your hardware representative, if necessary

About this Manual

The cabLase Editor 5 User Guide contains detailed information about the cabLase Editor 5 tools and commands. 
The manual is intended for use as a reference tool in everyday work with the cabLase Editor 5 software Suite. 
This manual assumes a working knowledge of computers and their operating conventions, including how to use a 
mouse and standard menus and commands. To review these techniques, see the documentation that came with the 
computer system.
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Congratulations on selecting the cabLase Editor 5 Software Suite, a powerful collection of laser marking software 
modules and libraries for OEM laser marking system integrators.

The cabLase Editor 5 Software Suite includes the following:

•	 The cabLase Editor 5 Graphical User Interface, which includes a software command API

•	 Lanmark Controls Inc. COM Automation Server API object interface library

•	 The TCP/IP Test Client tool

•	 The LEC Remote Admin tool

This User Guide is a cab branded copy of the Lanmark Controls WinLase LAN User Guide. cabLase Editor 5 is the 
cab brand name of WinLase LAN.

Lanmark Controls Inc. and cab Produkttechnik GmbH & Co KG have prepared the contents of this document for use 
by its personnel, licensees, and potential licensees. Lanmark Controls Inc. and cab Produkttechnik GmbH & Co KG 
reserve the right to change any products described in this document as well as information included herein without 
prior notice. Although the information presented in this document has been tested and reviewed, this document does 
not convey any license or warrantee beyond the terms and conditions set forth in the written contracts and license 
agreements between Lanmark Controls Inc., cab Produkttechnik GmbH & Co KG and its customers.

The software described in this document is licensed from and is a trade secret of Lanmark Controls Inc. Refer to your 
License Agreement for restrictions on use, duplication, or disclosure.

Copyright © 2010 Lanmark Controls Inc. - All rights reserved under the copyright laws of the United States of 
America.

There is no implied warranty of fitness for a particular purpose, and Lanmark Controls Inc. is not responsible for 
consequential damages. Individual components and/or software modules manufactured by Lanmark Controls Inc. or 
others may be covered by their own warranties. Refer to the appropriate manuals for this information.
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1.1	 SYSTEM  ELEMENTS

1.1.1	 SYSTEM ARCHITECTURE

cabLase Editor 5 offers a rich feature set and industry-leading capabilities by providing the complete software/
controller solution from the User Interface to the firmware resident on the LEC-2 card.

	 System architecture
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Important information and instructions in this user guide are designated as follows:

Danger!
Draws your attention to an exceptionally grave, impending danger to your health or life.

!
Warning!
Indicates a hazardous situation that could lead to injuries or material damage.

! Attention!
Draws attention to possible dangers, material damage or loss of quality..

i Note!
Gives you advice. They make a working sequence easier or draw attention to important working processes.

Tip!
Gives advice to make work easier.

 Environment!
Gives you advice on protecting the environment.

 Handling instruction

 Reference to section, position, illustration number or document.

 Option (accessories, peripheral equipment, special fittings).

time Information in the display.



15 15	 INTRODUCTION

1.1.2	 CabLase Editor 5 LASER MARKING SOFTWARE

cabLase Editor 5 elements include:

•	 Supports LEC-2 Ethernet controller cards

•	 Runs on Windows 7, Windows 10, Windows XP Professional

•	 Easy configuration of laser parameters for specific lasers

•	 Supports TrueType, OpenType and Laser fonts

•	 Supports graphic file import of DXF (versions 13, 14, 2000, 2004, 2007), DWG (versions 13, 14, 2000), PLT, EMF, 
WMF, EX2, MCL, BMP, JPG, GIF, PCX

•	 Supports linear barcode types Code 39, CodaBar, Code 93, Code 128, Interleaved 2 of 5, POSTNET, UPC A, 
UPC E, EAN 8, EAN 13, BookLan

•	 Supports 2D barcode types DataMatrix, Denso QR code, PDF417

•	 Extensive array of Automation objects: Wait for Input, Set Output, Time Delay, MessageBox, XY Motion, Rotary 
Motion, Linear Motion, Serial Communication, Run Application, Alignment Tool, Laser Control

•	 Interfaces with intelligent motion controllers for multipe motion axis control

•	 Regional language support for: Chinese (Simplified), Chinese (Traditional), English (United States), French 
(France), German (Germany), Italian, Japanese, Korean, Spanish (Spain)

•	 Marker Library functionality is exposed in a COM Automation server interface (IAutomate and ILec)

•	 Host Interface control via RS-232 or Ethernet

1.1.3	 COM AUTOMATION SERVER LIBRARY

cabLase Editor 5 exposes a COM Automation server, which offers external programs the ability to communicate 
with and control cabLase Editor 5. For detailed information on the COM Automation server interface, please refer to 
the document package cabLase Editor 5 COM Automation Server Interface Manual available separately from Cab 
Produkttechnik GmbH & Co KG

1.1.4	 HOST PROGRAMMING INTERFACE

The Host Programming Interface provides a remote program, written by the customer, the ability to take control of 
cabLase Editor 5. In addition, the Field bus interface provides a means for controlling cabLase Editor 5 and reading 
status back from cabLase Editor 5 to the Master controller.

1.2	 SOFTWARE TOOLS

1.2.1	 TCP/IP TEST CLIENT

cabLase Editor 5 has a built-in server, ready to respond to requests for information from other programs over an 
Ethernet network. The TCP/IP Test Client is a utility program, which allows simple testing and debugging of the server 
interface from the same computer or from a remote computer.

1.2.2	 TCP/IP TEST CLIENT

The LEC Remote Admin Tool is a utility program which allows communication directly with an LEC-2 control card. 
Please refer to the LEC-2 documentation regarding the use of the Remote  API.
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2.1	 SOFTWARE INSTALLATION

Before you begin working with cabLase Editor 5, take a few moments to review installation tips, how to get help, and 
safety considerations.

This section gives the system requirements and steps needed to install cabLase Editor 5.

2.1.1	 SYSTEM REQUIREMENTS

The following hardware is required:

Computer IBM PC/AT compatible computer
Operating system Microsoft Windows XP® Professional SP3 (32 bit / 64 bit)

Microsoft Windows 7® Professional SP1 (32 Bit / 64 bit)
Processor Intel Core i3-540, or more powerful

Working memory Min. 1 GB RAM, recommended > 2 GB
Harddisk Memory required for Software 1 GB

Hard disk size recommended > 40 GB
Drives CD-ROM or DVD drive for software installation

Interfaces 1 x network card 10/100 MBit for connection of laser (TCP/IP version)
3 x PCI slot (PCI version)
PS2 / USB interfaces for mouse / keyboard
Min. 2 x USB 2.0 backside (Dongle)
Min. 1 x USB 2.0 front side (for example storage medium)
Optionally: RS-232 interfaces
(When using cab axis systems or cab LabelMarker) 

Software cabLase Editor4 Version 4.1.6.18 and higher (PCI version)
cabLase Editor5 Version 5.1.5.2 and higher (TCP/IP version)

Monitor SVGA / DVI Monitor output, resolution recommended 1280 x 1024 dpi

2.1.1.1	 HOW THE OPERATING SYSTEM DICTATES SECURITY SETTINGS

•	 When installing the software, an account with Administrative privileges is required

•	 In order to make any changes to configurations such as laser calibration, lens calibration, etc., the same account 
that installed the software must be logged on

•	 Users with log on privileges less that Administrative will not be allowed to make configuration changes. When 
attempting to make changes, the following message box will be displayed:



17 172	 GETTING STARTED

2.1.1.2	 INSTALLING THE SOFTWARE

To install cabLase Editor 5:

XX Do not plug the Hard lock into a USB port at this time
XX Power up the computer and log on as an Administrator. The log on account must have administrator rights to 

install the software
XX Insert the cabLase Editor 5 Installation CD in the CD-ROM or DVD drive
XX The installation program will start automatically
XX Follow the instructions on the screen to complete the installation
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2.2	 HASP KEY (DONGLE) INSTALLATION
cabLase Editor 5 requires the included HASP (dongle). A HASP is a security device attached to the computer's USB 
port.

i Note!
Some features of cabLase Editor 5 may not be available, if a HASP key is not installed.

2.2.1	 TO INSTALL THE USB HASP VERSION

XX Plug the HASP device into an available USB port after completing the software installation procedure

2.2.2	 IF STARTING cabLase Editor 5 FROM THE WINDOWS

XX If starting cabLase Editor 5 from the Startup folder, changes must be made to the HASP driver configuration to 
insure the HASP device is enabled before cabLase Editor 5 starts. These changes are made in the Windows 
Registry

!
Warning!
You must have Administrator privileges to modify the Registry. Exercise extreme caution when making 
changes in the Registry, as incorrect settings could cause Windows to become unstable.

XX Open the Registry Editor. If using Windows XP, click the Start button, then click Run. Type regedit in the Open box 
and click OK. If using Windows 7, click the Start button and type regedit in the search box, then press the Enter 
key

XX Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services
XX For the HASP, select the hasplms key in the left pane of the Registry editor. For a Hard lock, select the hard lock 

key in the left pane. The settings for the key will appear in the right pane
XX Right-click the Start value in the right pane and select Modify
XX In the Value data field, enter 0 (zero) and click OK
XX Close the Registry Editor
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2.3	 SAFETY CONSIDERATIONS

It is important to observe laser safety while working with any laser product. Anyone who may come into contact 
with lasers or laser systems while they are operating must be aware of the warnings provided in this chapter and 
throughout the document. In addition, the system operator must be familiar with all cautions and notes throughout this 
manual.

i Note!
This safety information is provided as a reference to the user. Please consult you Laser System User 
documentation for details on the safety requirements appropriate for your particular laser system.

Danger!
Never stare into the beam of a laser or laser system, even if wearing protective eye wear. Severe injury may 
result to personnel from failure to observe this safety precaution.

2.3.1	 INTRODUCTION

Individuals, who maintain, troubleshoot, or otherwise service a laser system must comply with all applicable regula-
tions associated with laser operation and maintenance to ensure their own safety and that of others. This chapter 
introduces government safety policies and regulations. Specific information regarding theses policies and regulations 
can be obtained by contacting your plant safety representative and by reading the references cited at the end of this 
section.

!
Warning!
Severe injury to personnel or damage to equipment may result from failure to observe the most common 
safety precautions.

The hazards associated with laser operation include both lethal high voltage and those of potential severe eye or 
skin damage from exposure to the invisible radiation from a direct or reflected infrared laser beam. To minimize these 
hazards, personnel should exercise caution at all times when operating, maintaining or troubleshooting the system.

2.3.2	 SAFETY POLICIES AND REGULATIONS

Local/municipal, state/provincial and federal/national government legislate safety policies for laser operation. 
Government policies and regulations for the safe operation of lasers take priority over plant and any general guide-
lines presented. Refer to your plant safety representative for specific government policies and regulations that apply 
to safe laser system operation at your site.

2.3.3	 LASER HAZARDS

!

Warning!
All maintenance/service actions on a laser or laser system must be performed within the safety guidelines 
discussed in this chapter on System Safety. Laser safety eye wear, with a minimum optical density (OD) 07 
for the appropriate wavelength, must be worn when a laser or laser system is energized. 
Under no circumstances should you allow yourself to be exposed to a direct laser beam!
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2.3.4	 HAZARD ZONES AND OPTICAL BEAM PATH

!
Warning!
The beam produced by most industrial lasers is invisible. To protect operators from the effects of the laser 
emissions, the operator must be aware of the hazard zones of the laser the potential for severe eye or skin 
damage, and the electrical hazards associated with the equipment.

2.3.5	 EYE DAMAGE

Corneal or retinal burns (or both), depending upon laser wavelength, are possible from direct or indirect exposure 
to a laser beam. Because most industrial laser beams are not visible to the naked eye, it is possible to unknowingly 
be exposed to the laser light. For this reason, safety eye wear must aways be worn when operating the system as 
a Class IV laser or when working on the laser with the laser cover removed. For details about safety eye wear, see 
Laser Safety Eye wear.

i Note!
Failure to use the specified safety eye wear can result in burns to the cornea and retina, most likely 
resulting in loss or impairment of eyesight.

Danger!
Never stare into the beam of a laser or laser system, even if wearing protective safety eye wear. Severe 
injury may result to personnel from failure to observe this safety precaution.

2.3.6	 SKIN BURNS

Skin burns are possible from direct contact with high levels of optical radiation from laser beams. Skin burns are also 
possible from acute exposure to high levels of indirect optical radiation. To prevent skin damage, a Class I enclosure, 
laser cover, and beam tubes (for more information see Section 2.3.7 Devices to reduce laser hazard risks) should be 
in place when operating a laser or laser system.

2.3.7	 DEVICES TO REDUCE LASER HAZARD RISKS

To reduce the risks of potential hazards of the laser, the following safety devices should be used as directed.

LASER SAFETY EYE WEAR
Laser safety eye wear with a minimum optical density (OD) of 7 for light at the appropriate wavelength must be worn 
by everyone in the area whenever the laser is operational.

BEAM TUBES
Beam tubes (or rubber bellows) placed in the laser or laser system between the mirrors, apertures and other laser 
components:

•	 Reduce the eye hazard, if the laser or laser system cover were to be removed

•	 Limit direct access to the raw laser beam, and

•	 Protect optical surfaces from dust and contamination
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2.3.8	 LASER SAFETY SIGNS

Different warning labels are attached to the device to make aware of potential hazards.

i Note!
To identify potential hazards it is in no case allowed to remove or damage warning labels!

1

Class 4
Laser radiation of Class 4 is very dangerous for eye and skin. This also 
applies for even diffusely scattered laser radiation. The laser radiation may 
cause danger of fire and explosion.

XX Safety regulations for Class 4 must be strictly observed

Pilot laser, Class 2
In the case of class 2 laser devices, the eye is not endangered if the impact 
of the laser radiation is limited to a maximum period of 0.25 s.

XX Do not look directly into the laser beam.

2 Laser radiation warning

3 Aperture for visible and invisible laser radiation emission

Safety signs
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2.3.9	 ENVIRONMENT AND HEALTH

Warning!
Harmful effects on physical health and environment due to by-products set free in the laser processing.
Laser processing produces by-products being harmful to the environment and health. These hazardous 
substances may be carcinogenic and have effects that are damaging to the lung.
The hazardous substances are particulate (dust / fine dust) or gaseous (smoke, gases).

XX Only operate the device with a suitable, certified extraction and filtering device.
XX Observe operator's manual for the extraction and filtering device.
XX Check regularly the effectiveness of the extraction and filtering device. 
XX Correctly dispose of spent filters.

Examples :

Processing of Hazardous substances Potential hazard

Ceramic Aluminum oxide 
Magnesium oxide 
Calcium oxide 
Silicon oxide

Harmful to lungs

Beryllium oxide Highly toxic, carcinogenic
Silicon Silicon and Silicon Oxide 

fragments
Harmful to lungs 
Risk of silicosis

Metal Manganese (Mn) 
Lead (Pb)

Toxic

Zinc (Zn) 
Copper (Cu)

Toxic (allergies)

Chromium, (Cr) 
Nickel (Ni) 
Cobalt (Co)

Carcinogenic

Aluminum (Al) Harmful to lungs
Beryllium (Be) Risk of pulmonary fibrosis

Plastic Cyanides 
Chlorine compounds

Toxic

Polyvinyl chloride 
Formaldehyde

Carcinogenic, irritating to respi-
ratory tract

Benzenes Carcinogenic
Amines Irritating to respiratory tract
Isocyanate 
Acrylate

Irritating to skin (Allergies)

Paper and wood Benzenes Carcinogenic
Esters 
Acids 
Alcohol

Irritating to respiratory tract

Potential hazards due to laser processing

2.3.10	 FURTHER READING

For more information on laser safety issues, accident prevention regulations and operating directives about all laser 
classes consult the valid guidelines.

!
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3.1	 QUICK START GUIDE

Follow these steps to quickly get your cabLase Editor 5 software and your LEC-2 controller card up and running:

•	 Become familiar with the cabLase Editor 5 user interface. See "User Interface" on page 25

•	 Determine the IP addressing scheme to use. See "Connectivity Options" on page 43

•	 Connect the cables between the PC and the LEC-2

•	 Establish a network connection with the LEC-2 device from cabLase Editor 5. See "Making a connection" on page 
47

•	 Configure the LEC-2 with the appropriate laser and lens settings. See "Choosing Laser, Lens and Motion 
Settings" on page 51

•	 Add a system entity to a job. See "Adding a System Entity" on page 86

•	 Assign the job to the LEC-2 device. See "Assigning Jobs to an LEC-2 device" on page 83.

•	 Mark a sample in streaming mode by using the QuickMark feature. See "Using the QuickMark Feature" on page 
205

i Note!
Some features of cabLase Editor 5 may not be available, if a Hardlock key is not installed.

3.2	 SELECTING THE DISPLAY LANGUAGE

cabLase Editor 5 can be configured to use any one of the provided local display languages. Currently, these 
languages are: Chinese (Simplified), Chinese (Traditional), English (United States), French (France), German 
(Germany), Italian, Japanese, Korean and Spanish (Spain). Most of the Asian languages will not be available unless 
the version of Windows supports that language, or has been specially configured cabLase Editor 5. After installing 
cabLase Editor 5, the default language is English (United States).
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3.2.1	 TO CHANGE THE DEFAULT LANGUAGE

XX From the Main menu, select System > Preferences
XX Click on Languages tab. The Languages page appears

XX Select the desired language that will be used to display text throughout cabLase Editor 5
XX Click the Set as Default button. The Restart Application window displays
XX Click the OK button
XX Close cabLase Editor 5 and then restart to apply the changes
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3.3	 USER INTERFACE

There are three different interfaces available in which to interact with the software:

•	 The Job Editor Workspace, where all editing and full controls are available to the Job programmer

•	 The Operator interface, a limited interface, which only allows loading and running of Jobs. Job editing is not 
allowed

•	 The Touch screen interface, a specialized interface with large buttons and text boxes, designed for use with touch 
screens. This interface can be used with mouse input as well

JOB EDITOR WORKSPACE

When cabLase Editor 5 is started for the first time, the Job Editor Workspace is displayed by default. The Job Editor 
Workspace provides all editing functions and the full control set. Every function provided in the Job Editor Workspace 
can also be password protected by using the Permissions feature. See "Security Settings". In the Job Editor 
Workspace, the window within the cabLase Editor 5 program represents the physical marking field which is referred 
to as the Page size, which can be customized in the Job settings. See "Customizing the Page Size" on page 76.

3.3.1	 TO SWITCH TO THE JOB EDITOR WORKSPACE

XX From the Main menu, select System > Security > User Access. The Access Levels window appears.
XX Click the ALL editing functions radio button

The Job Editor Workspace

A Title Bar
B Main Menu
C Tools Bar
D Laser System Viewer
E Rulers
F Work Area
G Object Manager
H Status Bar
I Profile Manager
J Motion Manager
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3.3.2	 SETTING THE UNITS OF MEASURE

All marking objects placed in the marking field have their dimensions and positions specified internally in bits. See 
"Coordinate System Conventions" on page 75. To display an object's position and size in real world dimensions such 
as millimeters, cabLase Editor 5 needs to use a scale factor to convert from bits into millimeters. This scale factor 
is provided by the Lens Correction file. Different Lens Correction files have different scale factors. As a result, the 
physical size and position of an object in real world dimensions will change when the Lens Correction file is changed, 
although their position and size in bits will not.

3.3.2.1	 TO CHANGE THE UNITS OF MEASURE

XX From the Main Menu, select View. The View menu appears.

XX The current units are indicated with a dot to the left of the units. Select the desired units.
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3.3.2.2	 TO CHANGE THE UNITS DISPLAY ACCURACY

XX From the Main Menu, select System > Preferences
XX Click the Workspace tab. The Workspace page appears

The Workspace settings page

A Select the units used throughout the interface
B Select the number of decimal places used when displaying inches
C Select the number of decimal places used when displaying millimeters
D Select the number of decimal places used when displaying degrees
E Select the offset applied to an object when the keyboard nudge feature is used
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3.3.2.3	 THE TOP TOOLBAR

The Top Toolbar consists of shortcuts to often used functions, menus and other tools used to edit a Job. Place the 
cursor on a tool in the Toolbar to display the function of that tool in a hint window. The Top Toolbar location is below 
the Main menu. 

Button Function

Add a new job to the workspace

Open a job file

Save the current job

Save the current job with a new name

Print the current job

Cut the current selection to the Clipboard

Copy the current selection to the Clipboard

Paste the current selection from the Clipboard

Delete the current selection

Undo the last action

Import a file

Export a graphic image to a PLT or WLO file

Minimize laser power

Control Guide laser

Open QuickMark window

Open Run Process window

Open Globals toolbox

Apply Bold attribute to the selected text

Apply Italics attribute to the selected text

Left justify the selected paragraph text

Center justify the selected paragraph text

Right justify the selected paragraph text

Change user access level
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3.3.2.4	 THE LEFT TOOLBAR

The Left Toolbar consists of shortcuts to add objects to the job and often used drawing functions. Place the cursor on 
a tool in the Toolbar to display the function of that tool in a hint window. The Left Toolbar location is down the left side 
of the screen. 

Button Function

Arrow pointer

Zoom in tool

Zoom out tool

Show full workspace

New Line

New rectangle

New Rounded Rectangle

New Polygon

New Text

New Barcode

New Automation

New Point array

Show Guidelines

Snap to Guidelines

Show Grid

Snap to Grid

Open Alignment tool

Open Dimension tool
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3.3.2.5	 TO DISPLAY THE RULERS

The Rulers display on the top and left sides of the work area and visually indicate the physical size of the marking 
area. Change the ruler settings to Millimeters, Inches or Bits by selecting the Display Units of Measure. See "Setting 
the Units of Measure". By default, the rulers are displayed.

XX Select View > Rulers. The rulers appear or disappear around the work area.

CUSTOMIZING THE TOOLS MENU ITEM

cabLase Editor 5 provides the ability to customize a special Tools menu by adding menu items that start external 
programs.

3.3.2.6	 TO ADD A PROGRAM TO THE TOOLS MENU

XX From the Main Menu, select Tools > Configure Tools. The Configure Tools window appears.

The Configure Tools window

A Display the list of available configured programs
B Opens the Add tool window to add a new program to the list
C Removes a program from the list
D Opens the Edit tool window
E Moves the programs up or down in the tools list with the Arrow buttons

XX Click the Add button. The Edit Tool window appears.

The Edit Tools window

A The name of the program as displayed in the Tools menu
B The path to the executable file that will run when the tool item is selected in the Tools menu
C Optional command line switch parameters. Consult the documentation for the program to be run to see if 

there are any parameters required.
D Opens the Browse dialog to locate the executable file to run
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Tip!
The ellipsis (...) is usually added to the end of a menu item to indicate to the user that further action is 
required after the menu item is selected.

3.3.2.7	 TO EDIT AN EXISTING TOOL

XX From the Main menu, select Tools > Configure Tools. The configure Tools window appears.
XX In the Tools list, select the tool to edit and click the Edit button. The Edit Tool window appears.

3.3.2.8	 TO DELETE A TOOL

XX From the Main menu, select Tools > Configure Tools. The configure Tools window appears.
XX In the Tools list, select the tool to delete and click the Delete button. The tool is removed from the list.

3.3.2.9	 THE OPEN JOB TAB

The open Job Tabs control provides a visual indication of the currently loaded Jobs and the Active Job.

The open Job Tabs control, showing the Active Job is Job1.wlj

3.3.2.10	LASER SYSTEM VIEWER

The Laser System Viewer shows the local area network and any LEC-2 devices detected on that network. Open jobs 
are displayed in the Viewer as either assigned to the Offline configuration, or assigned to an LEC-2 device.

The Laser System Viewer

A The Local Area Network connection
B A detected LEC-2 device
C Jobs assigned to an LEC-2 device
D Close button
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3.3.2.11	OBJECT MANAGER

The Object Manager displays the Job Entities that are contained in the current job. The objects are listed in the order 
in which they will mark/process. If more than one object appears in the Object list, the up and down blue arrows (at 
the bottom of the Object Panel) become enabled. Use these buttons to move objects up and down relative to each 
other in the list. The number of objects within a Job is displayed to the right of the Objects title. A particular object can 
be selected by entering the object Index in the Index box. Use the Mark object and Mark fill check boxes to toggle 
the outline marking and fill marking feature. Objects can also be selected and grouped from the Object list. See 
"Managing Job Entities" on page 86 for more details.

The Object Manager

A Object title with number of objects in parentheses
B Objects contained in the job (three shown)
C Index of the selected object within the job
D Select this option to enable marking the outline of the object
E Select this option to mark fill (only available if fill has been enabled. See "Fill (Hatching)" on page 128)
F Close button
G Up / Down arrows used to move an object within the list

i
Note!
To display or hide the Object Manager:

XX Select View > Object Manager. The Object Manager appears or disappears at the left side of the work area.
XX Clicking on the Close button in the upper right corner of the Object Manager will also close the Object Manager.
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3.3.2.12	PROFILES PANEL

The Profile Manager displays a hierarchical view of the Profiles the user has saved. These Profiles can be organized 
into groups of folders and applied to marking objects in the Job. Profiles can be added to objects or groups of objects 
from within the Profile Manager by right clicking on the Profile and selecting the desired item from the popup context 
menu. Profiles can be viewed and edited by double clicking on the specific Profile. See "Profiles" on page 96 for more 
information.

The Profiles Panel

A Click to add a profile to the Profile library
B Click to organize the profiles in the library
C A profile folder
D Individual profiles contained in a folder
E The Default profile, which is applied to all new objects when they are first created. See "The Default Profile" 

on page 96
F Close button

i
Note!
To display or hide the Profile Manager:

XX Select View > Profile Manager. The Profile Manager appears or disappears at the right side of the work area.
XX Clicking on the Close button in the upper right corner of the Profile Manager will also close the Profile Manager.
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3.3.2.13	MOTION MANAGER

The Motion Manager provides a tool for direct control of installed motion devices. See "Using the Motion Manager" on 
page 107 for more information.

The Motion Manager

A Motion Configuration
B Control panel
C Control buttons
D Close button
E Settings button

i
Note!
To display or hide the Motion Manager:

XX Select View > Motion Manager. The Motion Manager appears or disappears at the right side of the work area.
XX Clicking on the Close button in the upper right corner of the Motion Manager will also close the Motion Manager.
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3.3.2.14	OPERATOR INTERFACE

The Operator Interface is intended for use in applications where the operator is restricted from making any changes 
to the Job. The Operator Interface provides the minimum controls necessary to execute pre-saved Jobs and to close 
the application. When configured in the User Access settings, the Operator Interface becomes available.

TO SWITCH TO OPERATOR INTERFACE MODE

XX From the Main menu, select System > Security > User Access. The Access Levels window appears.
XX Click the Operator Interface only radio button
XX Click the OK button. The screen switches to Operator Interface mode.

The Operator Interface

A Limited Main menu
B Limited Toolbar

i
Note!
To switch to the Job Editor Workspace:

XX From the Main menu, select System > Security > User Access. The Access Levels window appears.
XX Select the All editing functions radio button, then click OK
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3.3.2.15	TOUCHSCREEN INTERFACE

The Touch Screen Interface is intended for use in applications where the operator is restricted from making any 
changes to the Job. The Touch Screen Interface provides the minimum controls necessary to execute pre-saved Jobs 
and close the application. The design of the touch Screen Interface facilitates using a Touch Screen display panel, 
although a mouse driven interface is also possible. When configured in the User Access settings, the Touch Screen 
Interface becomes available.

i Note!
This feature is available only, if a Hardlock key is installed.

TO SWITCH TO TOUCH SCREEN INTERFACE MODE

XX From the Main menu, select System > Security > User Access. The Access Levels window appears.
XX Click the Touch Screen Interface radio button
XX Click the OK button. The screen switches to the Touch Screen mode

The Touchscreen Interface

A Loads a Job from the Touchscreen Job folder location. See "To edit the Default Open and Save behavior" on 
page 82. Jobs are loaded by clicking on the drop down list and selecting an available Job.

B Starts execution of the loaded Job. Clicking this button is equivalent to selecting Job > Run from the Main 
Menu and then clicking the Go button in the Run Process dialog

C Displays the objects within the Job in relation to the mark field
D Immediately stops execution of the running Job
E Displays the status of Interlocks 1 through 4. These interlock panels can be customized to display 

customized strings to represent each interlock port. See "To configure the Interlocks" on page 69
F Shut down Windows directly with this button
G Click this button to see a secondary menu which has selections for Global settings and to return to the full 

editing interface.
H Display an on-screen keyboard
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TO SWITCH TO THE JOB EDITOR WORKSPACE

XX Click the Options button. The Options window appears.

XX Click the Full Access button. The full access interface is restored. If a password is set, the system will prompt for 
the password.

XX Enter the password and click OK
XX The full access interface is restored
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3.4	 SECURITY SETTINGS

To control access to user interface elements as well as Job editing functions, cabLase Editor 5 has fully integrated 
password protection available. System Security involves working with:

•	 Permissions

•	 Login levels

•	 Passwords

•	 User interface access levels

3.4.1	 TO CHANGE THE DEFAULT LANGUAGE

cabLase Editor 5 offers four levels of permissions:

•	 Administrator

•	 Technician

•	 User

•	 No password required

Every individual function within cabLase Editor 5 can be assigned a Permission Level and each Permission Level can 
be assigned a unique password. These assignments are done through an initialization file.

3.4.1.1	 WORKING WITH THE PERMISSIONS FILE

cabLase Editor 5 uses an external file to configure the Permission levels for all protected tasks. This file can be found 
in the \marker\bin folder. The file is named permissions.ini. The following is a partial representation of the file loaded 
into notepad for editing.

The permissions.ini file

Each line in the file represents a specific task description followed by the Permission Level to assign this task.
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The Permission Levels are defined as follows:

•	 0 = No password required

•	 1 = User password required

•	 2 = Technician password required

•	 3 = Administrator password required

For example, in the first line from the example above, SYSTEM_PREFERENCES=2, in order to make System 
Preference changes, the user has to know the Technician password to complete the task.

3.4.1.2	 TO CHANGE PERMISSION LEVELS

XX Locate and open the permissions.ini file in a text editor such as notepad
XX Change the assigned permission after the equals (=) sign using the Permission Levels defined above

!
Warning!
Do not delete or add lines to the file. ONLY make a change to the Permission Level after the equals (=) 
sign. If the file is not in the correct format, cabLase Editor 5 will ignore All Permission Levels and use No 
Password Required.

USING THE LOGIN LEVEL

cabLase Editor 5 supports the concept of a current Login Level. The Login Level allows a user to set the current 
Permission Level within cabLase Editor 5, so that any tasks that require the current Login Level or below will be 
granted permission to execute the task without prompting for a password. Permissions are granted using the 
following rules:

•	 When the user attempts to execute a protected task, a permission check is performed

•	 The Permission Level for that particular task is determined from the initialization file

•	 If the Permission Level is less than or equal to the current Login Level, permission is granted without prompting 
for a password

•	 If the task requires a higher Permission Level than the current Login Level, a password challenge for the higher 
Permission Level is displayed. If there is no password set for the higher Permission Level, permission is granted 
without prompting for a password.

3.4.1.3	 TO CHANGE THE CURRENT LOGIN LEVEL

XX From the menu bar, select System > Security > Login Level. The Login Level menu appears.

XX The current Login Level is checked
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XX Select the new Login. If necessary, the password challenge window appears.

XX Enter the correct password and click OK. The current Login Level has been changed.

CHANGING AND DELETING PASSWORDS

There are three unique passwords that correspond to the three Permission Levels within cabLase Editor 5.

3.4.1.4	 TO CHANGE A PASSWORD

XX From the menu bar, select System > Security > Change Password. The Change Password menu appears.
XX Select the desired Permission Level password to set. The Change Password window appears.

XX From the New password field, type in the new password
XX From the Confirm password field, type in the same password as typed for the new password
XX Click OK. The Change Password window closes and a password for the selected Permission Level is now 

enabled.

3.4.1.5	 TO DELETE A PASSWORD

XX From the menu bar, select System > Security > Change Password. The Change Password menu appears.
XX Select the desired Permission Level password to delete. The Change Password window appears.
XX From the New password field, delete the password from the edit box so that it is blank
XX Click OK. The password is deleted and password protection is disabled for the selected Permission Level.
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ASSIGNING USER ACCESS

To control access to user interface elements as well as Job editing functions during the current session, cabLase 
Editor 5 supports the concept of Access modes. Note that Access modes override specific permission levels on tasks. 
For example, operator mode does not allow editing of a Job, no matter what the Permission Levels are for those Job 
editing tasks. 

The following Access modes are available:

•	 Full access where all operations are available to the User

•	 Operator interface only is for Users that are only allowed to load Jobs, run Jobs and close the application

•	 Touch screen is a large button format screen displayed and is ideal for use with a touch screen, although a mouse 
can be used with this interface as well

i Note!
Access modes override specific permission levels on tasks.

3.4.1.6	 TO ASSIGN USER ACCESS

XX From the menu bar, select System > Security > User Access. The Access Levels window displays the access 
levels available.

XX Enable the desired user access level. By default, the user has all editing functions available.
XX Click OK to close the window
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3.4.2	 CONTROLLING ACCESS LEVEL AT STARTUP

Using the Startup Options menu item, you can control what Access Level cabLase Editor 5 will initialize in. This 
Access Level is not dependent on the current access level when cabLase Editor 5 is closed. 

The following Startup Access modes are available:

•	 Full access where all operations are available to the User

•	 Operator interface only is for Users that are only allowed to load Jobs, run Jobs and close the application

•	 Touch screen is a large button format screen displayed and is ideal for use with a touch screen, although a mouse 
can be used with this interface as well

	 TO CONTROL THE STARTUP ACCESS MODE

XX From the menu bar, select System > Security > Startup Options. The Startup Options window displays the 
available options.

XX Select the desired startup access level
XX Click OK to close the window

The next time cabLase Editor starts, it will use the selected access mode.
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The LEC-2, in conjunction with cabLase Editor 5, controls a laser system's galvanometer motors, accurately 
positioning deflection mirrors affixed to these motors in synchronization with laser control signals. The motion 
sequence, the operation speed/s, the laser power used and any synchronization with external ancillary equipment is 
determined by marking jobs created and formatted by cabLase Editor 5. This chapter covers the basics of using an 
LEC-2 controller card and includes:

•	 Connectivity options, which configure the cabLase Editor 5 software and an LEC-2 controller card, so they may 
communicate with each other

•	 A section on Laser, Lens and Motion settings, which are configuration files that contain the necessary information 
for the LEC-2 to interface with lasers, scan heads and motion systems

•	 A section on configuring the LEC-2 for Stand-Alone Mode operation, where jobs created and edited in cabLase 
Editor 5 are saved on the LEC-2. At run-time these jobs can be executed directly on the LEC-2 without using 
cabLase Editor 5.

4.1	 CONNECTIVITY OPTIONS

In order for cabLase Editor 5 to correctly detect and connect to available LEC-2 devices, cabLase Editor 5, the 
local PC and the LEC-2 device must be configured correctly. Also, a valid hardlock license key must be installed 
on the local PC. If no hardlock key is detected, the Laser System Viewer will be disabled, as shown in the following 
screenshot.

Detection disabled - no hardlock key detected

The LEC-2 is designed to constantly broadcast its Device name and MAC address on the connected network. That 
network could be a Local Area Network, or a PC directly connected to the LEC-2 controller card. When cabLase 
Editor 5 detects a broadcast from an LEC-2 controller card, it displays the available LEC-2, as an icon with Device 
name (MAC address), in the Laser System Viewer.

An available LEC-2 device

Things to consider when configuring for communication:

•	 Assigning a unique Device name to each LEC-2 on a local area network to make it easier to identify LEC-2 device 
in the Laser System Viewer

•	 The IP Addressing scheme, which determines whether the connected resources will have fixed IP addresses, or 
be assigned an IP address dynamically (DHCP)

•	 Connecting the PC to the LEC-2 with a Direct connection

•	 Connecting the PC and the LEC-2 to a Local Area Network

•	 Selecting the default Network Adapter in cabLase Editor 5
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4.1.1	 DEVICE NAME

The device name is displayed throughout cabLase Editor 5 to represent an LEC-2 controller card on the network. The 
MAC address of the device is appended to the device name to create a unique identifier (two devices could have the 
same device name).

TO CHANGE THE DEVICE NAME

i Note!
There must be an active connection to an LEC-2 device. Renaming an LEC-2 will require the LEC-2 to be restarted.

XX In the Laser System Viewer, right-click on a connected LEC-2 controller card and select Settings
XX Click the Network tab

XX In the Name field, enter the desired device name and click OK
XX The Restart dialog is displayed. Click Yes to continue

XX The new device name appears in the Laser System Viewer
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4.1.2	 IP ADDRESSING SCHEME

The LEC-2 controller card has the option of configuring a static IP address, or contacting a DHCP server to get an IP 
address when the LEC-2 controller card powers up.

XX In Fixed IP Address Mode, care must be taken to use unique IP addresses. This is usually not an issue when 
directly connecting the PC to an LEc-2, but when connecting to a LAN, there may be many devices on the same 
network, and all must have a unique IP address.

XX Dynamic (DHCP) IP Address Mode is the most common approach and insures no two resources on the network 
have the same IP address. This mode will create a lengthy power up sequence however, if the PC and the LEC-2 
controller card are directly connected.

TO MAKE CHANGES TO THE LEC-2 IP ADDRESS SETTINGS

!
Warning!
Select the IP address carefully, as an incorrect address may render the LEC-2 unavailable without changing 
the PC IP settings.

XX In the Laser System Viewer, right-click on a connected LEC-2 device and select Settings
XX Click the Network tab

The IP address settings page

A

Select the IP Adress Mode
•	 Address Type: Manual - The LEC-2 can be configured with a fixed (static IP address)
•	 Address Type: Assigned by DHCP - The LEC-2 can be configured to request an IP address from a DHCP 

server
B The IP address to use when in Manual (Static) mode
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4.1.3	 CONFIGURING A DIRECT CONNECTION

The direct connection is the most simple - a CAT5 cable is used to connect the Ethernet connector on the PC with the 
Ethernet input on the LEC-2. The behavior of a direct connection depends on the IP addressing scheme.

When 
configured for 
DHCP ...

Since there is no DHCP server available to assign an IP address, both the PC and the LEC-2 
will wait up to 90 seconds, then assign themselves an Automatic Private Network address in the 
range 169.254.xxx.xxx

When 
configured 
for Static IP 
Addressing ...

The LEC-2 will immediately be available for connection to cabLase Editor 5

4.1.4	 CONNECTING THROUGH A LOCAL AREA NETWORK

When using a Local Area Network, both the PC and the LEC-2 are connected to the LAN.

When 
configured for 
DHCP ...

Since there is no DHCP server available to assign an IP address, both the PC and the LEC-2 
will wait up to 90 seconds, then assign themselves an Automatic Private Network address in the 
range 169.254.xxx.xxx

When 
configured 
for Static IP 
Addressing ...

The LEC-2 will immediately be available for connection to cabLase Editor 5

4.1.5	 SELECTING THE DEFAULT NETWORK ADAPTER

cabLase Editor 5 supports multiple network cards (NICs) installed in the local PC. Only one NIC can be used, 
however, to detect and connect with LEC-2 controller cards.

TO SELECT THE DEFAULT NETWORK ADAPTER

XX From the Main menu, select Connections > Manage ...
XX Click the Network adapters tab

XX Select the appropriate network adapter from the list and click Set as Default
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4.1.6	 MAKING A CONNECTION

Before cabLase Editor 5 can interact with the LEC-2, a connection must be made to the device. Once one instance 
of cabLase Editor 5 is connected to an LEC-2, other instances of cabLase Editor 5 are prevented from connecting. 
In order for a connection to be made, both the PC and the LEC-2 device should be on the same subnet. If cabLase 
Editor 5 detects that the PC and the LEC-2 device are on incompatible subnets. cabLase Editor 5 has the ability to 
add a temporary IP address to the local PC to allow connection to the LEC-2 device. This feature can be configured 
to happen automatically. Once the PC is rebooted, this temporary IP address is deleted.

To automatically add an IP address to the PC when incompatible subnets are detected

XX From the Main menu, select Connections > Manage ...
XX Click the Network adapters tab

XX Select the "Add a new temporary IP address automatically on subnet mismatch" option to automatically add a 
compatible IP address to the default PC network adapter

4.1.6.1	 CONNECTING MANUALLY

To connect to an LEC-2 controller
XX In the Laser System Viewer, right-click on an available LEC-2 controller card and click "Connect"
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XX If the PC and the LEC-2 are on different subnets, and the feature to automatically add a new IP address is 
disabled (see "To automatically add an IP address to the PC when incompatible subnets are detected"), the 
following message will appear:

XX If this dialog appears, click Yes to continue
XX If there are no Automatic connections configured, the following dialog appears:

XX If you want cabLase Editor 5 to automatically connect tot eh LEC-2 when it becomes available (see "Connecting 
automatically"), click Yes, otherwise click No

XX When cabLase Editor 5 connects to an LEC-2, configuration files are downloaded from the LEC-2 to the local PC. 
The Pending connections Viewer shows the progress of this process.

XX When the connection process is complete, the LEC-2 controller card turns blue to indicate it is actively connected
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4.1.6.2	 CONNECTING AUTOMATICALLY

In single device installations, where there is only one LEC-2 based system available, it may be more convenient to 
configure cabLase Editor 5 to connect automatically to the LEC-2 controller card.

To configure Automatic Connections

XX From the Main menu, select Connections  > Manage ...
XX Click the Laser Systems tab

XX Select the device to automatically connect to from the Laser System name list and click the Add >>> button
XX To remove an automatic connection, select it in the Automatic connections list and click the Remove button
XX Select Yes to continue

4.1.6.3	 CLOSING AN ACTIVE CONNECTION

To close an active connection

XX In the Laser System Viewer, right-click on the LEC-2 controller card that is currently connected and then click 
Disconnect
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4.1.6.4	 UNDERSTANDING THE LEC-2 STATUS ICONS

cabLase Editor 5 uses different icons in the Laser System Viewer to indicate the status of an LEC-2 controller card.

Button Function

Connected to this instance of cabLase Editor 5

Available

Invalid Firmware or License

Connected to another client or in local mode

PC software is incompatible

Not available or not found

Busy or disconnecting

Connecting

Paused

Caching jobs

In Local I/O mode

4.1.6.5	 CHECKING THE CONNECTION STATUS

The status of an LEC-2 can be checked at any time by hovering the mouse over the LEC-2 and waiting for a hint to 
appear.

To check the LEC-2 status

XX In the Laser System Viewer, place the mouse (hover) over an LEC-2
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4.2	 CHOOSING LASER, LENS AND MOTION SETTINGS

cabLase Editor 5 supports two hardware configurations:

•	 The Offline configuration mode which provides the necessary laser, lens and motion information to cabLase Editor 
5 when there is no connection to an LEC-2 controller

•	 The Active configuration mode in which cabLase Editor 5 applies the current laser, lens and motion settings from 
the currently active LEC-2 controller

4.2.1	 UNDERSTANDING HOW cabLase Editor 5 USES LASER, LENS AND MOTION SETTINGS

The LEC-2 controller board can function as a stand-alone capable embedded controller, and so hardware settings 
and parameters specific to laser, lens and motion control are stored in configuration files in the LEC-2 flash memory. 
These files are copied to the LEC-2 flash memory when the user selects the appropriate configuration files in the 
cabLase Editor 5 hardware manager.

During the Job editing process, information is needed from these configuration files in order to calculate and display 
properties such as speeds, distances and other related parameters in cabLase Editor 5.

When a connection is made to the LEC-2, these configuration files are downloaded onto the local PC for use by 
cabLase Editor 5. See "Making a Connection" on page 47. When a Job is assigned to the LEC-2 device (see 
"Assigning a Job to an LEC-2 device"), the Job uses the configuration files that were downloaded to the local PC. 
This allows any instance of cabLase Editor 5 to connect to any LEC-2 and have all the information it needs for Job 
editing. This is known as the Active configuration mode.

There are times, however, when an active connection to an LEC-2 controller is not possible, or desirable. For these 
situation, cabLase Editor 5 has an Offline configuration mode.

!
Warning!
When editing Jobs in Offline configuration mode, make sure the laser, lens and motion profiles are the same 
as on the target LEC-2, or unexpected behavior will result.
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4.2.2	 TO SELECT AN OFFLINE LASER DRIVER FILE

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Open the Offline folder and select the Laser item under the Offline folder. The laser properties will update the 
properties panel.

XX Click the Change button. The Select Laser Driver window appears.

XX Select the desired Laser Configuration file from the list and click OK
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4.2.3	 TO COPY A LASER DRIVER FILE FROM THE PC TO THE LEC-2

There must be an active connection to an LEC-2 device.

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Locate the LEC-2 to assign the laser to in the tree view. Click on the laser name under this LEC-2. The laser 
properties will appear in the properties panel.

XX Click the Change button. The Select Laser Driver window appears.

XX From the drop down box, select Show Laser drivers in the PC library
XX Select the desired Laser Driver file from the list. The currently active driver has (active) appended to the driver 

name.
XX To automatically set the laser driver used in the Offline Configuration to the new selection, check Also apply to 

Offline configuration
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4.2.4	 TO SELECT A LASER DRIVER FILE ALREADY INSTALLED ON THE LEC-2

There must be an active connection to an LEC-2 device.

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Locate the LEC-2 to change in the tree view. Click on the laser name under this LEC-2. The laser properties will 
appear in the properties panel.

XX Click the Change button. The Select Laser Driver window appears.

XX From the drop down box, select Show Laser Drivers installed on the Laser System
XX Select the desired Laser Configuration file from the list and click OK
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4.2.5	 TO ADD A NEW LASER DRIVER FILE TO cabLase Editor 5

See “To add a new Laser Driver file” on page 233.

4.2.5.1	 TO SELECT AN OFFLINE LENS CORRECTION FILE

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Open the Offline folder and select the Lens item under the Offline folder. The lens properties appear in the 
properties panel

XX Click the Change button. The Select Correction File window appears.

XX Select the new correction file
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4.2.6	 TO COPY A LENS CORRECTION FILE FROM THE PC TO THE LEC-2

There must be an active connection to an LEC-2 device.

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Locate the LEC-2 to copy the lens to in the tree view. Click on the lens name under this LEC-2. The lens 
properties appear in the properties panel.

XX Click the Change button. The Select Correction File window appears.

XX From the drop down box, select Show Correction Files in the PC library
XX Select the new correction file
XX To automatically set the correction file used in the Offline Configuration to the new selection, check Also apply to 

Offline configuration
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4.2.7	 TO SELECT A LENS CORRECTION FILE ALREADY INSTALLED ON THE LEC-2

There must be an active connection to an LEC-2 device.

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Locate the LEC-2 in the tree view. Click on the lens name under this LEC-2. The lens properties appear in the 
properties panel

XX Click the Change button. The Select Correction File window appears.

XX From the drop down box, select Show Correction Files installed on the Laser System
XX Select the new correction file
XX To automatically set the correction file used in the Offline Configuration to the new selection, check Also apply to 

Offline configuration
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4.2.8	 TO ADD A NEW LENS CORRECTION FILE TO cabLase Editor 5

See “To create a new Lens Correction file using scan head design data” on page 227.

4.2.8.1	 TO SELECT AN OFFLINE MOTION CONFIGURATION FILE

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Open the Offline folder and select the Motion item under the Offline folder. The motion properties appear in the 
properties panel.

XX Click the Change button. The Select Motion Configuration window appears.

XX Select the new motion configuration from the list and click OK
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4.2.9	 TO COPY A MOTION CONFIGURATION FILE FROM THE PC TO THE LEC-2

There must be an active connection to an LEC-2 device.

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Locate the LEC-2 to copy the motion configuration to in the tree view. Click on the motion configuration under this 
LEC-2. The motion properties appear in the properties panel.

XX Click the Change button. The Select Motion Configuration window appears

XX From the drop down box, select Show Motion Configurations in the PC library
XX Select the new configuration file
XX To automatically set the configuration file used in the Offline Configuration to the new selection, check Also apply 

to Offline configuration
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4.2.10	 TO SELECT A MOTION CONFIGURATION FILE ALREADY INSTALLED ON THE LEC-2

There must be an active connection to an LEC-2 device.

XX From the Main menu, select System > Preferences
XX Click on the Hardware tab. The Hardware page appears.

XX Locate the LEC-2 in the tree view. Click on the motion configuration under this LEC-2. The motion properties 
appear in the properties panel.

XX Click the Change button. The Select Motion Configuration window appears

XX From the drop down box, select Show Motion Configurations installed on the Laser System
XX Select the new configuration file and click OK

4.2.11	 TO CREATE A NEW MOTION CONFIGURATION

See "To create a new Motion Configuration" on page 250.
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4.3	 CONTROLLING THE LEC-2 REMOTELY

The LEC-2 supports the ability to execute jobs without the need for a PC. This capability is referred to as Stand-Alone 
mode. For performance reasons, some features, such as Mark on the Fly, are only available in Stand-Alone mode. To 
configure Jobs and the LEC-2 for Stand-Alone operation, consider the following:

•	 Some mark object properties and some job automation properties need to be correctly configured for use in 
Stand-Alone mode. See “Stand-Alone Job Considerations” on page 85 for more information.

•	 An LEC Binary job file must be saved in the LEC-2 flash or on a connect USB flash drive. See “Saving Jobs” on 
page 78.

•	 If an LEC Binary Job file references an embedded Laser Font, that font must be in the Fonts folder of the LEC-2 
device. See “Adding a new Laser font to cabLase Editor 5” on page 106 and “Managing Job Entities” on page 86 
for more information.

cabLase Editor 5 provides the following features to configure the LEC-2 for Stand-Alone mode operation:

•	 A file Browser, which explores the on-board flash and connected USB flash drives

•	 Settings for I/O Job Selection, which provides a means to load selected Jobs and execute them with simple 
discrete I/O

•	 Settings for Mark on the Fly, which provides for marking on moving parts.

•	 An Interactive tool, which allows communication with an LEC-2 using the Remote API from within cabLase Editor 
5. See “To use the Interactive tool”.

•	 A Run Job Remotely tool, which allows “remote control” of an LEC-2 running a Stand-Alone job from within 
cabLase Editor 5. See “Running Stand-Alone Jobs” on page 221.

Running Stand-Alone Jobs with cabLase Editor 5

cabLase Editor 5 provides the capability to interact with the LEC-2 and run Stand-Alone Jobs from within the cabLase 
Editor 5 user interface. See “Running Stand-Alone Jobs” on page 221.

4.3.1	 MANAGING FILES ON THE LEC-2

cabLase Editor 5 provides tools for browsing files that are stored on an LEC-2 or on a connected USB drive. These 
files can be of type:

•	 Lec Binary Job files, which have been saved to the LEC-2 and are used when the LEC-2 is executing in Stand-
Alone mode

•	 Laser Font files, which are used by mark objects in Stand-Alone mode
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To open the LEC-2 file browser

There must be an active connection to an LEC-2 device

XX In the Laser System viewer, right-click on a connected LEC-2 device and select Explore...
XX From the Look in drop down, select Internal Flash memory or External USB stick

The LEC-2 device Explorer

A

Select the location on the LEC-2 to explore

•	 Internal flash memory - The integrated memory on the LEC-2 for storing jobs

•	 External USB stick - Storage available on an installed USB stick

•	 Fonts - The font library stored on internal flash memory
B The amount of available storage on the current location
C Files found in the current location
D When copying jobs or fonts to the LEC-2, select this option to overwrite a file with the same name
E Add a new file to the current location
F Copy a file from the current location to a folder on the PC
G Rename the selected file
H Delete the selected file
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4.3.2	 I/O JOB SELECTION

It is possible to select and execute an available locally saved job by using I/O bit combinations. In order for the LEC-2 
to respond to I/O in this manner, the board must be in I/O Job Selection mode. When in this mode, a maximum of 
eight user programmable I/O Selection inputs are used to select the pre-configured job. The actual inputs scanned 
by the LEC-2 depend on whether the optional Extended I/O module is installed. See “The Start Mark input is used to 
start the marking process.” for more details. In order to enable I/O Job Selection, please note the following:

•	 The LEC-2 controller must be in I/O Job Selection Mode

•	 Jobs stored locally on the LEC-2 must be assigned to I/O Selection bit combinations

•	 The appropriate I/O Selection inputs must be set to indicate which job to load/enable

•	 The Job Select input must be used to trigger the loading/enabling of a job

•	 After the Job Select input is triggered, the Ready output is used to signal that the job is loaded/enabled

•	 The Start Mark input is used to start the marking process

I/ Selection
bit mapping

Extended I/O
option not installed

Extended I/O
option installed

00000001 (1) User In 1 User In 5

00000010 (2) User In 2 User In 6

00000100 (3) User In 3 User In 7

00001000 (4) User In 4 User In 8

00010000 (5) N/A User In 9

00100000 (6) N/A User In 10

01000000 (7) N/A User In 11

10000000 (8) N/A User In 12

Mapping Table
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4.3.2.1	 CONTROLLING I/O JOB SELECTION MODE

XX In the Laser System Viewer, right-click on an available LEC-2 controller and click Settings. The Laser System 
Settings window appears.

!
Warning!
If the LEC-2 is already in I/O Job Selection mode, opening the Settings dialog will abort any job that is currently 
active.

The following message is displayed to warn the user:

XX Click the Job Selection tab. The Job Selection page appears.

The Job Selection page

A Select this option to enable or disable I/O Job Selection. When checked and after the OK button is pressed, 
the LEC-2 card will be immediately put into I/O Job Selection mode.

B

Loading of jobs can be accomplished in one of two ways. (1) In cache mode, all the jobs in the Job 
assignment list are loaded either at boot time, or when the board is first placed in I/O Job Selection mode. 
Later, the Job Select bit is used to quickly switch between the previously loaded jobs. Caching the jobs in 
memory is preferable if fast switching times between jobs is desired. However, the time to cache all the jobs 
in the job assignment list may be lengthy(2) If jobs are not cached, each job is loaded when the Job Select 
bit is set HIGH and the appropriate selection bits are set. This mode is desirable when the job files are very 
large, and would consume the local RAM if they were all loaded in memory at the same time. Because the job 
is loaded when the Job Select bit is set, the process controller must wait for the job to load before executing 
the job.

C
Select the location of the jobs
•	 Internal flash memory - The integrated memory on the LEC-2 for storing jobs
•	 External USB stick - Storage available on an installed USB stick
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D List of jobs available in the current location
E List of jobs available in the current location
F Insert the selected job at the top of the Job Assignment list

G
The list of job assignments. Use this list to assign available jobs to a specific I/O input bit combination. For 
example, to select the job circle.dat, Bit 2 must be HIGH, and all other Bits must be LOW when the Job Select 
bit is set HIGH.

H Remove the selected job from the Job Assignments list

4.3.2.2	 TO ASSIGN JOBS TO INPUT BIT COMBINATIONS

XX From the Available jobs list, select an available job. Either drag the job into the Job assignment list, or click the 
Insert at top button to add the job to the list.

XX Delete a job from the Job assignment list by selecting the job and clicking the Remove button

I/O Job Selection Timing 

Once the LEC-2 is in I/O Job Selection mode, the LEC-2 periodically scans (every 400 ms, or 10ms in cache mode) 
the status of the Job Select input. When the LEC-2 detects that the Job Select input has transitioned (level detection) 
from GND (LOW) to +5 VDC (HIGH), for at least 400 ms (10 ms in cached mode) it then scans the I/O Selection bits.

•	 If the I/O Selection bits are all at GND (LOW), this state is interpreted as an Abort. If there is a job actively 
executing, it will be aborted, and the system will return to scanning the Job Select input.

•	 If the I/O Selection bits represent a specific bit combination, this state is interpreted as an Enable Job (in cached 
job mode) or Load Job. The Job Assignment list is used to determine which job to activate

•	 If the LEC-2 successfully loaded/enabled a job, the LEC-2 immediately starts waiting for a Start Mark signal. The 
Ready output is switched to +5 VDC (HIGH), indicating that the job was successfully loaded/enabled and the 
LEC-2 waits for Start Mark signal.

•	 	If there was an error in loading the job, the system returns to scanning the Job Select input. The Ready output 
stays at GND (LOW).

•	 	The Job Select bit must be brought to GND (LOW) to allow the LEC-2 to detect the next input transition.

4.3.3	 MARK ON THE FLY

cabLase Editor 5, in combination with the LEC-2, offers marking of moving objects with the Mark on the Fly (MOTF) 
feature. Using Mark on the Fly, moving objects can be marked while they move through the mark field. An RS-422 
encoder input is available, which allows continuous (every 10 µs) corrections to the marking vector list based on the 
part speed. Pulse frequencies of up to 12.5 MHz can be provided to this input from an external encoder. If the appli-
cation does not require such accuracy, a Simulated encoder mode is also available.

To configure the Mark on the Fly settings

XX In the Laser System viewer, right-click on a connected LEC-2 device and select Settings
XX Click the Mark on the Fly tab
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The Mark on the Fly Settings page when using an encoder

A v 1.5 en

B

The speed of the part can be tracked in two ways:
•	 Using an encoder - An encoder, physically linked to the movement of the part, will allow tracking of part 

speed during the mark. This is the most accurate way to mark moving parts.
•	 Simulating an encoder - If an encoder is not available to track the part speed, the controller card can 

“simulate” an encoder by providing internal pulses to the MOTF system. The system will assume a fixed 
part speed during the

C Select the part movement direction relative to the marking field
D The current encoder count. Click the Get Count button to refresh
E Click this button to refresh the Encoder count value

The Mark on the Fly Settings page when in simulated mode

A Enter the actual part speed in mm/s. The system assumes a constant part speed during the marking process
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4.3.4	 CONTROL SIGNAL OPTIONS

cabLase Editor 5 must have an active connection to an LEC-2 controller in order to configure the Control signal 
options. The following control signal settings can be configured:

•	 The Analog servo output voltage range

•	 The Initial states of the User Out signals

•	 The Laser Pipeline delay, which provides a programmable delay between the galvo command stream and the 
laser signals. 

•	 The Interlocks, which are four dedicated interlock inputs when signaled, will Abort an active job, and switch all 
laser signals to their OFF state. 

•	 The COM Port settings and interface assignments.

4.3.4.1	 TO CONFIGURE THE ANALOG SERVO OUTPUTS

XX In the Laser System viewer, right-click on a connected LEC-2 device and select Settings. Click the Outputs Tab 
and then the Analog button

The Analog servo page

A If using analog servo amplifiers directly, the voltage range of the analog outputs can be selected
B If using analog servo amplifiers directly, the voltage range of the analog outputs can be selected
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4.3.4.2	 TO CONFIGURE THE INITIAL USER OUT STATES

XX In the Laser System viewer, right-click on a connected LEC-2 device and select Settings. Click the Outputs Tab 
and then the Digital button.

The Initial User Out settings page

A Check a box to set an output HIGH, and check a box to set an output LOW when the LEC-2 first starts up, or 
after an Abort

B The Pipeline delay sets a fixed delay between the galvo control signals and the laser control signals and is 
used when connecting the LEC-2 to some digital servo amplifier systems

i
Note!
To set the Pipeline Delay:

•	 In the Laser System viewer, right-click on a connected LEC-2 device and select Settings
•	 Click the Outputs Tab
•	 Click the Digital button and enter the desired value in the Pipeline Delay



69 694	 WORKING WITH THE LEC-2

4.3.4.3	 TO CONFIGURE THE INTERLOCKS

XX In the Laser System viewer, right-click on a connected LEC-2 device and select Settings
XX Click the Interlocks Tab
XX Select the “Enable Interlock monitoring” check box

The Interlocks page

A Enable interlock monitoring. This option must be selected in order to monitor the interlock inputs
B Enable monitoring of a specific Interlock. Each interlock can be enabled independently.

C Each interlock can have a description, which will display in the Run Process or QuickMark dialog window, if 
the interlock is signaled

D Select if the interlock will trip on a HIGH or a LOW signal input

When an interlock is tripped, the interlock description is displayed
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4.3.4.4	 TO CONFIGURE THE COM PORTS

XX In the Laser System viewer, right-click on a connected LEC-2 device and select Settings
XX Click the COM ports Tab

The COM ports page

A Select what COM port to use for the Pendant
B Select the Pendant port speed. Default is 19200.
C Select what COM port to use for the Remote API
D Select the Remote API port speed
E Select what COM port to use for the Motion control interface
F Select the Motion port speed
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4.4	 DIAGNOSTIC TOOLS

CabLase Editor 5 provides two diagnostic tools for examining the current settings and I/O port states on the LEC-2. 
They are:

•	 The Properties Window, which displays the current property set

•	 The I/O Diagnostics Tool for working with the hardware inputs and outputs on an LEC-2 device

•	 The Interactive Tool, which provides an means to communicate with an LEC-2 using the Remote API

4.4.1	 TO OPEN THE LEC-2 PROPERTIES WINDOW

XX In the Laser System viewer, right-click an LEC-2 device and select Properties ...
XX The LEC-2 Properties Window appears
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4.4.2	 TO USE THE I/O DIAGNOSTICS TOOL

There must be an active connection to an LEC-2 device.

XX In the Laser System viewer, right-click on a connected LEC-2 device and select I/O Diagnostics ...

The I/O Diagnostics Tool

A The current status of the User In inputs is displayed and updated once per second
B The current status of the Interlock inputs is displayed and updated once per second

C The current status of the User Out outputs is indicated by the state of the pushbuttons. In the screen shot, all 
outputs are currently LOW.

D
Use the pushbuttons to change the state of a specific User Out output. The state of the pushbuttons is 
updated once per second. This option will have no effect if there is no active connection to the LEC-2 device. 
See “Making a Connection” on page 47.

E The current status of the System outputs is displayed and updated once per second

If the optional Extended I/O board is connected, the I/O Diagnostics Tool expands to included the additional I/O.

The I/O Diagnostics Tool expanded to include the Extended I/O ports
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4.4.3	 TO USE THE I/O DIAGNOSTICS TOOL

XX Right-click the LEC-2 device in the Laser System Viewer and select “Interactive..”....

Click the Interactive tab

The Interactive Control window	

A Enter the string to send to the Remote API
B The response sent from the LEC-2 is displayed here
C Select the length of time to wait for a response before triggering a time-out exception
D Click the Send button to send the string to the Remote API
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4.5	 FIRMWARE UPDATES
From time to time, Cab Produkttechnik GmbH & Co KG will release an updated version of the firmware resident on 
the LEC-2 board. This update may be in the form of a single file, or a web link.

!
Warning!
When updating the LEC-2 firmware, all files stored locally on the LEC-2 will be lost. It is highly recom-
mended to back up any job files that have been stored in the flash memory of the LEC-2.

i Note!
After updating the firmware, the LEC-2 board must be automatically (or manually) restarted for changes to 
take effect.

4.5.1	 TO INSTALL AN UPDATE FROM A PROVIDED  UPDATE FILE

XX From the Main menu of cabLase Editor 5, click Tools -> Laser System device software update. The backup 
warning appears.

XX Click Yes and the Browse for Laser System software updates dialog box appears
XX Browse to the provided Update file, select it, and click Open. The Laser System Software Updater appears.

The Laser System Firmware Updater	

A List of LEC-2 devices detected on the local network. Select all the devices to update.

B

On current firmware versions after 1.4.2, the LEC-2 can automatically restart when the firmware update is 
complete. In order for changes to take affect, the LEC-2 must be restarted after an update session. On LEC-2 
devices with current firmware previous to 1.4.2, this checkbox has no effect, and the LEC-2 must be restarted 
manually.

C Click this button to re-scan the network for LEC-2 devices
D After selecting the LEC-2 devices to update, click the Update button to start the process
E The version of the firmware currently on the LEC-2 device

F Indicates whether the update file you have selected is newer, older, or the same version as the version 
currently on the LEC-2 device

XX Select the LEC-2 boards to update, and click the Update button
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The Job, with the entities it contains, form the basis for all interaction with a laser marking system. At job execution 
time, cabLase Editor 5 directs the motion of scanning galvanometers while simultaneously modulating the laser 
beam, based on the graphical images and laser settings contained within the job entities. The laser is turned on when 
a pattern is to be drawn, and off when moving to the beginning of a new pattern location. Entities are placed spatially 
within the marking field, which is defined by a Cartesian coordinate system.

5.1	 SETTING UP THE WORKSPACE

5.1.1	 COORDINATE SYSTEM CONVENTIONS

The marking field is defined using a Cartesian coordinate system that is illustrated in the following figure:

 Scanning system coordinate conventions

The imaging field is addressed using 16-bit integers with a range of -32768 to +32767. These units are referred to 
in the following sections as “bits”. All job coordinates are expressed in these units. When a user desires to represent 
coordinates in other units such as mm, cabLase Editor 5 scales those coordinates appropriately taking into account 
the projection system optics that are involved.
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5.1.2	 CUSTOMIZING THE PAGE SIZE

Use the Page Setup settings to specify a custom field size area. The custom area can be circular or square and must 
be smaller in dimension than the maximum field size allowed by the LEC-2 device. The Page Setup settings are 
saved with the job, so different jobs could have different Page Setup settings.

To modify page setup values

Do one of the following things:

XX From the main menu, select Job > Settings, then click the Page Setup tab
XX 	Double click the Page Setup item in the Job Manager
XX 	The Page Setup Properties window appears

The Page Setup Property page	

A
Select the format:
•	 Display as Rectangle - The marking field is defined and displayed as a rectangular field
•	 Display as Circle - The marking field is defined and displayed as a circular field

B The width of the logical field size. This size must be less than or equal to the maximum available field size 
width as determined by the LEC-2 device

C The height of the logical field size. This size must be less than or equal to the maximum available field size 
height as determined by the LEC-2 device.

D Click this button to use the current settings and apply them when a new job is created
E Apply the maximum field size width and height as determined by the LEC-2 device
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5.2	 JOB HANDLING

5.2.1	 CREATING, OPENING AND CLOSING JOBS

When starting cabLase Editor 5, a new Job is automatically created by default. See “Default Open and Save 
Behavior” to configure how cabLase Editor 5 opens jobs when first starting. New Jobs can also be created or existing 
Jobs can be opened at any time using the File menu or the tool bar buttons once cabLase Editor 5 is running. An 
existing Job appears with its name displayed in the Title Bar above the menu bar, in the Laser System Viewer, and on 
the Active Job tab. cabLase Editor 5 supports a maximum of ten open Jobs at the same time.

5.2.1.1	 TO START A NEW JOB

XX Choose File > New Job or click on the New Job button

Button Function

New Job toolbar button

5.2.1.2	 TO OPEN AN EXISTING JOB

XX Choose File > Open Job… or click on the Open button

Button Function

Open file toolbar button

XX Locate and select the name of the Job to open
XX Click Open. The Title Bar, Job Manager and Active Job tab updates with the Job name
XX When finished with a Job, close it individually or close all open Jobs

5.2.1.3	 TO LOAD AN AVAILABLE JOB IN THE TOUCH SCREEN INTERFACE

XX When running in the Touch Screen Interface, only jobs stored in the Touchscreen Job folder location are available
XX Click in the Job Manager and select the desired Job from the list of available Jobs
XX The Job loads and updates the display screen with the marking objects

5.2.1.4	 TO CLOSE AN EXISTING JOB

XX Choose File > Close Job. The Job is closed

5.2.1.5	 TO CLOSE ALL OPEN JOBS

XX Choose File > Close All Jobs. All the open Jobs are closed, and the cabLase Editor 5 workspace is cleared
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5.2.2	 SAVING JOBS

The job file, with the entities it contains, form the basis for all interaction with a laser marking system. There are two 
types of job files that cabLase Editor 5 supports:

XX PC Job files, which are saved on the local PC or on a network resource. These files have the extension WLJ.
XX LEC binary Job files, which are compiled from a cabLase Editor 5 job, and can be stored on the local PC, directly 

on the LEC-2 or on a USB drive attached directly to the LEC-2. These files have the extension DAT, and are the 
files used by the LEC-2 when it loads a job in Stand-Alone mode.

cabLase Editor 5 provides several ways to save a Job using the File menu or the tool bar buttons:

XX The Save Job command saves the Job with its current name and location. To save the Job for the first time, the 
Save As dialog box appears. Specify the Job name and where to save the Job.

XX The Save Job As command saves the Job with a different name or location

5.2.2.1	 TO SAVE AN EXISTING JOB

XX Choose File > Save Job or click on the Save button. The Job is saved with the same Job name and location

Button Function

Save Job toolbar button

Save Job As toolbar button

Saving Stand-Alone (LEC Binary) Job Files

When creating job files for Stand-Alone operation, there are several ways to store files and move them to the LEC-2 
device.

•	 While connected to an LEC-2 device, directly save an open job to the flash memory of the LEC-2 device

•	 While connected to an LEC-2 device, directly save an open job to USB flash drive which is connected to the 
LEC-2 device 

•	 Save an open job to a USB flash device connected to the PC and later transfer the USB device to the LEC-2

•	 Archive an open file to a hard drive location

Not all object types (Run Application automation objects for example) or special functions within objects (such a 
operator prompts) are supported in Stand-Alone mode. See “Stand-Alone Job Considerations” for more information.



79 795	 JOB EDITING

5.2.2.2	 TO SAVE A STAND-ALONE JOB TO A CONNECTED LEC-2

There must be an active connection to an LEC-2 device, and the Job to save must be assigned to that device.

XX In the Laser System Viewer, right-click on the Job and select “Save to Laser System...”.

XX If the External Start settings have not been configured properly, a warning message will appear. See “To control 
the job with External I/O” on page 213 for configuration options.

XX From the Location drop down list, select “Internal Flash Memory”
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5.2.2.3	 TO SAVE A STAND-ALONE JOB TO A USB FLASH DRIVE CONNECTED TO AN LEC-2

i Note!
When transferring large Job files, it may be faster to save the Job to the USB flash drive while the flash 
drive is plugged into the PC.

There must be an active connection to an LEC-2 device and the Job to save must be assigned to that device. There 
also must be a recognized USB flash device connected to the LEC-2.

XX In the Laser System Viewer, right-click on the Job and select “Save to Laser System...”.

XX If the External Start settings have not been configured properly, a warning message will appear. See “To control 
the job with External I/O” on page 213 for configuration options.

XX From the Location drop down list, select “Internal Flash Memory”
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5.2.2.4	 TO SAVE A STAND-ALONE JOB TO A USB FLASH DRIVE CONNECTED TO A PC

XX From the Main menu, select File > Save Job As... The Save Job dialog appears.
XX In the Save as Type drop down list, select “LEC binary Job files (*.dat)”

XX Browse to the USB flash drive
XX In order for the LEC-2 to find detect Jobs on the USB flash drive, the folder hierarchy must be \LEC\Jobs. Create 

the folder structure on the USB flash drive.

The folder structure for job file storage on a USB flash drive

XX Copy the file into the Jobs folder

5.2.2.5	 TO ARCHIVE A STAND-ALONE JOB

XX From the Main menu, select File > Save Job As... The Save Job dialog appears.
XX In the Save as Type drop down list, select “LEC binary Job files (*.dat)”

XX Browse to the desired hard drive location to save the file

5.2.3	 MOVING JOBS TO A NEW LOCATION

When a Job containing imported graphics is saved, cabLase Editor 5 saves a reference to the imported graphic file in 
it’s original location. If a Job file is moved to another location (a PC or a different network location), the Job will not be 
able to locate the imported graphic file. To make moving Jobs easier, cabLase Editor 5 supports packaging of a Job, 
with all the associated graphic files.

To move a Job and all referenced graphic files to a new location

XX From the Main menu, select File >Save Job Package... The Save Job Package As dialog appears.
XX Browse to the new location and click Save
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5.2.4	 DEFAULT OPEN AND SAVE BEHAVIOR

5.2.4.1	 TO EDIT THE DEFAULT OPEN AND SAVE BEHAVIOR

XX From the Main menu, select System > Preferences. The System Preferences window appears.
XX Click on the Job Files tab. The Job Files page appears.

The Job files page	

A

Select options for job loading when the application starts:
•	 Do not load a job - No job is loaded when the application starts
•	 Load a specific job - A specifically named job can be selected to load when the application starts. Click the 

Browse button to locate the job.
•	 Load a new job - When the application starts, a new, empty job is loaded.
•	 Load the last saved job - When the application starts, the job file that was last saved will be automatically 

loaded.
B The name of the job file, depending on the option selected in A

C
Select this option to automatically save a backup copy of a Job (with a .bak extension) when the Job is 
saved. By default, the Automatic backup is enabled and the save location is c:\marker\backup. To change the 
Automatic back up location, click on the Browse button and select the desired backup location.

D Backup job file folder location

E Location of job files when using the Touchscreen interface. Only jobs located in this folder will be visible in the 
available jobs list in the Touchscreen interface.

F Select this option to automatically display the Job Notes when the Job is loaded from disk
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5.3	 ASSIGNING JOBS TO AN LEC-2 DEVICE

The LEC-2 is a network device,and is intended to be to installed onto a local area network, or connect directly to a 
PC. Multiple LEC-2 devices can be attached to the same network, and cabLase Editor 5 will display all the LEC-2 
devices detected on the local area network. In order for cabLase Editor 5 to know which LEC-2 to communicate with 
when executing jobs, and which laser and lens settings to use, the Job must be “assigned” to an LEC-2 device. When 
a job is not assigned to an LEC-2 device, it is by default assigned to the Offline configuration.

When assigned 
to an LEC-2 
device

The job file will use the laser, lens and motion configuration files that are associated with the 
LEC-2 device. It is also possible to execute the job in streaming mode, and to save the job to the 
LEC-2 device

When assigned 
to the Offline 
configuration

The job file will use the Offline laser, lens and motion configuration files. The job cannot be 
executed because there is no association between the job and an LEC-2 device

5.3.1	 TO ASSIGN A JOB TO AN LEC-2 DEVICE

XX Make the Job to assign Active by selecting it with the Job tab, or selecting it in the Laser System Viewer

The Laser System Viewer showing the Active Job is circle.wlj
Both test.wlj and circle.wlj are assigned to the Offline configuration

XX Right-click the job, and select Assign to:

XX Select the LEC-2 device to assign the job to. The job now appears as a child of the LEC-2 device.

The Laser System Viewer showing circle.wlj is assigned to the Maestro LEC-2 
device and test.wlj is assigned to the Offline configuration
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5.3.2	 TO ASSIGN A JOB TO THE OFFLINE CONFIGURATION

XX Make the Job to assign Active by selecting it with the Job tab, or selecting it in the Laser System Viewer

XX Right-click the job, and select Assign to:

5.3.3	 TO AUTOMATICALLY ASSIGN JOBS TO AN LEC-2 DEVICE

XX From the Main menu, select System > Preferences. The System Preferences window appears.
XX Click on the Job Files tab. The Job Files page appears.

The Job files page	

A Select this option to automatically assign jobs to the default LEC-2 device
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5.4	 STAND-ALONE JOB CONSIDERATIONS

The LEC-2 supports the ability to execute jobs without the need for a PC. This capability is referred to as Stand-Alone 
mode. For performance reasons, some features, such as Mark on the Fly, are only available in Stand-Alone mode. To 
configure Jobs and the LEC-2 for Stand-Alone operation, consider the following:

•	 If changing strings at run-time, some String based object properties need to be correctly configured for use in 
Stand-Alone mode, and some are not available.

•	 The External Start settings need to be configured correctly.

•	 Only Laser Fonts can be used if strings need to be changed at run-time. New Laser fonts can be created for appli-
cations where the look of TrueType style fonts is required. See “Creating a new Laser font” on page 104 for more 
information.

•	 Only symbologies Data Matrix, and Code 128 are currently available if the barcode string needs to be changed at 
run-time.

5.4.1	 CHANGING STRINGS AT RUN-TIME

If the application requires strings contained in Text / Barcode objects to be changed at run time, only the following 
Source > String rules are available:

•	 Use AutoDate - The Text / Barcode object will mark a date code according to the format specified

•	 Serialize with current start value - The Text / Barcode object will mark a serial number using the format specified

•	 Get string from memory buffer - The Text / Barcode object will retrieve the next string from a memory buffer 

•	 Custom string - The Text / Barcode object will build a custom string according to the format specifier

•	 Controlled by Remote API - The string contained in the Text / Barcode object can be modified using the Remote 
API on an Ethernet connection or RS-232 serial port connection.

All other String rules are not applicable to dynamic strings in Stand-Alone mode.

5.4.2	 CONFIGURING EXTERNAL START SETTINGS

Stand-Alone jobs, by definition, are executed on the LEC-2 device. To control the execution of these jobs, an External 
Start signal is usually used to synchronize the start of the next job execution cycle. When a job is saved to the 
Stand-Alone format, cabLase Editor 5 checks the External Start settings to verify that External Start is enabled. It 
may be desirable in some situations not to use an External Start signal, and execute the job only with Remote API 
commands. The External Start settings can be configured to support this requirement.

5.4.2.1	 TO CONFIGURE THE EXTERNAL START SETTINGS

See “To control the job with External I/O” on page 213.
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5.4.2.2	 TO DISABLE EXTERNAL START SETTINGS IN STAND-ALONE MODE

XX From the Main menu, select Job > Settings, then click the External Start tab.
XX The External Start Properties window appears.
XX If the state of the External Start signal is always LOW (default when nothing is connected to the input), from the 

Trigger Mode drop down list, select “If Port is LOW”

XX If the state of the External Start signal is always HIGH, from the Trigger Mode drop down list, select “If Port is 
HIGH”

5.5	 MANAGING JOB ENTITIES

The Job, with the entities it contains, form the basis for all interaction with a laser marking system cabLase Editor 5. 
Add new job entities:

•	 By adding a System Entity

•	 By importing a graphic file

•	 By pasting a graphic from the Windows clipboard into the current job

•	 By pasting a job entity from another cabLase Editor 5 job into the current job

5.5.1	 ADDING A SYSTEM ENTITY

A system entity includes any of the built in mark objects such as Rectangle, Polygon, etc. and any of the Automation 
objects.

Button Function

New Line toolbar button

New Rectangle toolbar button

New Rounded Rectangle toolbar button

New Polygon toolbar button

New Text toolbar button

New Barcode toolbar button

New Automation toolbar button

New Point array toolbar button
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i Note!
To add a System entity to a Job

XX Select Objects > Add and then select the desired object, or click on the Object from the Tool bar. The selected 
object is added to center of the Work area. 

5.5.2	 IMPORTING GRAPHIC FILES

Importing files or objects from other applications into cabLase Editor 5 is easily performed using the File menu or 
the Import button. cabLase Editor 5 can import many file formats, including WLJ (WinLase Job), WLO (WinLase 
Object), PLT (HPGL Plotter File), WMF (Windows Metafile), EMF (Windows Enhanced Metafile), DXF (AutoCAD), 
DWG (AutoCad), EPS (Encapsulated PostScript), BMP (Windows Bitmap), JPG (JPEG Bitmaps), GIF (CompuServe 
Bitmaps), PCX (PaintBrush), JOB (TruView Job), and MCL (TruView Object).

i Note!
When importing a graphic image, cabLase Editor 5 creates a link to the graphic file, which includes the file name 
and its location on disk. When the job containing the object is saved, cabLase Editor 5 saves the link to the object 
in the job file. When the job is reopened, the graphic file must be present at the original location of the link, or the 
graphic will fail to load.

5.5.2.1	 TO IMPORT A FILE

XX Choose File > Import, or click the Import button

Button Function

Import toolbar button

XX Locate and select the file to import.
XX Click Open. The Work Area displays the imported file and the Object List updates with the new object.

5.5.2.2	 TO PASTE A GRAPHIC FROM THE WINDOWS CLIPBOARD

XX Select Edit > Paste Special. If the Clipboard contains more than one type of compatible image format, the Paste 
Special dialog appears.

XX Select the desired graphic format to paste. The following options may be available depending on the contents of 
the Clipboard:

•	 Picture (Metafile) - Graphic is pasted as a vector object. 

•	 Device Independent Bitmap - Graphic is pasted as a bitmap object.

•	 Text - Graphic is pasted as a text object.
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5.5.3	 IMPORTING JOBS

A Job is a collection of objects and system settings that describe a set of actions the laser and connected equipment 
will perform when the Job is run. When a Job is imported, the objects in the imported Job are added to the currently 
open Active Job. This is in contrast to opening a Job, where the opened Job is added to the list of Available Jobs.

5.5.3.1	 TO IMPORT A JOB FILE

XX Select File > Import. Click the Files of type drop down list. The supported Job file formats are displayed. These 
formats are:

•	 	cabLase Editor 5 Job (WLJ) - The cabLase Editor 5 Job file.

•	 	TruView Job (JOB) - A Job file format developed by General Scanning, Inc. and used on its TruView DOS based 
software package.

XX Select the desired Job file type.
XX Locate the file to import and select it.
XX Click Open to close the Import dialog window and import the file.

Cut, Copy and Paste Job Entities

The Cut, Copy and Paste commands are usually used in conjunction with one another to move, or copy an object 
or objects within or between Jobs. cabLase Editor 5 provides several ways to accomplish these tasks using the File 
menu, Tool bar buttons, or the Ctrl+C, Ctrl+X, and Ctrl+V commands.

5.5.3.2	 TO COPY AN OBJECT OR OBJECTS TO THE SAME JOB

XX Select a single object or group of objects.
XX Select Edit > Copy, click the Copy button, or press Ctrl+C

Button Function

Copy toolbar button

XX Click the Paste button, or Select Edit > Paste or press Ctrl+V. The object(s) are added to the Work area.

Button Function

Paste toolbar button

5.5.3.3	 TO COPY AN OBJECT OR OBJECTS TO ANOTHER JOB

XX Select a single object or group of objects.
XX Select Edit > Copy, click the Copy button, or press Ctrl+C

Button Function

Copy toolbar button
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XX Select the target Job by clicking on the Job tab in the Available Jobs tab control, or selecting Job > and clicking on 
the desired Job in the list.

XX Click the Paste button, or Select Edit > Paste or press Ctrl+V. The object(s) are added to the Work area of the 
target Job.

Button Function

Paste toolbar button

5.5.3.4	 TO MOVE AN OBJECT OR OBJECTS TO ANOTHER JOB

XX Select a single object or group of objects.
XX Select Edit > Cut, click the Cut button, or press Ctrl+X. The objects are deleted from the Work area of the current 

Job.

Button Function

Cut toolbar button

XX Select the target Job by clicking on the Job tab in the Available Jobs tab control, or selecting Job > and clicking on 
the desired Job in the list.

XX Click the Paste button, or Select Edit > Paste or press Ctrl+V. The object(s) are added to the Work area of the 
target Job

Button Function

Paste toolbar button

5.5.4	 DELETING OBJECTS

The Delete command removes the selected object. cabLase Editor 5 provides several ways to do this using the File 
menu, Tool bar button, Ctrl+Del command, or right-mouse click after selecting the object.

To delete an object or objects

XX Select the object or objects to delete in the Work area or in the Object Manager
XX Select Edit > Delete, click the Delete button or press Ctrl+Del. The selected object or objects are deleted from the 

Work area.

Button Function

Delete toolbar button

5.5.5	 USING SELECTING ALL

The Select All command selects all objects in the Active Job.

To use Select All

XX Select Edit > Select All. The objects are selected in the Work area and in the Object Manager.
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5.5.6	 EXPORTING ENTITIES

Exporting vector graphic objects is easily performed using the File menu or the Export button. cabLase Editor 5 can 
export to the following file formats: PLT (HPGL Plotter File) and WLO (cabLase Editor 5 Object).

To export a file
XX Select the desired object to export. Choose File > Export or click the Export button. The Export Graphic dialog 

appears

Button Function

Export toolbar button

5.5.7	 SELECTING AND DE-SELECTING OBJECTS

Before modify an object, it needs to be selected by clicking on the object in the Object Manager or clicking on the 
object in the work area. Once an object is selected, an array of handle boxes surrounds the object and it can be 
edited by moving, duplicating or deleting it. Once an object has been deselected, it must be reselected to do any 
further editing.

Button Function

Arrow pointer toolbar button

5.5.7.1	 TO SELECT AN OBJECT USING THE ARROW BUTTON

XX Using the arrow cursor, click on the desired object in the work area. The object now appears with anchor points 
around it to indicate selection and the object name is highlighted in the Object Manager.

5.5.7.2	 TO SELECT AN OBJECT FROM THE OBJECT MANAGER

XX Click on the desired object in the Object Manager. That object now appears with anchor points around it to 
indicate selection.

5.5.7.3	 TO SELECT MULTIPLE OBJECTS
Do one of the following:

XX Using the arrow cursor, place it near the desired objects in the work area. Hold down the left mouse button, click 
and drag a marquee over all the objects to be selected. The objects now appear with one set of anchor points 
around them to indicate a group selection. All selected objects are highlighted in the Object Manager.

XX Using the Object Manager, click on the first desired object, hold down the Ctrl key and click on the next desired 
object. Continue selecting objects until all desired objects are selected and highlighted in the Object Manager.

XX From the Work area, while holding down the shift key, click on each object to add to the group. As each object is 
added to the current group, new anchor points will appear. 

5.5.7.4	 TO DE-SELECT OBJECTS
Do one of the following:

XX Using the arrow cursor, click at least 2 pixels away from the selected object. The anchor points are removed from 
around the object.

XX Click on a different object in the Object Manager. The anchor points now appear around the newly selected 
object.
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5.5.8	 EDITING OBJECTS IN THE WORKSPACE

Editing Jobs is made easy in cabLase Editor 5 by means of tools that allow objects to be moved and arranged 
precisely. cabLase Editor 5 provides tools to move and align, scale and rotate objects, and apply these changes to 
groups of objects. Objects can also be moved and arranged by using the Dimension Tool. See “Using the Dimension 
Tool”.

5.5.8.1	 TO MOVE AN OBJECT

XX Select the desired object using one of the selection tools. See “Selecting and De-selecting Objects” for 
instructions.

XX Click the object with the mouse, and while holding the left mouse button down, drag the object to the desired 
location on the work area

XX Release the mouse button. The object is moved to the new location.

5.5.8.2	 TO MOVE MULTIPLE OBJECTS

XX Select the desired objects to move using one of the selecting tools. See “Selecting and Deselecting Objects” for 
instructions.

XX Click the group with the mouse, and while holding the left mouse button down, drag the group to the desired 
location on the work area

XX Release the mouse button. The object is moved to the new location.
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5.5.8.3	 TO NUDGE AN  OBJECT WITH THE KEYBOARD

XX Select the mark object to nudge.
XX While holding down the Ctrl key, use the arrow keys to nudge the object in the desired direction.

5.5.8.4	 TO NUDGE A GROUP OF OBJECTS WITH THE KEYBOARD

XX Select the group to nudge.
XX While holding down the Ctrl key, use the arrow keys to nudge the object in the desired direction.

5.5.8.5	 TO ADJUST THE KEYBOARD NUDGE

XX From the Main menu, select System > Preferences.
XX Click the Workspace tab. The Workspace page appears

The Workspace settings page	

A Enter the amount of offset to apply to the object(s) when using the Keyboard Nudge function

5.5.8.6	 TO SIZE AN OBJECT PROPORTIONALLY

XX Select the desired object using one of the selection tools. See “Selecting and De-selecting Objects” for 
instructions.

XX Place the mouse over one of the corner handles and the mouse will change to the proportional arrow indicator. 
Click the left mouse button, and while holding the button down, drag the object to the new proportional size. 
Release mouse button
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Left: Mouse placed on the upper right handle. 
Middle: Mouse dragged to size object
Right: Object at new size

5.5.8.7	 TO SIZE (STRETCH) AN OBJECT

XX Select the desired object using one of the selection tools. See “Selecting and De-selecting Objects” for 
instructions.

XX Place the mouse over one of the side handles and the mouse will change to the size arrow indicator. Click the left 
mouse button, and while holding the button down, drag the object to the new size. Release mouse button.

Left: Mouse placed on the right side handle. 
Middle: Mouse dragged to size object
Right: Object at new size

5.5.8.8	 TO SIZE A GROUP OF OBJECTS PROPORTIONALLY

XX Select the desired group of objects using one of the selection tools. See “Selecting and De-selecting Objects” for 
instructions.

XX Place the mouse over one of the corner handles and the mouse will change to the proportional arrow indicator. 
Click the left mouse button, and while holding the button down, drag the object to the new proportional size. 
Release mouse button.

Left: Mouse placed on the right side handle. 
Middle: Mouse dragged to size object
Right: Object at new size
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5.5.8.9	 TO SIZE (STRETCH) A GROUP OF OBJECTS PROPORTIONALLY

XX Select the desired group of objects using one of the selection tools. See “Selecting and Deselecting Objects” for 
instructions.

XX Place the mouse over one of the side handles and the mouse will change to the size arrow indicator. Click the 
left mouse button, and while holding the button down, drag the group of objects to the new size. Release mouse 
button.

Left: Mouse placed on the right side handle. 
Middle: Mouse dragged to size object
Right: Object at new size

5.5.8.10	TO MODIFY THE RADIUS AND ROTATION OF A RADIAL TEXT OBJECT

XX Radius - First make sure the object is selected. See “Selecting and Deselecting Objects” for instructions. While 
holding down the ALT key, press the up or down arrow keys to increase or decrease the objects radius. If the 
String orientation is Radial - fixed, the circumference can be directly entered into the Dimension tool.

XX 	Rotation - First make sure the object is selected. See “Selecting and Deselecting Objects” for instructions. While 
holding down the ALT key, press the left or right arrow keys to rotate the object clockwise or counterclockwise.

5.5.9	 LOCKING / UNLOCKING OBJECTS

A job entity can be locked to prevent changes to its settings, and to prevent the object from being sized, scaled, 
moved, or deleted.

5.5.9.1	 TO LOCK AN OBJECT

XX Click on the desired unlocked object to select it.
XX From the Main menu select Objects > Lock Object, or right click with the mouse and select Lock Object. The 

object handles change to indicate the object is locked.

Locking is indicated by different grab handles	

A Unlocked
B Locked
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5.5.9.2	 TO UNLOCK AN OBJECT

XX Click on the desired locked object to select it.
XX From the Main menu select Objects > Unlock Object, or right click with the mouse and select Unlock Object. The 

object handles change to indicate the object is unlocked.

5.5.9.3	 TO LOCK ALL OBJECTS

XX From the Main menu select Objects > Lock All. When selected, the object handles indicate the objects are locked. 
The Lock All menu item will only be available if there is more than one object in the Job.

5.5.9.4	 TO UNLOCK ALL OBJECTS

XX From the Main menu select Objects > Unlock All. When selected, the object handles indicate the objects are 
unlocked.

5.5.10	 UNDOING ACTIONS

The Undo command reverses up to ten actions that have been performed on a Job. cabLase Editor 5 provides 
several ways to do this using the File menu, Toolbar button, or the Ctrl+Z command.

Button Function

Undo toolbar button

	

To Undo the last action

XX Select Edit > Undo, click on the Undo button, or press Ctrl+Z. The last action performed is reversed.
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5.6	 MANAGING PROFILES

An Object Profile is the set of laser parameters and scan head parameters specified in the Object Properties. 
cabLase Editor 5 provides options for saving Profiles, arranging them in a tree structured set of folders, and applying 
the Profiles to objects. Saved Profiles are displayed in the Profile Manager. By default, the Profile Manager is 
displayed on the right hand side of the cabLase Editor 5 workspace. See "Profiles Panel" on page 33.

5.6.1	 THE DEFAULT PROFILE

cabLase Editor 5 applies the Default Profile to a new object when it is first created. Because it is a required part of the 
system, the Default Profile cannot be deleted or moved to another folder.

i
Note!
The Default Profile always uses the Laser and Lens settings from the Offline configuration. See “To select an 
Offline Lens Correction file” on page 55 and “To select an Offline Laser Driver file” on page 52.

5.6.1.1	 TO APPLY AN OBJECTS PROFILE TO THE DEFAULT PROFILE

XX Right mouse click on the object in the work area and select Add to Profiles. The Add Profile window appears.

XX Select “Apply this profile when creating a new object”. The Copy to Default confirmation appears.

XX Click OK. This profile is now applied to all new objects created.
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5.6.1.2	 TO APPLY AN EXISTING PROFILE TO THE DEFAULT PROFILE

XX From the Profile Manager, right mouse click on the existing profile. The Profile menu appears.

XX Select “Copy to Default”. The Copy to Default window appears.
XX Click OK. The profile is now applied to all new objects created.

5.6.1.3	 TO MODIFY THE DEFAULT PROFILE

XX From the Profile Manager, do one of the following:
XX 	Right mouse click on the Default Profile.
XX 	Double click on the Default Profile.
XX Select “Modify”. The Modify Profile window appears.
XX Modify the Default Profile as desired. See “Profiles” on page 96 for a description of the Profile parameters.

5.6.2	 CREATING AND ORGANIZING PROFILES

Object Profiles can be created and organized into folders in a hierarchical directory tree.

To Organize Profiles

Do one of the following:
XX 	From the Menu bar, select Profiles > Organize Profiles
XX Click the Organize button in the Profile Manager
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Use the Organize Profiles window to create folders, move profiles, rename profiles, and delete profiles	

A Create a new folder
B Move the selected profile to another folder
C The properties of the selected profile
D Rename the selected profile
E Delete the selected profile
F The Profile viewer

5.6.3	 ADDING PROFILES

To add a Profile

XX From the Work area, click on the object with the profile to be saved. Do one of the following:
XX 	Right-mouse click on the object and select Add to Profiles.
XX 	From the Menu bar, select Profiles > Add to Profiles.
XX 	From the Profiles area, click the Add button
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Use the Add Profile window to name the profile, select its folder or apply this profile when creating a new 
Object	
A The name of the new profile as displayed in cabLase Editor 5
B Select this option to assign the profile to the Default profile. See “The Default Profile”.
C Select the folder to place the new profile in if not applying to the Default profile
D Open the Profile viewer
E Create a new folder

5.6.4	 MOVING PROFILES
Profiles can be moved to another folder in cabLase Editor 5.

To move a Profile

Do one of the following:

XX From the Menu bar, select Profiles > Organize Profiles.
XX 	From the Profile Manager, click Organize.

XX From the Profile list, click on the plus sign to display the profiles in that folder.
XX Click on the desired profile to move.
XX Click Move to Folder. The Browse Folder window appears.
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XX Click on the folder to move the selected profile to

5.6.5	 APPLYING PROFILES TO OBJECTS

Existing Profiles can be applied to an individual object, a group of objects, or all objects within a Job.

5.6.5.1	 TO APPLY A PROFILE TO ALL OBJECTS IN A JOB
XX From the Profile Manager, right mouse click on the desired profile to apply. The Profile menu appears.
XX Select “Apply to All”. The Apply Profile confirmation window appears.

Do one of the following:
XX 	Click OK to apply this profile to all marking objects in the Job. To confirm the profile on each object, right mouse 

click on the object and select Properties. The profile values in the Profiles folder are identical to the profile 
selected from the profile list.

XX 	Click Cancel to cancel the command

5.6.5.2	 TO APPLY A PROFILE TO A SINGLE OBJECT

XX From the Work area, click on the object to which the profile will be applied.
XX From the Profile Manager, right mouse click on the desired profile to apply to the selected object. The Profile 

menu appears.
XX Select “Apply to Object”. The selected profile values are applied to the selected object.
XX To confirm the Profile has been applied to the object, right mouse click and select Properties. The profile values in 

the Profiles folder are identical to the profile selected from the Profile Manager.
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5.6.5.3	 TO APPLY A PROFILE TO A GROUP OF OBJECTS

XX From the Work area, select the group of objects. See the section on Selecting Objects on how to select groups.
XX From the Profile Manager, right mouse click on the desired profile to apply to the selected group of objects. The 

Profile menu appears.
XX Select “Apply to Group”. The selected profile values are applied to the group of objects.
XX To confirm the Profile has been applied to the objects, right mouse click and select Properties. The profile values 

in the Profiles folder are identical to the profile selected from the Profile Manager.

5.6.5.4	 TO COPY AN OBJECTS PROFILE TO ANOTHER OBJECT

XX From the Work area, right mouse click on the object to copy the profile from. The objects Context menu appears.

XX Select “Copy Profile”. The objects profile is temporarily stored in memory.
XX Right mouse click on the object to copy the profile to. The objects Context menu appears.

Select “Paste Profile”. The profile in memory is copied to the object.
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5.6.5.5	 TO COPY AN OBJECTS PROFILE TO A GROUP OF OBJECTS

XX From the Work area, right mouse click on the object to copy the profile from. The objects Context menu appears.
XX Select “Copy Profile”. The objects profile is temporarily stored in memory.
XX Select a group of objects.
XX Right mouse click on the group to copy the profile to. The groups Context menu appears.
XX Select “Paste Profile”. The profile in memory is copied to the group of objects.

5.6.6	 MODIFYING EXISTING PROFILES

To modify an existing Profile

XX From the Profile Manager, right mouse click on the desired profile to be modified. The Profile menu appears.
XX Select “Modify”. The Modify Profile window appears.
XX Or, double click the desired profile. The Modify Profile window appears.
XX Modify the profile as desired. See "Profiles" on page 96 for a description of the Profile parameters.
XX Click OK. The new values are applied to this profile.

5.6.7	 IMPORTING AND EXPORTING PROFILES

Profiles created in CabLase Editor 5 can be easily imported or exported by using the File menu. 

5.6.7.1	 TO IMPORT PROFILES

From the main menu, select File > Import and Export Profiles. The dialog appears.

XX From the Choose an action list, select “Import Profiles from a file”.
XX Click the Next button. The Select file to import page appears.
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XX Click the Browse button. The Import from File dialog appears.
XX Locate the file to import and click the Open button

When importing Profiles, the following two options are available:

•	 	Replace duplicates with Profiles imported - If there are any existing Profiles with the same name as the Profiles 
imported, the existing Profiles will be overwritten.

•	 	Do not import duplicates - Duplicate imported Profiles will not overwrite existing Profiles.

XX Click the Finish button to close the Wizard. The confirmation window appears. Click OK to close the window. 

5.6.7.2	 TO EXPORT PROFILES

XX From the main menu, select File > Import and Export Profiles. The Import and Export Profiles window appears. 
XX From the Choose an action list, select “Export Profiles to a file”.
XX Click the Next button. The Save exported file page appears.
XX Click the Browse button. The Export to file dialog box appears.
XX Type the file name and locate the desired folder to save the file. Enter a filename that is unique. If the file already 

exists, the export operation will fail.
XX Click the Save button. The filename appears in the filename field.
XX Click the Next button. The Select folder page appears.

XX Select the folder to export. The profiles appear in the list for reference, but they cannot be exported individually.
XX If the top Profiles folder is selected, all sub folders will be exported.
XX Click the Finish button. The confirmation window appears.
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5.7	 MANAGING FONTS

Text Objects created in cabLase Editor 5 can either use TrueType fonts or Laser fonts to generate their graphical 
representation. TrueType fonts are outline fonts and are installed in the Windows operating system. Laser fonts are 
specially designed fonts that are installed in the cabLase Editor 5 font library.

5.7.1	 ADDING A NEW TRUETYPE FONT

TrueType fonts are installed directly into the Windows operating system.

To install a new TrueType font

XX In Windows click Start > Control Panel.
XX Double-click the Fonts applet. The Fonts window appears.
XX From the Main menu, click File > Install New Font... The Add Font tool appears.
XX In the Folders drop down, select the folder that contains the new font. 
XX The font will appear in the List of Fonts list. Select the font in the list and click OK.

5.7.2	 CREATING A NEW LASER FONT

In some Dynamic Text applications, the available Laser fonts may not be acceptable for aesthetic and/or technical 
reasons. cabLase Editor 5 provides a tool to create Laser Fonts from TrueType fonts. To use a custom Laser Font, 
consider the following:

•	 After the font is compiled, it needs to be added to the cabLase Editor 5 font library, which is stored on the PC

•	 Text objects can be added to a job, and the new Laser Font selected as the Text Object font.

•	 To use the Laser Font in Stand-Alone mode, the font must also be copied to the LEC-2 card, so it is available as a 
resource when the job executes locally on the LEC-2 device.
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To compile a new Laser font

XX From the Main menu, select Tools > Laser font compiler...

The Laser Font compiler utility	

A
Select the source of the font outlines:
•	 TrueType font
•	 PLT files

B The name of the new Laser font as displayed in cabLase Editor 5. This name is created automatically by the 
utility, but can be overridden with another name.

C The TrueType font to convert

D
Select the character set:
•	 ASCII (32d to 127d) - The standard ASCII character range
•	 ASCII (32d to 255d) - The extended ASCII character set

E The character spacing value controls the default space added between characters. The spacing can also be 
overridden later in the Text Object by changing the Character spacing value of the Text object.

F Curve optimization allows control over the number of straight-line segments used to define the curves in each 
character. More segments produce a smoother curve, but will increase the size of the Laser font file.

G

Select this option to automatically add the new Laser font to the cabLase Editor 5 font library. This library is 
located at \marker\marker\fonts. After creating a new laser font, it must be located in the library for cabLase 
Editor 5 to access it. If the font is to be used in Stand-Alone mode, it must also be copied to the font library on 
the LEC-2 device.

H Select this option to space the characters evenly in the font, rather than space them based on the width of the 
characters.

I Click the Compile button to create the font
J Select the Bold or Italics attributes before compiling the font
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5.7.3	 ADDING A NEW LASER FONT TO cabLase Editor 5

Laser fonts are added to the cabLase Editor 5 font library. Usually, when the Laser font is created, the “Add new font 
to Laser font library option” is selected. A new Laser font can also be manually added to the Laser font library

5.7.3.1	 TO ADD A NEW LASER FONT

XX In Windows Explorer, browse to the folder \marker\marker\fonts on the local drive that cabLase Editor 5 was 
installed on.

XX Copy the new font into this folder

!
Warning!
Adding file types other than a Laser font to the fonts folder will create errors in the way cabLase Editor 5 detects 
Laser fonts. Copy ONLY Laser fonts into this folder.

	

5.7.4	 ADDING A NEW LASER FONT TO AN LEC-2 DEVICE

If a job contains a Text object that uses a Laser font that is not part of the standard Laser font library, and that job is to 
be run in Stand-Alone mode on an LEC-2 device, then the Laser font must be installed on the LEC-2 device.

5.7.4.1	 TO ADD A NEW LASER FONT TO AN LEC-2 DEVICE
To add a new Laser font to an LEC-2 device

i Note!
There must be an active connection to an LEC-2 device

XX In the Laser System viewer, right-click on a connected LEC-2 device and select “Explore...”.
XX From the Look in drop down, select “Fonts”.

XX Click the Add button and browse to the new Laser font.
XX Select the new Laser font and click Open. The file is copied to the LEC-2 device.
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5.8	 USING THE MOTION MANAGER

The Motion Manager provides a method for direct control of installed motion devices. There are two versions of the 
Motion Manager, depending on the installed hardware.

5.8.1	 INTELLIGENT MOTION

To interact with available motion devices, check the following:

•	 A motion device or devices are attached to the correct COM port of the LEC-2. See “To configure the COM ports” 
on page 4 -38 for more information.

•	 cabLase Editor 5 has an active connection to the LEC-2 device. See “Making a Connection” on page 47.

•	 cabLase Editor 5 has a Motion Configuration loaded. See “Working with Motion Configurations” on page 249

•	 The LEC-2 device is selected in the Laser System Viewer.

5.8.1.1	 TO USE THE MOTION MANAGER

XX If the Motion Manager is not visible, select View > Motor Manager.
XX From the Laser System Viewer, select an LEC-2 device that has a motion system connected.

XX When an LEC-2 device is selected, the Motion Manager updates with a view of the current Motion Configuration

XX With the mouse, select an axis to control. The motion control panel appears
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The Motion Manager with an axis motor selected	

A The current Motion Configuration of the selected LEC-2 device
B A Motion axis type contained in the Motion Configuration
C The individual axis motors within the Motion axis type

D

The Limit and Home switch states:
•	 L- is the negative travel Limit switch state. When the indicator is Red the switch is signaled.
•	 H is the Home switch state. When the indicator is Red the switch is signaled.
•	 L+ is the positive travel Limit switch state. When the indicator is Red the switch is signaled.

E The current position of the selected motor
F The amount to move the axis

G

Select an Action:
•	 Absolute - Move the axis to absolute position F
•	 Relative - Move the axis a relative amount from the current position using F
•	 Home - Perform a Homing routine
•	 Stop - Stop an axis that is currently moving using a deceleration profile
•	 To + limit - Slew the axis to the plus limit until stopped by either the software or the limit switch.
•	 To - limit - Slew the axis to the minus limit until stopped by either the software or the limit switch.

H Select the units to display in the Motion Manager.
I After selecting the move profile, click the Go button
J The Settings button, used to access the axis speed and acceleration settings
K Stop an axis immediately without using a deceleration profile
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5.8.1.2	 TO CHANGE  SPEED AND ACCELERATION SETTINGS

XX Click the Settings button. The Settings panel appears

The axis Settings panel	

A The acceleration rate of the axis
B The deceleration rate of the axis
C The initial speed of the motor when it first starts accelerating
D The speed of the motor after the acceleration ramp is complete.
E When working with rotary motion, the radius of the part can be entered

Runtime Errors

When using the Motion Manager, runtime errors may be encountered. These errors are displayed as they are 
received in the Motion Manager. Click the + to see a list of all the errors received. When the Go button is click, the 
current Runtime errors are cleared.

				    Runtime Error logging
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5.8.2	 PRODEX OMS CONTROLLER

The Motor Manager is only available if the OMS hardware is installed in the PC and detected by CabLase Editor 5.

To use the Motor Manager

XX If the Motor manager is not visible, select View > Motor Manager.
XX In the Motor Manager panel, select a motor axis to interact with. A control panel appears.

The OMS controller Motor Manager	

A The installed Pro-Dex OMS controller card
B The enabled axes (one shown)
C The units of display in the Motion Manager
D The current position of the selected axis
E The amount to move the axis when the move button is clicked
F The amount to jog the axis when one of the jog buttons is clicked
G The speed the axis moves
H Perform a homing routine
I The Move button
J The Jog buttons
K The Stop button
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5.9	 USING THE MOTION MANAGER

The Dimension Tool is used to adjust the position, size, and angular orientation of Mark Objects. To set the display 
units of measure and accuracy, see “Setting the Units of Measure” on page 3 -6. The Dimensions form consists of six 
tabs:

•	 	Rotate, which provides the ability to rotate the selected object or group

•	 	Nudge, which provides the ability to nudge the selected object or group

•	 	Skew, which provides the ability to shear the selected object

•	 	Position, which provides the ability to move the selected object or group to the indicated position

•	 	Scale, which provides the ability to scale or mirror the selected object or group

•	 	Size, which provides the ability to change the selected object or group to the indicated size

Opening the Dimension Tool

i Note!
There must be an object or group of objects selected to initially display the Dimension Tool. See “Selecting and 
De-selecting Objects”.

To open the Dimension Tool, do one of the following:

XX From the Main menu, select Objects > Dimensions.
XX Right-click the selected object(s) and click “Dimensions...”.

XX Click the Dimension button.

Button Function

Dimension toolbar button
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5.9.1	 TO ROTATE A MARK OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Rotate tab. The Rotate page appears.

XX Type in the desired angle in degrees
XX Click Apply. The object rotates about its center.
XX Optional. Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

5.9.2	 TO NUDGE A MARK OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Nudge tab. The Nudge page appears.

XX Type in the desired horizontal and vertical nudge in the current units
XX Click Apply. The object moves the indicated amount.
XX Optional. Click Apply to Duplicate to create a duplicate of the object with the indicated settings.
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5.9.3	 TO SKEW A MARK OBJECT

XX Skew shears the object in the indicated direction. The following examples show a skewed and an unskewed 
Rectangle object:

			   Skewed by 45 degrees and Unskewed

XX From the menu bar, select Objects > Dimensions
XX Click on the Skew tab. The Skew page appears.

XX Type in the desired horizontal and vertical skew in degrees
XX Click Apply
XX Optional. Click Apply to Duplicate to create a duplicate of the object with the indicated settings.

5.9.4	 TO POSITION A MARK OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Position tab. The Position page appears.

XX Type in the desired horizontal and vertical position in the current units
XX Click Apply. The bottom left corner of the objects bounding rectangle moves to the indicated position.
XX Optional - Click the Center button to move the objects center to the center of the marking field
XX Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings
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5.9.5	 TO SCALE A MARK OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Scale tab. The Scale page appears.

XX Type in the desired horizontal and vertical scale in percent
XX Optional - Enable the Proportional box to maintain the aspect ratio between the height and the width of the object
XX Click Apply. The object scales from its center.
XX Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings

5.9.6	 TO MIRROR A MARK OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Scale tab. The Scale page appears.
XX Select the desired Mirror action. The two mirror options available are:

Button Function

Mirror Horizontally button

Mirror Vertically button
	

XX Click Apply
XX Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings 
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5.9.7	 TO SIZE A MARK OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Size tab. The Size page appears.

XX Type in the desired horizontal and vertical size in the current units
XX Optional - Enable the Proportional box to maintain the aspect ratio between the height and the width of the object
XX Click Apply. The object sizes from its center.

5.9.8	 TO CONSTRAIN THE SIZE OF A MARK OBJECT

XX From the menu bar, select Objects > Dimensions.
XX Click on the Size tab. The Size page appears.

XX Click on the Constraints radio button. This is only available with Text Objects.
XX Click the When marking, constrain size to: check box.
XX Enter the desired size constraints.
XX When marking, if the current text string (for example, from a text merge operation) will be larger than the 

constraints, the object will be scaled down to fit inside the constraints. If the text string will fit inside the 
constraints, no scaling is applied.
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5.9.9	 TO SIZE A FIXED RADIAL TEXT OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Size tab. The Size page appears.

	

The Radial text size page	

A The circumference of the text itself. This circumference is represented on screen as a circle drawn with a red 
dotted line.

B The actual height of the ascent portion of a text character.
C The actual height of the descent portion of a text character.

5.9.10	 TO CONSTRAIN THE ARC OF A FIXED RADIAL TEXT OBJECT

XX From the menu bar, select Objects > Dimensions
XX Click on the Size tab. The Size page appears.

XX Check the “When marking constrain arc to:” check box
XX Enter the desired value
XX Click Apply. The object redraws with the new setting.
XX Optional - Click Apply to Duplicate to create a duplicate of the object with the indicated settings
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5.10	 USING THE ALIGN TOOL

The Align Tool is useful for aligning two or more objects to each other.

To use the Align Tool

XX Select more than one object in the work area. See “Selecting and Deselecting Objects”.

Do one of the following:
XX From the Main menu, select Tools > Align. 
XX Click the Align button.

Button Function

Open Alignment tool
	

XX Select the desired alignment options. For example, to align the centers of both objects to each other, use the 
settings shown above. Note that the last object selected into the object group becomes the target object for the 
align process.

XX Click the Preview button to see what the align action will do to the objects in the work area. Click the Reset button 
to return the objects to their original positions.

5.11	 USING THE GRID AND GUIDELINES

In addition to the Align Tool, there are two on-screen object alignment tools that aid in positioning objects in the 
marking field. They are:

•	 	Grid, which is a series of evenly spaced horizontal and vertical lines that are used to help draw and arrange 
objects. Use the controls on the Grid/Guidelines window to set the grid's parameters.

•	 	Guidelines, which are lines that can assist in aligning objects. Use the controls on the Grid/Guidelines window to 
set the guideline parameters.

5.11.1	 USING SNAP TO GRID

The Snap to Grid command automatically aligns object edges vertically and horizontally relative to the Grid.
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5.11.1.1USING SNAP TO GRID

Select Edit > Snap to Grid or click on the Snap to Grid button.

Button Function

Snap to Grid toolbar button
	

5.11.1.2TO DISPLAY THE GRID

The grid can be visible, overlaying on the work area, or it can be hidden from view. 

To display the Grid over the work area, do one of the following:

XX 	From the menu bar, select View > Grid.
XX 	Click the Show Grid button on the toolbar.

Button Function

Show Grid toolbar button
	

5.11.1.3TO HIDE THE GRID

To hide the Grid do one of the following:

XX 	From the menu bar, select View > Grid.
XX 	Click the Show Grid button on the toolbar.

5.11.1.4TO MODIFY GRID SETTINGS

Grid settings affect the way the Grid is drawn on screen, and how an object behaves when moved near a grid line.

XX From the menu bar, select Tools > Grid/Guidelines. The Grid/Guidelines window appears.
	



119 1195	 JOB EDITING

The Grid page	

A Sets the spacing between the horizontally drawn grid lines, in the current display units.
B Sets the spacing between the vertically drawn grid lines, in the current display units.
C Shows or hides the grid
D If this option is selected, when an object is moved near a grid line, the object will snap to the line.

5.11.2	 USING SNAP TO GUIDELINES

The Snap to Guideline command automatically aligns object edges vertically and horizontally relative to the guideline.

Button Function

Snap to Guidelines toolbar button
	

5.11.2.1TO USE SNAP TO GUIDELINES

XX Select Edit > Snap to Guidelines or click on the Snap to Guidelines button

5.11.2.2TO ADD, DELETE AND MOVE GUIDELINES

An unlimited number of guidelines can be added to the work area. Guidelines can be added, moved, deleted, and 
cleared. All of these tasks are performed from the Guidelines Setup window.

XX From the menu bar, select Tools > Grid/Guidelines
XX Click the Setup button. The Guidelines Setup window appears.

	

The Guidelines Setup page	

A Select the Horizontal or Vertical tab to manage guidelines
B Enter a position
C List of current guidelines
D Add a guideline at the position specified in B
E Move a selected guideline to a new location as specified in B
F Delete the selected guideline
G Clear the list of guidelines
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5.11.2.3TO DISPLAY THE GUIDELINES

The Guidelines (if there are any set) can be visible, overlaying the work area, or they can be hidden from view.

i Note!
If there are no Guidelines set, the Show Guidelines feature is disabled.

To display the Guidelines over the work area, do one of the following:

XX 	From the menu bar, select View > Guidelines
XX 	Click the Show Guidelines button on the toolbar

Button Function

Show Guidelines toolbar button
	

5.11.2.4TO HIDE THE GUIDELINES

To hide the Guidelines do one of the following:
XX 	From the menu bar, select View > Guidelines
XX 	Click the Show Guidelines button on the toolbar

5.11.2.5TO MODIFY GUIDELINE SETTINGS

Guideline settings affect the way the Guidelines are drawn on screen, and how an object behaves when moved near 
a Guideline.

XX From the menu bar, select Tools > Grid/Guidelines. The Grid/Guidelines window appears.
	

The Guidelines page	

A Restores the Guidelines as they were saved in the Job. If this selection is not checked, the Job loads without 
displaying the guidelines.

B Shows or hides the Guidelines
C If this option is selected, when an object is moved near a Guideline, the object will snap to the line
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5.11.3	 GUIDELINE PRESETS

cabLase Editor 5 can save different combinations of Guidelines to the Preset library. This feature is useful if there are 
many different tooling sets and a quick method is needed to set up for each tool. The Preset options are:

•	 	Load Preset, which loads a pre-saved Guideline set into the work area.

•	 	Save Preset, which saves the current Guidelines to a Preset.

•	 	Organize Presets, which renames and deletes Presets.

5.11.3.1TO SAVE A GUIDELINES PRESET

XX From the menu bar, select Tools > Grid/Guidelines
XX Click the Setup button
XX 	If there are no Guidelines set, add the desired horizontal and vertical Guidelines
XX Click the Save Preset button. The Save Preset window appears.
XX Select an appropriate name for the new Preset, and click the OK button

5.11.3.2TO LOAD A GUIDELINES PRESET

XX From the menu bar, select Tools > Grid/Guidelines
XX Click the Setup button
XX Click the Load Preset button. The Preset window appears.

XX Select the desired Preset
XX Click OK to apply this Preset, Cancel to quit
XX The Preset values appear in the Guidelines Setup list
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5.11.3.3	TO DELETE A PRESET

XX From the menu bar, select Tools > Grid/Guidelines.
XX Click the Setup button.
XX Click the Organize Presets button. The Organize Presets window appears.

XX Select the desired Preset to delete.
XX Click the Delete button. The Preset is deleted and removed from the list.

5.11.3.4TO RENAME A PRESET

XX From the menu bar, select Tools > Grid/Guidelines.
XX Click the Setup button.
XX Click the Organize Presets button. The Organize Presets window appears.
XX Select the desired Preset to rename.
XX Click the Rename button. An edit box appears next to the Preset.
XX 	Edit the Preset name as desired.
XX Click away from the Preset. The new Preset name is saved.

5.12	 USING THE ZOOM TOOLS

There are three tools available to change the zoomed view of the work area:

•	 	Zoom In Tool, which provides methods to zoom in on a specific place in the work area.

•	 	Zoom Out Tool, which provides methods to zoom out, reversing the zoom in actions.

•	 	Full Field Tool, which returns the work area to the default full field area view.

The scroll bars on the right and bottom of the work area can also be used to scroll the current view of the work area.
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5.12.1	 USING THE ZOOM IN TOOL

Click on the Zoom In button. The button stays depressed, and the mouse cursor changes to the zoom in cursor.

Button Function

Zoom in toolbar button
	

XX While holding the right mouse button down, drag a marquee around an object in the work area. The marquee box 
updates the screen.

				             Zoom Marquee around Rectangle

XX Release the mouse button. The new work area extents become the window that the marquee defined. The Zoom 
In button returns to its off state, and the mouse cursor returns to its default.

XX 	To repeat the process, click the Zoom In button again.

5.12.2	 USING THE ZOOM OUT TOOL

XX Click on the Zoom Out button.

Button Function

Zoom out toolbar button
	

XX The work area zooms out
XX To repeat the process, click the Zoom Out button again

5.12.3	 USING THE FULL FIELD  TOOL

XX Click on the Full Field button.
	

Button Function

Show full field toolbar button

XX The work area returns to its default size.
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5.13	 PRINTING JOBS

cabLase Editor 5 can print an image of a Job as it appears on screen. cabLase Editor 5 provides several ways to 
print Jobs using the File menu or the Toolbar button.

5.13.1	 TO PRINT A JOB

XX Select File > Print Setup. The Print Setup dialog appears.
XX Click the Print button

Button Function

Print toolbar button

	
XX Select the desired printer from the drop down list
XX Select the desired paper size and source
XX Select the desired orientation of the Job
XX Click OK. The Job prints to the selected printer.

5.13.2	 TO ADJUST THE PRINT LAYOUT OF A JOB BEFORE PRINTING

XX Select File > Print or click on the Print button. 

Button Function

Print toolbar button

	
The Print Layout dialog appears.

The Print Layout dialog

A Objects will print the actual size
B Scales the Job so that it fits on the page

C Adjusts the Job so that it's located in the center of the page. Select this to adjust the width and height of the 
printed Job.

D Changes the width and height of the Job to be printed
E Forces the width and height to maintain a constant rate
F Displays the field size boundaries on the printed Job
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This chapter provides an overview of the Job Entity types. There are three types of Job Entities:

•	 	Mark Objects consist of lines, rectangles, polygons, text, barcodes, imported vector files, imported bitmap files 
and drill points. These objects represent the pattern the laser will mark.

•	 Automation Objects consist of I/O functions that set or get the state of I/O ports, Time Delays, displaying of 
Message Boxes, and multi-axis Motor Control objects. These Automation objects are usually used for interfacing 
to and controlling external equipment.

•	 The Template Object, which provides a graphic that is displayed in the work area, but is not a marking object.

6.1	 WORKING WITH JOB ENTITIES

Each entity has a set of properties that can be modified, and these settings can be edited by selecting the object and 
selecting Objects > Properties, pressing F2 on the keyboard while a single object is selected, or right-mouse clicking 
on the selected object and selecting Properties.

To view and set Entity Property Values

XX Click on the desired object to select it.

Do one of the following:

XX From the Main menu, select Objects > Properties
XX Press F2 on the keyboard
XX Right-mouse click on the selected object and select “Properties...”. The Properties window appears for the 

selected object.

XX Edit the property values as desired.
XX Click Apply to leave the Properties window open, or click OK to apply the changes and close the Properties 

window.

6.1.1	 CHANGING THE NAME OF AN OBJECT

You can change the name of the job entity as it appears in the Object Manager.

To change the Name of the Object

XX Click on the desired Object in Object Manager.
XX Right-mouse click and select Properties. The Properties window appears.
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                                  Enter the object name

                                                            
                                                          The object name as it appears in the Object Manager

6.1.2	 ADDING NOTES TO AN OBJECT

All objects have a Notes property, which you can use to save details about the object. The notes property is only 
visible in the User Interface.

To add a Note to the Object

XX Click on the object to be modified
XX Right-mouse click and select “Properties...”
XX Click on the Notes Tab. The Properties window displays the Notes settings. 
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6.2	 MARK ENTITIES

Mark entities can be defined as any entity type that controls the motion of the scan head and the laser to produce a 
laser mark. Mark entities consist of imported graphics files as well as the cabLase Editor 5 built-in system objects.

6.2.1	 EXTERNAL CONTROL

Use External Control to Enable or disable marking of the entity based on discrete I/O input. 

i Note!
This feature is ONLY available when running the job in Stand-Alone mode.

To modify External Control settings

XX Click on the Object to be modified.
XX Right-mouse click and select “Properties...”.
XX Click on the Ext. Control tab. The Properties window displays the ExternalControl settings.
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The property External Control page

A Select this option to enable External Control. When the Job is run, the object will check the I/O ports, and if 
they match the configuration selected in D, the object will mark, otherwise, it will be skipped.

B Selects the I/O ports to be used during the process. Only User In 1 - User In 20 are available when working 
with an LEC-2 device.

C

Select the Control logic:
•	 Scan ALL inputs (AND) - All the inputs on the LEC-2 device are read and then compared to the configu-

ration in D. If every input matches D, then the object is marked
•	 Scan ONLY checked inputs (OR) - All the inputs on the LEC-2 device are read and then compared to the 

configuration in D. If just the inputs checked in D match, even though other inputs may actually be set on 
the LEC-2 device, the object is marked.

D Select a checkbox to require the input to be HIGH, deselect the checkbox to require the input to be LOW.

6.2.2	 FILL (HATCHING)

cabLase Editor 5 has the ability to add fill lines inside closed paths within any two-dimensional object type (except 
Bitmaps and Dot Matrix). Closed paths are defined as polyline objects where the beginning of the first vector aligns 
with the end of the last vector. See “Understanding Closed Paths”. Fill is usually used to create a “solid look” to the 
marked objects. An important parameter in fill is the spacing between each fill line. The optimal spacing value is 
dependent on laser wavelength, spot size, material, etc. Once the optimal value is determined, it can be saved with 
the object. cabLase Editor 5 has an added benefit: as the object is scaled and sized, the fill maintains a constant 
spacing. This eliminates the need to regenerate the object artwork with new fill each time the object is resized.	
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                                     An unfilled and a filled Text entity using parallel lines

In addition to parallel lines, a crosshatch style is available, with customized settings for the angles of each set of lines.

                                     Crosshatch at 0 and 90 degrees, Crosshatch at -45 and 45 degrees

To modify Fill values

XX Click on the object to be modified
XX Right-mouse click and select “Properties...”. The Properties window displays.
XX 	If the object has closed paths (a contiguous series of connected vectors that start and stop at the same point), the 

Fill tab will be visible. Click the Fill tab. The Fill page appears.

The Property Fill page

A Enable or disable filling (hatching) objects

B

Select the Style:
•	 Parallel lines
•	 Crosshatch
•	 Bidirectional

C The distance between adjacent fill lines

D The angle from the X-axis for the parallel fill or bidirectional fill, or the first set of fill lines in crosshatch fill 
hanges the width and height of the Job to be printed

E The angle from the X-axis for the secondary fill lines when using the crosshatch style
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Understanding Closed Paths

The path is the basis for all vector objects. A path is made up of one or more line segments connected by two or more 
anchor points. Paths can be made from a combination of straight lines and curves, each of which may be made up 
of many connecting points. Paths can be open or closed. An open path is one with unconnected end points, while 
a closed path is one whose start and end points meet. cabLase Editor 5 cannot fill objects unless they are closed 
paths.

                                      Example of an open path

                                                                     Example of a closed path with four nodes

6.2.3	 PROFILES

An Object Profile defines the laser marking parameters and scan head parameters to be used when marking the 
object. After developing laser-marking parameters for different materials, these settings can be saved in the Profile 
library. cabLase Editor 5 provides a means of saving the marking Profiles, and arranging them in a tree structured set 
of folders.
Saved Profiles are displayed in the Profile Manager. By default, the Profile Manager is displayed on the right hand 
side of the cabLase Editor 5 workspace. See “Profiles Panel” on page 33.

To show the Profiles page

Do one of the following:
XX 	Right mouse click on a mark object and select “Properties...”.
XX 	Select a mark object, then from the menu bar, select Objects > Properties.
XX Select a mark object and then press the F2 key. 
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The Profiles page

A

Select the marking Mode:
•	 Mark once - The object will mark once with the selected Profile parameters.
•	 Mark Multiple times - The object will mark the number of times indicated in the Passes field.
•	 2 pass Cut and Clean - The object will mark twice and each pass has its own Profile settings. To modify 

different Profile settings, select them with the Current Profile box.
•	 3 pass Cut and Clean - The object will mark three times and each pass has its own Profile settings. To 

modify different Profile settings, select them with the Current Profile box.
•	 4 pass Cut and Clean - The object will mark four times, and each pass has its own Profile settings. To 

modify different Profile settings, select them with the Current Profile box. If the Use pens checkbox is 
checked, 2 pass Cut and Clean, 3 pass Cut and Clean, or 4 pass Cut and Clean is not available.

B

When the Mode field is set to 2 pass Cut and Clean, 3 pass Cut and Clean, or 4 pass Cut and Clean, or the 
Use pens box is checked, the Current Profile box selects which Profile is currently displayed. If displaying 
pens, the associated pen color is displayed to indicate which line segments in the object will use the current 
Profile. Changes can be made to the current Profile and saved with the object.

C
The Passes field is only available when the Mark Multiple times mode is selected. Enter the desired number 
of marking passes for the object. When running the Job, the object will mark the number of times indicated in 
the Passes field, even though it only appears in the Object List once.

D

Controls the output power of the laser. On YAG type lasers, this is typically accomplished by changing the 
lamp or diode current. On CO2 type lasers, varying the pulse width while maintaining the frequency at a 
constant value controls power. Depending on the settings in the Laser Configuration file, the units are percent 
(%) or Watts.

E Controls the repetition rate of the laser control signal. On YAG lasers, this is usually referred to as the 
Q-Switch frequency.

F

Many applications require laser marking without variation in intensity at the start or end of a vector. In order 
to reach acceptable marking results, it is necessary to mark vectors with a constant velocity. When the 
Scan Head first executes a marking vector, the mirrors on the galvanometers have to be accelerated up 
to the defined marking speed. To make sure the laser is not switched on before the mirrors have reached 
the programmed angular velocity, a LaserOn Delay is automatically inserted before the start of a series of 
marking vectors. The length of the LaserOn Delay has to be matched with the Mark Speed.
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The Profiles page

G

Depending on the programmed Mark Speed, a difference occurs between the commanded position and the 
actual position of each mirror during execution of a vector. The difference in time between these two values 
is called lag. When the command value of the end of a vector is reached, the laser should not be turned off 
immediately; it must be turned off after a delay, to compensate for the lag. A LaserOff Delay is automatically 
inserted at the end of every series of marking vectors. The length of the LaserOff Delay has to be matched 
with the Mark Speed.

H
At the end of a series of marking vectors, the mirrors have to settle to a stop before executing the next 
command. For this reason, a Mark Delay is automatically inserted after the last marking vector in a series. 
For best performance, Mark Speed and Mark Delay have to be well matched.

I The time lag occurring while executing a series of marking vectors results in a rounding of the corners of the 
polygon. To control this a Poly Delay is inserted between each vector is a series of marking vectors (polyline).

J The position to move the z-axis output device. This is typically used with a linear translator assembly to move 
the focus point up and down in relation to the marking surface.

K Controls the Waveform mode of the laser. Currently supported only with SPI G3 laser systems.

L After the object has completed marking, the laser power will be set to zero % if this option is selected. This 
feature is useful if using certain laser types that require a separate signal to control the laser power.

M

The Use pens check box is only available when the object contains extended pen information. Pen infor-
mation is usually found in files of type *.PLT, *.DXF and *.DWG.. Using pens allows different line segments 
within one object to be assigned different Profiles. When the Use pens box is checked, the Current Profile 
control updates with the pens available in the object, and the associated color in which the line segments in 
the object are drawn on screen When the Mode field is set to 2 pass Cut and Clean, 3 pass Cut and Clean, or 
4 pass Cut and Clean, using pens is not available

N Controls the speed with which the laser spot moves on the target while executing a marking vector. The laser 
is on during the mark.

O
Controls the pulse width of the laser control signal. On CO2 lasers, this parameter is not available, as it is set 
automatically based on the value in the Laser Power field. For example, if the Laser Power field is set to 50% 
and the Frequency field to 5 KHz, the pulse width will be set automatically to 100 µs.

P Controls the speed with which the spot moves while “jumping” to the start of the next marking vector. The 
laser is off during the jump.

Q

Before executing a jump command, the Scan Head mirrors have to be accelerated up to the programmed 
Jump Speed. This acceleration results in a time lag. After the jump, the mirrors need time to settle to a 
complete stop. In order to take into account the time lag and settling time, a Jump Delay is inserted automat-
ically at the end of every jump vector. Note that a higher Jump Speed requires a longer Jump Delay. The 
entire time taken by a jump consists of the jump time and the Jump Delay and can be minimized by choosing 
optimum values of Jump Speed and Jump Delay.

R
Jump delays sometimes need to be longer for larger jumps, and shorter for smaller jumps. When a jump 
length is greater than the Vari. Jump Length, the Vari. Jump Delay is applied. When jumps are smaller than 
Vari. Jump Length, the standard Jump Delay is used. To disable, set to 0.

S
Jump delays sometimes need to be longer for larger jumps, and shorter for smaller jumps. When a jump 
length is greater than the Vari. Jump Length, the Vari. Jump Delay is applied. When jumps are smaller than 
Vari. Jump Length, the standard Jump Delay is used.

T When Wobble Width is greater than 0, the beam dithers (moves in a very small circle) while marking a vector. 
Changing the Wobble Frequency controls the speed at which this circle is moved.

U
When Wobble Width is greater than 0, the beam dithers (moves in a very small circle) while marking a vector. 
This has the effect of making the marked line wider. Changing the value of Wobble Width controls the width 
of the marked line.

V Select this option to place the laser in CW Mode. This option is only available on SPI G3 lasers.
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6.2.3.1	 ESTIMATING THE MARK TIME

The estimated marking time for an object or group of objects is calculated automatically and can be displayed in the 
objects Properties window.

To display estimated marking times

Do one of the following:
XX 	Right mouse click on a mark object or group of objects and select “Properties...”.
XX 	Select a mark object or a group of mark objects, then from the Main menu, select Object > Properties.
XX 	Select a mark object or group of mark objects and then press the F2 key.
XX The Properties window appears. Click the Performance details button to show the marking times.

The Performance details panel

A The total theoretical marking time for the object / group
B The total time of all the delays
C The total time of all the jump vectors
D The total time of all the marking vectors
E The total number of marking vectors in the outline portion of the object / group
F The total number of jump vectors in the outline portion of the object / group
G The total number of marking vectors in the fill portion of the object / group
H The total number of jump vectors in the fill portion of the object / group

6.2.3.2	 MICRO-VECTORING AND DELAYS

Controlled velocity marking and jumping is accomplished through a process call micro-vectoring. This process is 
illustrated in the following figure. The marking engine of the LEC-2 takes a vector and divides it into multiple shorter 
segments (micro-vectors) that are applied to the galvos at regularly spaced time intervals. This interval is known as 
the update interval. The galvo speed is controlled by the magnitude of the change in the output command at each 
update period.
The following figure shows the sequence of typical output commands for the X axis. The commands for the Y and Z 
axes are similar and are strictly locked in time with the X axis, differing only in magnitude of the discrete steps. As the 
X axis reaches successive targets X1,X2, etc., so do the Y and Z axes reach their corresponding targets, Y1, Z1,Y2, 
Z2, etc.

		            Micro-vector operation
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Because laser scanning systems are electro-mechanical in nature, various delays must be employed to compensate 
for inertial effects of the mirror and motor structure. These effects generally result in a positional lag of the deflection 
mirrors relative to the electrical command to make them move. These delays are used to properly time laser on/off 
and modulation signals relative to the mirror positions. In addition to compensating for lag times, the delays can be 
used to compensate for transient instability in mirror positions after a step to a new location. The following figures 
illustrate these effects.
Each system configuration requires fine-tuning of delay commands to ensure full and complete marking with no 
over burns. The individual delay settings are dependant on the dynamic response of the galvo/mirror combination in 
use, and the sensitivity characteristics of the marking medium. Determining these delays is typically a trial-and-error 
process. The delays are specified as part of the job definition described in the next section.

		         Micro-vectoring and laser timing relationships 

Optimizing the Jump delay

During a jump, the scan head mirrors accelerate to rapidly to get to the next mark position, ideally at the fastest 
speed possible to minimize overall marking time. As with all accelerations, mirror and system inertia create a slight 
lag at the beginning of the acceleration. Likewise, the system will require a certain delay (settling time) at the end of 
the jump as it decelerates to precisely the correct speed required for accurate marking. Acceleration and deceleration 
times and settling times will vary from system to system (weight of mirrors, type of galvanometer, etc.), and will vary 
depending on the requested jump speed and the length of the jump.

		               Effects of the Jump Command
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			   Jump Delay too short: Marking starts before mirrors properly settle. Too short of Jump delay 	
			   will cause marking to start before mirrors are properly settled, resulting in inadvertent 		
			   marking. Too long of a Jump Delay will have no visible effect, but marking is delayed so 		
			   overall job production time (marking time) increases.

Optimizing the Mark delay

A mark delay at the end of marking a line segment allows the mirrors to complete the move to the required position 
prior to executing the next mark command. 

			   Mark Delay too short: Marking continues into a jump vector. Too short of a Mark Delay will 		
			   allow the subsequent jump command to begin before the system mirrors get to their final
			   marking position. The end of the current mark will turn towards the direction of the jump 		
			   vector, as shown to the right. Too long of a Mark delay will cause no visible marking errors, 	
			   but will add to the overall processing time. 

Optimizing the Laser On Delay

The Laser On Delay can be used to prevent burn-in effects at the start of a vector. This delay in time before the laser 
is turned on is typically used to turn on the laser after the first few micro-steps of a mark command to ensure that the 
laser's motion control systems (mirrors, Etc.) are “up to speed” before marking. This delay can have either a positive 
or a negative value and will vary with different systems and lasers because of galvo motor and mirror inertias, and 
laser activation timings.

		                  Laser On Delay too short: Burn-in at vector start points
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			     Laser On Delay too long: Marking starts too late, skips vector start points because the 		
			     vector mark has started before the laser has switched on

Optimizing the Poly Delay

A polygon delay is a delay automatically inserted between two marking segments where two vectors meet. The 
minimum delay allows enough time for the galvos and mirrors to “catch up” with the command signal before a new 
command is issued to move on to the next point.

		                  Poly Delay too short: Characters not well formed

		                  Poly Delay too long: Burn-in at vector junctions

Optimizing the Laser Off Delay

The Laser Off Delay is used to prevent burn-in effects at the end of a vector. This delay in time before the laser is 
turned off is typically used to turn off the laser just before the last few micro-steps of a mark command to ensure 
that the marking stops exactly where it is desired to stop. The goal is to adjust the Laser Off Delay to ensure uniform 
marking with no variations of intensity throughout the desired vector.
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			     Laser Off Delay too short: Marking stops too soon, skipping vector endpoints. Typically, too 	
			    short of a delay will cause skipping of vector endpoints as the laser switches off too early.

		                  Laser Off Delay too long: Marking stops too late, burn-in at vector end points.Typically, too 	
			     long of a delay will cause burn-in at the end of a vector where the laser stays on too long.

Tips on optimizing Profiles

Take care of the basics when setting up a scanning system. Best results are achieved when the input beam is 
perfectly aligned cleanly into the scan head without contacting non-transmissive surfaces, expanded and collimated 
so the energy floods the mirrors without overspill. eg. using a 10mm scan head, the entry diameter is just under 
10mm. Larger and the beam will contact the housing, causing interference, and compounding the focus at the target. 
Pay strict attention to parallelism between scan head and target. Be aware the wider the angle scanned to the field 
extremities, the more the spot will change from a perfect circle, and when using focusing lenses after the mirrors, 
more diffraction will be introduced.

XX Ensure any pointer laser is aligned to the main processing beam. Mark 5 points (center and corners), and position 
the pointer to the same points, adjusting until it falls perfectly on the marks.

XX Mark a series of 10 close parallel lines across roughly half the field size. Do not worry about the starts and ends 
of the lines at this point. The first goal is to find the best laser and marking speed settings for the absorption of the 
energy by the target material.

XX Set Line 1 at the minimum and Line 10 at the maximum Mark speed you feel would suit the material. Set Lines 2 
to 9 in incremental Mark speed steps between the minimum and maximum. This gives an indication of the best 
results, but may be slower or faster than expected. You may need to adjust the speed range and mark again. 
When you have a good result, reduce the range to fine-tune the Mark speed.

XX Set the best Mark speed to all lines. Set a range of incremental laser frequencies between the minimum and 
maximum you feel may suit the material and mark again. Different materials may absorb differently at differing 
frequencies, and you may see further improvements. 
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XX When you have found the best laser parameters, set all lines the same and repeat the incremental Mark speed 
variations either side of the setting for the frequency optimization. Repeat these steps until you have the best 
results.

XX Use a step-by-step approach to optimize delays, rather than changing several parameters at the same time. 
Download the delays.plt file and place in the marker/graphics/vector folder. Open a new Job and import the delays 
graphic. 4 simple lines will be marked, joined by a double-Jump.

XX The file is in its simplest form and will mark over 80% of the field, starting with the index lines A-B-C. The 
scanners will then double-jump without marking via C-D-E, before marking the calibration lines E-F-G.

XX Set the Jump speed the same as the Mark speed, the Laser On, Jump and Mark delays relatively long (800µs), 
and the Poly and Laser Off delays relatively short (80µs).

XX Mark and check Point E. A tail in the direction D-E leading into the marked line E-F should mark. If the tail is, say 
2mm, reducing the Laser On delay to 400µs will roughly halve it to 1mm. This is speed and laser dependent. 
Continue reducing the Laser On delay until Point E starts the mark perfectly in the middle of the A-B index line.

XX Now increase the Jump speed until Point E starts to lose position. Reduce the Jump speed slightly until Point E is 
clear again.

XX Now reduce the Jump delay to 400µs. If you see no difference, halve it again. Keep reducing the Jump delay until 
Point E starts to lose position, then slightly increase the Jump delay until Point E starts the mark perfectly in the 
middle of the A-B index line.

XX Because a jump is a repositioning of the mirrors, you want to minimize these process timings. The faster the Jump 
speed, the longer the Jump delay to allow the mirrors to settle, and you may have to reduce the Jump speed to 
reduce the Jump delay to gain faster overall process times.

XX Now concentrate on Point F where the 2 vectors E-F and F-G meet. If Point F over-burns, reduce the Poly delay. 
If Point F is rounded, increase the Poly delay until you have a crisp result.

XX Finally, check Point G where the vectors end. Increase the Laser Off delay until Point G ends the mark perfectly 
in the middle of the B-C index line. Reduce the Mark delay until the mark moves away or over-burns, then reduce 
slightly until it marks perfectly in the middle of the B-C index line again.

You have now set the optimum parameters for the material. Do not forget to save these parameters by adding them 
to a Profile and naming as your choice (refer to Managing Profiles in the cabLase Editor 5 User Guide provided as a 
.pdf document in your marker/documentation folder).
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6.2.4	 OBJECT SETTINGS

Use the Object Settings to configure:

•	 The Object Name

•	 The on screen Color

•	 When the Outline and Fill will mark

•	 Jump display properties

To modify Settings Values

XX Click on the Mark Object to be modified.
XX Right-mouse click and select “Properties...”.
XX Click on the Settings tab. The Settings page displays the object settings values.

The Settings page

A This name will appear in the Object Manager, and in any messages that appear referencing the object.
B Change the color of the selected object on screen. 
C Select between vector, dot and circle dot marking styles (not available on all releases of cabLase).
D Check this box to mark the outline portion of the object. By default, this field is enabled.
E If Fill has been enabled, select this option. By default, this field is disabled.

F Shows the jump vectors, indicating the path the marking beam spot takes while moving to the next marking 
vector. By default, this field is disabled.

G To mark multiple objects in a job onto a continuous moving part (like wire, etc.), endless sequences of marks 
can be attained by resetting the starting point of the object using this option.

H Enter the spacing, in field distance on the moving part, between successive objects.
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6.2.5	 BITMAP GRAPHIC OBJECT

A bitmap is a rectangular grouping of pixels that form a visual image. In laser marking, the bitmap image must be 
“rastered” to render it with the laser. Because the scan head is a vector output device, this rastering action must be 
simulated, with the laser spot tracing across the image one row of pixels at a time. This can be a time consuming 
process, and it will usually take longer to mark a bitmap representation of an object than a vector representation. 
Some images, however, lend themselves only to bitmap marking, i.e. photographs. cabLase Editor 5 supports 
importing bitmap files with monochrome, grayscale or color content. All color images, however, will be converted to 
grayscale internally after import.

To modify Bitmap Graphic settings

XX Click on the Bitmap Graphic to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Bitmap object settings values for a multi-tonal bitmap.

The Bitmap graphic Settings page

A Adjusts the spacing of pixels within the bitmap image, in dots/inch.
B Adjusts the range between the lightest and darkest pixel. A higher contrast setting will increase this range.

C Adjusts the overall lightness of the image. Increasing this value will cause the laser to stay on longer at each 
pixel.

D Applies the standard error diffusion algorithm to a grayscale bitmap, converting it to a monochrome bitmap. 
E Reverses the light and dark pixels in the image, using the middle of the range as a reference point.

F Forces the lines of pixels in the bitmap to all be marked in the same direction. This improves pixel alignment 
when marking at high speed.

G When marking, pixels that have a value of black (non-marking) will be jumped over by the laser beam, 
reducing the overall marking time.

H When bitmaps are rotated, black pixels may be added to the bitmaps corners. To add white pixels instead, 
select this checkbox.

I Select this option to lock the Y mirrors in place and only scan the X mirrors. The part to be marked is then 
translated under the marking head in the y axis.
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6.2.6	 POINT ARRAY OBJECT

Point objects direct the laser to specific coordinates and then turn the laser on for a specified time. Point objects are 
usually set up as an array of points arranged in rows and columns. If specifically placed point objects are needed, use 
multiple objects of one point each. This object is used for applications such as perforating or drilling into a material.

To modify Point settings

XX Click on the Point Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Drill Object settings values.

The Point object Settings page

A The size each individual dot is displayed on the screen in cabLase Editor 5. This value has no effect on the 
mark.

B The length of time the laser is on during a single pulse.
C The time the laser is off between successive pulses.
D The number of times to pulse the laser at each dot location.
E The number of rows in a point object array.
F The number of columns in a point object array.
G Total number of points in an array. Note that a setting of 1 creates a single point.
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6.2.7	 POLYGON OBJECT

Polygons are markable objects with a specified number of sides of equal length, each side being the same distance 
from the center of the object.

To modify Polygon settings

XX Click on the Polygon to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Polygon object settings values.

The Polygon Settings page

A The number of straight-line segments the object has. For example, to create a triangle, use a value of three. 
Circles are specified by setting this value to a large number. (> 10).

B The angle where the first line segment starts. An angle of 0 is the 12:00 position.
C The angle where the last line segment ends.
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6.2.8	 RECTANGLE OBJECT

Rectangle Objects are markable objects with four sides, and optional radiused corners. The radius changes as the 
object is sized.

To modify Rectangle settings

XX Click on the Rectangle to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Rectangle object settings values.

The Rectangle Settings page

A The radius of the corner as a percent of the size of the rectangle.
B The number of straight line segments used to make up the corner radius.
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6.2.9	 ROUNDED RECTANGLE OBJECT	

Rounded Rectangle Objects are markable objects with four sides, and optional radiused corners. The radius of the 
corners is fixed and independent of the size of the rectangle.

To modify Rounded Rectangle settings

XX Click on the Rounded Rectangle to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Rectangle object settings values.

The Rounded Rectangle Settings page

A The radius of the corner.
B The number of straight line segments used to make up the corner radius.
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6.2.10	 TEXT AND BARCODE OBJECTS

cabLase Editor 5 has two object types that represent strings:

•	 Text Objects

•	 Barcode objects

Text Objects

Text Objects are a collection of alphanumeric characters that represent words, sentences, and numbers. Text objects 
can be either created from TrueType fonts or Laser fonts. TrueType fonts are outline fonts and are installed in the 
Windows operating system. Laser fonts are specially designed fonts that are installed in the cabLase Editor 5 font 
library.

The Text object uses a different icon for each font type

A Icon representing a TrueType font based text object
B Icon representing a Laser font based text object

Shows ...

Top Typical TrueType font
Bottom Typical Laser font
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Dot Matrix Laser Fonts

Dot Matrix Laser Fonts provide a fundamentally different way to mark text from the standard vector-marking format. 
With Dot Matrix Laser Fonts, the text is comprised of closely spaced dots, similar to a bitmap object. The Dot Matrix 
Laser Font offers control over the number of times the laser will fire at each dot. The following images illustrate some 
of the effects that are achieved by adjusting the dot matrix parameters.

Shows ...

Left On screen display using dot display size of 200 bits
Right On screen display using dot display size of 50 bits

To modify Dot Matrix Laser Font settings

XX Click on the Dot matrix text style object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Text object settings values.
XX In the Mark Style drop-down, select Dot.

The Dot Settings page

A
Changes the size of each individual dot as it is displayed in cabLase Editor 5. This value has no effect on the 
actual mark. If the dot size is set to the effective spot size of the laser on the material, correct dot spacing can 
be visualized on screen.

B The length of time the laser is on during a single pulse.
C The time the laser is off between successive pulses.

D This setting controls the number of times the laser will fire at each dot within the array of dots that comprise a 
character. The laser is turned on using the settings of frequency and pulse width found on the Profiles page.
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6.2.10.1	To modify Horizontal and Vertical Text String settings

XX Click on the Text object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the String tab. The String page displays the Text object string values.

The Horizontal and Vertical Text Object String page

A
The currently selected font. There are two types of fonts:
•	 TrueType fonts
•	 Laser fonts

B The string value of the object

C

Change the text flow to:
•	 Horizontal (default) - Text is marked along the horizontal axis.
•	 Vertical - Text characters are placed vertically, each one under the previous
•	 Radial Variable - Text is arranged in a circular fashion, and can be scaled independently in the x and y 

axes.
•	 Radial fixed - Text is arranged in a circular fashion, and the object is displayed with three dotted line 

circles. The inner circle represents the maximum descent, the middle circle represents the circumference 
of the text itself, and the outer circle represents the maximum text height.

•	 Circumferential - Text can be marked around the outside diameter of cylindrical parts by using a rotary 
motion system.

D Change the spacing between characters

E Enabled only when Radial - fixed is selected in the String orientation box. Change the width of the characters 
independent of the height

F Change the spacing between lines. This field is only enabled if there is more than one line of text in the edit 
box.

G Change the Bold attribute of a True Type text object.
H Change the Italics attribute of a True Type text object
I Use the justify buttons to control the alignment of multiple lines of text.
J Use this Windows tool to insert special characters into the string edit box.
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6.2.10.2	To modify Paragraph Text String settings

XX Click on the text to be modified.
XX Right mouse click and select “Properties...”.
XX Click on the String tab. The String page displays the Text object string values.

The Text Object paragraph property page

A
To space lines further apart, enter a positive number. To space lines closer together, enter a negative number. 
A value of zero uses the default line spacing built into the font. Note that if the current text is a single line, this 
field is disabled.
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6.2.10.3	To modify Radial Text String settings

XX Click on the text object to be modified. 
XX Right mouse click and select “Properties...”.
XX Click on the String tab. The String page displays the Text object string values.

The Text Object radial property page

A
Select from the following:
•	 CW fit
•	 CCW fit
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6.2.10.4	To modify Circumferential Text String settings with Intelligent Motion

i Note!
This function is available only if a compatible motion controller is detected by cabLase Editor 5 and an appropriate 
motion configuration has been created.

	
XX Click on the text object to be modified.
XX Right mouse click and select “Properties...”.
XX Click on the String tab. The String page displays the Text object string values.
XX From the String orientation drop down list, select “Circumferential”. A new tab appears in the Property window 

called Motion.
XX Click the Motion tab. The Motion page displays the motion settings.

The Text Object Motion property page

A Initial velocity of the motor
B The acceleration rate of the motor when changing velocity.
C The radius of the cylindrical part to be marked.
D Reverses the rotation direction of the motor when indexing between individual characters in the text string.
E The maximum velocity the motor will reach during a move.
F The deceleration rate when the motor is coming to a stop.

G Change the delay between when the motor has stepped to its final position and when the next character is 
marked. This delay allows settling time for the motor.

	 .
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6.2.11	 BARCODE OBJECTS

Barcode Objects represent numeric and/or alpha characters as machine-readable images. CabLase Editor 5 Barcode 
Objects are offered in several different symbologies, including Code 39, Extended Code 39, HIBC, CodaBar, Code 
93, Code 128, EAN/UCC 128, Interleaved 2 of 5 (ITF), POSTNET (Zip+4, Zip+6), UPC A, UPC E, EAN 8, EAN 13, 
BookLan, Data Matrix (ECC200), Denso QR code, PDF417

6.2.11.1	To modify Barcode String settings

XX Click on the Barcode Object to be modified.
XX Right-mouse click and select “Properties...”.
XX Click on the String tab. The String page displays the Barcode Object string values.

The Barcode Object String property page

A The character string data for the object. Refer to the barcode specific sections that follow for the rules on 
what characters are allowed for each barcode type.

B Select this option to automatically position a text string, which represents the string content of the barcode. 
This option is not available in Stand-Alone mode.

C The font used to display and mark the text string.
D Where the string is positioned relative to the barcode: Bottom, Top, Left, Right
E The direction the text string is drawn and marked.
F The height of the text string as a percentage of the barcode height.

G

The distance from the closest part of the text to the edge of the barcode, as a percentage of the barcode 
height.

Left: Human Readable Text String position Bottom, Orientation 0
Middle: Human Readable Text String position Top, Orientation 180
Right: Human Readable Text String position Right, Orientation 90
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6.2.11.2	To modify Code 39 settings

Code 39 is a variable length symbology that can encode a maximum of 100 characters in a single string. Each bar 
code is framed by a start/stop character represented by an asterisk(*). The Asterisk is reserved for this purpose and 
may not be used in the body of the message. cabLase Editor 5 automatically adds the start and stop code to each 
barcode, so do not include them in the string.

XX Click on the Code 39 Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The Code 39 tuner property page

A

Normal Code 39 is a variable length symbology the can encode the following 44 characters:
•	 1234567890ABCDEFGHIJKLMNOPQRSTUVWXYZ-.*$/+%. If the string contains lower case characters, 

cabLase Editor 5 will convert them to upper case, even though they appear as lower case in cabLase 
Editor 5.

B

Full ASCII is a modification of the Normal (standard) version that can encode the complete 128 ASCII 
character set (including asterisks). The full set of characters uses the concept of shift characters to change 
the meanings of the rest of the characters in the Normal Code 39 set. Please refer to the Code 39 specifica-
tions for more details.

C
HIBC, or “Health Industry Bar Code” is a specification for a standard method of encoding data using Code 39 
in health care applications. When using this option, cabLase Editor 5 automatically adds a plus character (+) 
as the first character, and also calculates and adds a Modulo 43 check digit.

D The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

E
Code 39 symbologies consist of bars and spaces with only two element widths, Narrow and Wide, where the 
width of the wide elements is a fixed multiple of the width of the narrow elements. The specifications for Code 
39 allow a Narrow to Wide Ratio of 20% to 30% (2.0 to 3.0).

F Code 39 allows for an optional (modulo 43) check. When this option is enabled, cabLase Editor 5 will 
automatically calculate and append the proper check character to the symbol.

G Inverts the dark and light bars, and adds a quiet zone around the barcode.
H The size of the quiet zone as a percentage of the barcode size
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6.2.11.3	To modify CodaBar settings

CodaBar is a variable length symbology that allows encoding of the following 20 characters:

•	 0123456789-$:/.+ABCD

A maximum of 100 characters can be encoded in a single string. CodaBar uses the characters A B C and D only as 
start and stop characters. Thus, the first and last digits of a CodaBar message must be A B C or D and the body of 
the message should not contain these characters. If lower case letters are used for A B C or D, cabLase Editor 5 will 
convert them to upper case, even though lower case is displayed in cabLase Editor 5.

XX Click on the CodaBar Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The CodaBar tuner property page

A The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

B
CodaBar symbologies consist of bars and spaces with only two element widths, Narrow and Wide, where 
the width of the wide elements is a fixed multiple of the width of the narrow elements. The specifications for 
CodaBar allow a Narrow to Wide Ratio of 20% to 30% (2.0 to 3.0).

C  Inverts the dark and light bars, and adds a quiet zone around the barcode.
D The size of the quiet zone as a percentage of the barcode size
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6.2.11.4	To modify Code 93 settings
	
Code 93 is a variable length symbology that can encode the complete 128 ASCII character set. A maximum of 
100 characters can be encoded in a single string. Code 93 incorporates two check digits as an added measure of 
security, and the barcode is also framed by a special start/stop character. cabLase Editor 5 will automatically add the 
start and stop characters as well as the check digits, so they should not be included as part of the string value.

XX Click on the appropriate barcode object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The Code 93 tuner property page

A The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

B Inverts the dark and light bars, and adds a quiet zone around the barcode.
C The size of the quiet zone as a percentage of the barcode size
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6.2.11.5	To modify POSTNET settings

POSTNET (POSTal Numeric Encoding Technique) is a 5, 9 or 11 digit numeric only bar code symbology. The bar 
code may represent a five digit ZIP code (32 bars), a nine digit ZIP + 4 code (52 bars) or an eleven digit Delivery 
Point code (62 bars). cabLase Editor 5 will ignore non-numeric data in the bar code string when creating the bar code 
image, even though the non-numeric data is displayed in cabLase Editor 5.

XX Click on the appropriate barcode object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The POSTNET tuner property page

A The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

B Inverts the dark and light bars, and adds a quiet zone around the barcode.
C The size of the quiet zone as a percentage of the barcode size
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6.2.11.6	To modify UPC settings

UPC-A and UPC-E are numeric only symbologies used in retail applications. When specifying UPC-A or UPC-E 
codes, the string may contain 6,7, 11 or 12 digits. If the string contains 6 or 7 digits, cabLase Editor 5 will generate a 
UPC-E symbol. In a 7 digit string, the 7th digit will be removed. If the string contains 11 or 12 digits, cabLase Editor 
5 will generate a UPC-A symbol. In a 12 digit string, the 12th digit will be removed. cabLase Editor 5 automatically 
calculates and appends a check digit when creating the bar code image.
Both UPC-A and UPC-E allow for a supplemental two or five digit number to be appended to the main bar code 
symbol. The supplemental is simply a small additional bar code that is added onto the right side of a standard UPC 
symbol. To include a supplemental number, append it to the main number, with a comma separating it from the main 
number as in: 123456,12.

XX Click on the appropriate barcode object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The UPC tuner property page

A The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

B Inverts the dark and light bars, and adds a quiet zone around the barcode.
C The size of the quiet zone as a percentage of the barcode size
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6.2.11.7	To modify Code 128 settings

Code 128 is a variable length, high density, alphanumeric symbology, and can encode a maximum of 100 characters 
in a single string. Code 128 has 106 different bar and space patterns, and each pattern can have one of three 
different meanings, depending on which of three different character sets is employed. In addition to ASCII characters, 
Code 128 also allows encoding of four special function codes (FNC1 - FNC4). Please refer to the Code 128 specifi-
cation for more details.

XX Click on the Code 128 Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The Code 128 tuner property page	

A Supports the special function codes (FNC1 - FNC4). Please refer to the Code 128 specification.

B
EAN/UCC 128 (European article numbering) is a special form of the Code 128. EAN 128 is based on 
Code128 but has a double start character. Also the code does not support function codes FNC2 - FNC4, and 
uses FNC-1 as part of the start code in the symbol.

C
cabLase Editor 5 will automatically select the proper character sets and insert the necessary start character 
and shift codes so that the resulting bar code will be as short as possible. The check digit will also be calcu-
lated automatically.

D Use character subset A which includes the standard ASCII symbols, digits, upper case letters, and control 
codes.

E Use character subset B which includes standard ASCII symbols, digits, upper and lower case letters.
F Use character subset C which compresses two numeric digits into each character, providing excellent density

G The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

H Some applications for EAN/UCC 128 require an additional Mod 10 check digit, which can be enabled by 
selecting this option.	

I Inverts the dark and light bars, and adds a quiet zone around the barcode.
J The size of the quiet zone as a percentage of the barcode size
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6.2.11.8	To modify Interleaved 2 of 5 settings	
	
Interleaved 2 of 5 is a high density variable length numeric only symbology that encodes digit pairs in an interleaved 
manner. The odd position digits are encoded in the bars, and the even position digits are encoded in the spaces. 
Because of this, Interleaved 2 of 5 bar codes strings must consist of an even number of digits. If an odd number of 
digits is entered for the string, cabLase Editor 5 will Left-Pad one zero to the string entered, even though cabLase 
Editor 5 does not display the Left-Padded digit.

XX Click on the 2 of 5 Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The Interleaved 2 of 5 tuner property page

A The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

B
Interleaved 2 of 5 symbologies consist of bars and spaces with only two element widths, Narrow and Wide, 
where the width of the wide elements is a fixed multiple of the width of the narrow elements. The specifica-
tions for Interleaved 2 of 5 allow a Narrow to Wide Ratio of 20% to 30% (2.0 to 3.0).

C
Interleaved 2 of 5 optionally allows for a weighted modulo 10 check character for special situations where 
data security is important. When this option is selected, CabLase Editor 5 will automatically calculate and 
append the proper check character to the symbol.

D Inverts the dark and light bars, and adds a quiet zone around the barcode.
E The size of the quiet zone as a percentage of the barcode size
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6.2.11.9	To modify EAN settings

EAN or European Article Numbering system (also called JAN in Japan) is a European version of UPC. It uses the 
same size requirements and a similar encoding scheme as UPC codes. When specifying EAN-8 or EAN-13 codes, 
the string may contain 7, 8, 12 or 13 digits. If the string contains 7 or 8 digits, cabLase Editor 5 will generate an 
EAN-8 symbol. In an 8 digit string, the 8th digit will be removed. If the string contains 12 or 13 digits, cabLase Editor 
5 will generate a UPC-13 symbol. In a 13 digit string, the 13th digit will be removed. cabLase Editor 5 automatically 
calculates and appends a check digit when creating the bar code image.
Like UPC, both EAN-8 and EAN-13 allow for a supplemental two or five digit number to be appended to the main bar 
code symbol. The supplemental is simply a small additional bar code that is added onto the right side of a standard 
EAN symbol. To include a supplemental number, append it to the main number, with a comma separating it from the 
main number as in: 123456,12.

XX Click on the EAN Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The EAN tuner property page

A Encodes a standard EAN symbol.

B
Encodes a BookLAN symbol, which is an EAN-13 symbol consisting of the first 9 digits of a ISBN number 
preceded by the digits 978 and terminated with a standard EAN check digit. Please refer to the BookLAN 
specification.

C The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

D Inverts the dark and light bars, and adds a quiet zone around the barcode.
E The size of the quiet zone as a percentage of the barcode size
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6.2.11.10To modify Data Matrix settings

Data Matrix is a high density 2 dimensional matrix style barcode symbology that can encode up to 3000 characters 
from the entire 256 byte ASCII character set. The symbology is built on a square (or optionally rectangular) grid 
arranged with a finder pattern around the perimeter of the bar code symbol.

XX Click on the Data Matrix Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 

The Data Matrix tuner property page

A Select the resulting shape of the symbol. Automatic will generate a square grid, and the other selections will 
generate rectangular grids.

B

Select from the following ECC (Error Checking and Correction) options:
•	 ECC 000 - Provides no error correction
•	 ECC 050 - Provides error correction for damage of up to 2.8% of the marked symbol
•	 ECC 080 - Provides error correction for damage of up to 5.5% of the marked symbol
•	 ECC 100 - Provides error correction for damage of up to 12.6% of the marked symbol
•	 ECC 140 - Provides error correction for damage of up to 25% of the marked symbol
•	 ECC 200 - The latest and most advanced version of Data Matrix, which employs a Reed-Solomon error 

correction algorithm along with a code set switching mechanism that is much more efficient at packing 
data into the symbol. This option supports all. 

C

When specifying ECC 000 - ECC 140, select from the following Data formats, which defines the type of data 
that may be encoded in the symbol:
•	 1 - Numeric digits 0 to 9 and the space character
•	 2 - Upper case alpha A-Z and the space character
•	 3 - Upper case alphanumeric A-Z, 0-9 and the space character
•	 4 - A-Z, 0-9, space, minus, period, comma and forward slash
•	 5 - 7 bit ASCII - all ASCII characters between ASCII 0 to ASCII 127
•	 6 - 8 bit ASCII - all ASCII characters between ASCII 0 to ASCII 255

D Adjust the size of each individual cell as a percentage of the normal size cell
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E

When this option is selected, then the tilde character (~) can be used in the string as an indicator that the 
character(s) following the tilde are to be interpreted with a special meaning. An example is when encoding 
UID codes. If this option is not selected, then the string is assumed to not contain any special function codes. 
For most applications, this option would be used.

F Inverts the dark and light bars, and adds a quiet zone around the barcode.
G The size of the quiet zone which surrounds the symbol as the number of cells.

	

	

6.2.11.11To modify QR Code settings	

QR code is a two-dimensional matrix symbol which consists of square cells arranged in a square pattern and can 
encode the following 4 character sets:

•	 Numeric data (0 to 9)

•	 Alphanumeric data (0 to 9, Uppercase A to Z, and nine special characters -- space, &%*+-./:

•	 8-bit byte data (JIS 8-bit character set (Latin and Kana) in accordance with JIS X0201)

•	 Kanji characters (Shift JIS values 8140h to 9FFCh and E040h to EAA4h shifted from JIS X0208)

XX Click on the QR Code Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 



162 1626	 JOB ENTITIES	

The QR Code tuner property page

A

Select from the following models: 

B

•	 Select the Reed-Solomon error correction level from the following:
•	 L (7%)
•	 M (15%)
•	 Q (25%)
•	 H (30%)

C Adjust the size of each individual cell as a percentage of the normal size cell
D Inverts the dark and light bars, and adds a quiet zone around the barcode.
E The size of the quiet zone which surrounds the symbol as the number of cells.

	

6.2.11.12To modify PDF417 settings	

PDF417 is a high density 2 dimensional bar code symbology that essentially consists of a stacked set of smaller bar 
codes. The symbology is capable of encoding the entire 255 ASCII character set. A maximum of 2710 characters can 
be encoded in a single string.

XX Click on the PDF417 Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Tuner tab. The Tuner page displays the Barcode Object tuner values. 
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The PDF 417 tuner property page

A

Select from the following Compaction modes:
•	 Auto/EXC/Bin/Num - This mode allows full switching between the three standard data compaction modes 

and provides the maximum data compression possible
•	 Auto/EXC/Bin - This mode is similar to Auto/EXC/Bin/Num except it does not allow switching to Numeric 

mode.
•	 EXC mode only - Extended Alphanumeric Compaction, which supports the encoding of all printable ASCII 

characters and can compress approximately 2 characters per code word.
•	 Binary mode only - Supports encoding the entire ASCII character set, and can compress approximately 

1.2 characters per code word.
•	 Numeric mode only - Supports encoding only the numeric characters 0 - 9 and can achieve data 

compression of approximately 3 characters per code word.

B

Select from the following Security levels:

C If the Security Level is set to Automatic, the Error Correction overhead can be specified from 0 to 99%.

D
The default maximum number of row and columns allowed in a PDF symbol is 30 rows and 90 columns. If 
smaller values for these parameters are specified, an upper limit is defined for the overall height or width of 
the generated symbol.

E
The default maximum number of row and columns allowed in a PDF symbol is 30 rows and 90 columns. If 
smaller values for these parameters are specified, an upper limit is defined for the overall height or width of 
the generated symbol.

F Defines the overall shape of the symbol

G The Bar Width Reduction parameter allows setting of a reduction or gain (-99 to 99%) in the width of all the 
solid bars in a barcode, as a percentage of the Narrow bar width.

H
Select this option to generate a Truncated PDF417 symbol. A truncated symbol is almost identical to a 
standard PDF417 symbol except that the right row indicator code words and the right hand stop pattern are 
omitted and replaced with a narrow bar one module wide.	

I Inverts the dark and light bars, and adds a quiet zone around the barcode.
J The size of the quiet zone which surrounds the symbol as the number of cells.
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6.2.12	 FILLING BARCODES WITH DOTS OR CIRCLES

Dot mode provides a fundamentally different way to mark barcodes from the standard vector-marking format. In Dot 
mode, the barcode is comprised of closely spaced dots, similar to a bitmap object. The Dot mode barcode object 
offers additional control over dot spacing, and the number of times the laser will fire at each dot. The following 
images illustrate some of the effects that are achieved by adjusting the Dot parameters. In Circle mode, the barcode 
is comprised of closely spaced circles. The Circle Dot mode barcode object offers additional control over circle dot 
spacing, the number of sides on each circle, and the diameter of each circle.

Shows ...

Left Section of a Data Matrix object with 4 rows / columns, dot display size 30
Right Section of a Data Matrix object with 2 rows / columns, circle diameter 150

6.2.12.1	To modify Linear bar code Dot Setting Values

XX Click on the linear barcode object to be modified
XX Right-mouse click and select “Properties...” 
XX Click on the Settings tab. The Settings page displays the Text object settings values
XX In the Mark Style drop-down, select Dot.
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The Dot Settings page

A Control the spacing between adjacent dots.
B Changes to the size of the dot on screen have no effect on the mark.
C The length of time the laser is on during a single pulse.
D The time the laser is off between successive pulses.

E This setting controls the number of times the laser will fire at each dot within the array of dots that comprise a 
character. The laser is turned on using the settings of frequency and pulse width found on the Profiles page.

F Display and mark the rectangular outline that represents each individual bar.

	

6.2.12.2	To modify 2D bar code Dot Setting	
	

XX Click on the 2D barcode object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Text object settings values.
XX In the Mark Style drop-down, select “Dots”.

The Dot Settings page

A Select the number of rows and columns of dots to place in each cell.
B Control the spacing between adjacent dots.
C Changes to the size of the dot on screen have no effect on the mark.
D The length of time the laser is on during a single pulse.
E The time the laser is off between successive pulses.

F This setting controls the number of times the laser will fire at each dot within the array of dots that comprise a 
character. The laser is turned on using the settings of frequency and pulse width found on the Profiles page.

G Display and mark the rectangular outline that represents each individual cell.
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6.2.12.3	To modify linear bar code Circle Settings

XX Click on the linear barcode object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Text object settings values.
XX In the Mark Style drop-down, select “Circles”.

The Circles Settings page

A The spacing between adjacent circles.
B The number of straight line vector segments that make up the circle.
C The diameter of each individual circle.
D Display and mark the rectangular outline that represents each individual bar

		

6.2.12.4	To modify 2D bar code Circle Settings	
	

XX Click on the linear barcode object to be modified. 
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Text object settings values.
XX In the Mark Style drop-down, select “Circles”.
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The Circles Settings page

A The number of rows and columns of circles that are placed in each cell.
B The spacing between adjacent circles.
C The number of straight line vector segments that make up the circle.
D The diameter of each individual circle.
E Display and mark the rectangular outline that represents each individual cell

6.2.13	 VECTOR GRAPHIC OBJECT
	
Unlike JPEGs, GIFs, and BMP images, vector graphics are not made up of a grid of pixels. Instead, vector graphics 
are comprised of paths, which are defined by a start and end point, along with other points, curves, and angles along 
the way. A path can be a line, a square, a triangle, or a curvy shape. These paths can be used to create simple 
drawings or complex diagrams. Paths are even used to define the characters of specific typefaces.
Because vector-based images are not made up of a specific number of pixels, they can be scaled to a larger size 
and not lose any image quality. When you scale up a vector graphic, the edges of each object within the graphic stay 
smooth and clean. Vector images are ideal for use with laser marking equipment, as the scan head is a vector output 
device. 

6.2.13.1	To modify Vector Graphic curve settings

i Note!
Curve settings are available only on Vector objects that were originally imported from a DXF or DWG file.

XX Click on the Vector Graphic to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Settings tab. The Settings page displays the Vector object settings.
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The Vector graphic Settings page

A The size that each individual Point entity is displayed on the screen in cabLase Editor 5. This value has no 
effect on the mark.	

B The length of time the laser is on during a single pulse at each Point entity.
C The time the laser is off between successive pulses at each Point entity.
D The number of times to pulse the laser at each Point entity location. cabLase Editor 5.

E Select the number of straight line vector segments to use when rendering an arc section into vectors. More 
segments will produce a smoother curve, but will increase the number of vectors.

F Select the number of straight line vector segments to use when rendering a spline section into vectors. More 
segments will produce a smoother curve, but will increase the number of vectors.

G Select the number of straight line vector segments to use when rendering text into vectors. More segments 
will produce a smoother curve, but will increase the number of vectors.

H Select the number of straight line vector segments to use when rendering a Bezier curve section of a text 
curve into vectors. More segments will produce a smoother curve, but will increase the number of vectors.

Importing Graphics at actual size

Some vector graphics files, such as EMF, DXF and DWG files, contain information to scale the vector coordinates 
contained in the file into real world dimensions. If the file contains this Unit information, cabLase Editor 5 can use 
it to import the graphic to “actual size”. Without this Unit information, cabLase Editor 5 will import the graphic using 
dimension units of BITS. See “Coordinate System Conventions” on page 5 -1. Refer to the following table for import 
behavior with the different graphics files. cabLase Editor 5.
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6.2.13.2	When importing DXF and DWG files

XX Form the Main menu, click File > Import. The Import dialog box appears.
XX Browse to a DXF or a DWG file and click Open. The Import AutoCAD file dialog appears.

The Import AutoCAD dialog window

A The version of the file being imported.

B The Units that were detected in the file. AutoCAD version 14 and older did not support real world units and 
the graphic units will be indicated as “Unspecified”.

C

Select what action cabLase Editor 5 should take when importing the graphic:
•	 Automatic - This is the default setting. If the file was saved with real world units, it will be imported and 

sized in cabLase Editor 5 to actual size. If the units in the file are unspecified, cabLase Editor 5 assumes 
the units are Millimeters when converting coordinates.

•	 English - Forces cabLase Editor 5 to use units of Inches when converting coordinates.
•	 Metric - Forces cabLase Editor 5 to use units of Millimeters when converting coordinates.

D If an image will size import larger that the field size, this option will scale the image to just fit into the field. 
Note that the graphic will no longer be actual size.

E This option will center the image in the field independent of where it was drawn with respect to the origin.
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6.3	 DYNAMIC STRINGS

Changing the String at Run time (Dynamic Strings)

One of the most powerful features of cabLase Editor 5 is the ability to dynamically change the string content of 
barcode and text objects while the job process is running. Changing the string can be accomplished in a number of 
different ways:

•	 Configuring the object to prompt the machine operator to enter a new string using the Supply String Source 
options. Not available in Stand-Alone mode.

•	 Configuring the object to automatically serialize it’s text string using the Serialize Source option.

•	 Reading consecutive strings from a text file using the TextMerge Source option. Not available in Stand-Alone 
mode.

•	 Configuring the object to retrieve the next test string to mark from an internal memory buffer using the Get string 
from memory buffer Source option.

•	 Automatically retrieve the current time/date settings from the operating system for the AutoDate feature

•	 Configure complex combinations of string components using the Custom String Source option

•	 Configure the job so strings can be changed while in Stand-Alone mode using the Controlled from Remote API 
Source option

i
Note!

•	 Dynamic Text is only possible in Stand-Alone mode when using Laser Fonts. See “Creating a new Laser font” on 
page 104 and “Adding a new Laser font to an LEC-2 device” on page 106 for more information.

•	 Dynamic Text only supports Barcode types: Data Matrix, Code 128. For additional symbology support, please 
consult the factory.

6.3.1	 To control the justification of the Object

The way an object justifies after rendering its image with the new string it receives during run time can be configured 
using the Justify settings.

XX From the Source tab, select the appropriate radio button corresponding to the justification desired. This feature is 
for single line text or barcodes only.

6.3.2	 Controlling how the User Interface updates when strings are dynamically changed

During the execution of a job than contains Dynamic Strings, the object can be configured to display the previous 
string, or the next string to be marked in the cabLase Editor 5 workspace. For example, if using the TextMerge 
function, what the next string to mark will be, before marking the part. In this case, the screen is displaying the 
next string. In other situations, it may be desirable to compare the string displayed on the screen after the mark is 
complete. In this case the screen would display the previous string.
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XX To see the next string on-screen, from the Source tab, select “Update String before mark”
XX To see the previous string on-screen, deselect “Update String before mark”

XX To refresh the screen while the Run dialog is open, it may be necessary to click the Refresh button.

6.3.3	 To configure the Text Merge option

Create or link to a text file, and select the desired justification to use when merging the next string from the text file. 
At runtime, the object will automatically extract the correct line or lines from the text file, and mark the barcode on the 
part. TextMerge is a feature that allows large lists of string values, such as names, etc. to be “merged” with the text 
object while the Job is running. A text merge file is a simple text file, with a .txt extension. Each contiguous string must 
be separated by a carriage return (Enter key). The last line of the text merge file must also have a carriage return 
as well. Single lines, as well as multi-line merge operations are available. Multi-line text merge operation is made 
possible by using the # objects in group and the Start line values. A detailed description of these features is in the 
following section.

i Note!
Not available in Stand-Alone mode

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Use TextMerge”. The TextMerge settings appear.
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The TextMerge property page

A The text file to link to at run time. The text file is read once when the Job is first started, and then written to at 
the end of a Job to save the current text file line location.

B Create and save a text merge file with this button

C

Change the number of objects in a multi-line merge group. An example of a multi-line merge group is a Name 
and Company Name. The Job would consist of two text objects, positioned appropriately, each using the 
same MergeFile. Both objects would have the # objects in group set to 2. The first object to mark would have 
the Start line value set to 1, and the second object to mark would have the Start line value set to 2.

D

Change the starting line in a multi-line merge group. An example of a multi-line merge group is a Name and 
Company Name. The Job would consist of two text objects, positioned appropriately, each using the same 
MergeFile. Both objects would have the # objects in group set to 2. The first object to mark would have the 
Start line value set to 1, and the second object to mark would have the Start line value set to 2.

E Edit an existing text file with this button.
F Locate and insert a text merge file with this button.

6.3.4	 To configure the AutoDate option		

The calendar date, time, or shift code will be automatically inserted, using the justification selected, and the date 
format selected. AutoDate automatically inserts a time related string retrieved from the Windows system clock into the 
objects string value at runtime. The original object can be regarded as a placeholder for the date to be inserted during 
Job execution.

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Use AutoDate”. The AutoDate settings appear.
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The AutoDate property page

A

Using the date January 15, 2009 as an example, the available AutoDate formats are:
•	 	YYMMDD - Object will print a barcode representation of: 090115
•	 	MM/DD/YY - Object will print a barcode representation of: 01/15/09
•	 	DD/MM/YY - Object will print a barcode representation of: 15/01/09
•	 	Month DD YYYY - Object will print a barcode representation of: January 15 2009
•	 	DD Month,YYYY - Object will print a barcode representation of: 15 January 2009
•	 	YWW - Object will print a barcode representation of: 902, where WW is the week number.
•	 	YMD - Object will print a barcode representation of: 912
•	 	JJJ - Object will print a barcode representation of: 015, where JJJ is the three-digit day of the year.
•	 	JJJY - Object will print a barcode representation of: 0159, where JJJ is the three-digit day of the year, and 

Y is the single digit year.
•	 	YY - String will print 09.
•	 	Shift code - String will print a custom value depending on the settings chosen. Details on using the shift 

code feature are in the next section.
•	 	DMY - String will print 15019.
•	 	HH:MM:SS - String will print the current system time.

6.3.5	 To configure the AutoDate > Shift code option

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Use AutoDate”.
XX From the Format drop down list, select Shift Code. The shift code settings appear.
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The Shift code property page

A Changes the start time at which this particular shift code is valid.

B
Enables or disables multiple shift codes. If multiple shifts have overlapping times, the first shift that is valid is 
used, and the rest are ignored. If there are times that are not specified within any of the enabled shifts, a “?” 
is returned.

C Changes the stop time where this particular shift code is no longer valid.
D Changes the character string to mark if this shift code is valid.

6.3.6	 To configure the Supply String at Start option
	
Before the Job is run, the operator is prompted to enter a text string, which will be used throughout the running of the 
Job. The next string value will use the selected justification. The Supply string at start feature will prompt the operator 
to supply a new string value just after the Job > Run button is clicked. This new value is then used until the process is 
stopped.

i Note!
Not available in Stand-Alone mode

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Supply string at start”. The Supply string at start settings appear.
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6.3.7	 To configure the Supply String Every Mark option

Prompts the operator to supply a text string before each mark is executed, using the selected justification. Short 
production runs are typical of this example. For larger volumes, the TextMerge feature should be used. The Supply 
string every mark feature will prompt the operator to supply a new string value just before the object is scheduled to 
mark.

i Note!
Not available in Stand-Alone mode

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Supply string every mark”. The Supply string every mark settings 

appear.

6.3.8	 To configure the Serialize option

Uses the current string value as the start of a serialization sequence, using the selected justification. The increment 
controls the amount the alpha numeric string value is incremented each mark, and the batch value controls how 
many cycles to wait before incrementing. To automatically increment or decrement a Barcode Objects string value, 
use this feature. When the Job starts, the first value marked by the object will be the current string value that was 
saved with the Job. Prompts the operator to supply the starting value of a serialization sequence, using the selected 
justification. The increment controls the amount the alpha numeric string value is incremented each mark, and the 
batch value controls how many cycles to wait before incrementing. This feature is the same as Serialize with Current 
Start Value, except the operator will be prompted to supply the starting value of the serialization sequence.

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Serialize with current start value” or “Serialize with supplied start 

value”. The Serialize settings appear. 
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The Serialize property page

A

There are two options available for serialization:
•	 Serialize with current start value - This option will start serializing with the value that the text object had 

when the job was saved. To save the current value of the text object to the job automatically when the job 
is running, see “To continuously save Dynamic string changes” on page 212.

•	 Serialize with supplied start value - When the job is run, the operator is prompted to enter the starting 
serial number. See “To respond to the Enter Character String dialog box” on page 208/216 for more 
details.

B

Changes the serialization increment value. Serialization is alpha as well as numeric; 0001A will increment 
to 0001B. Note that alpha serialization is only valid on ANSI text. Unicode alpha text may not increment 
correctly. Leading zeros are retained in the string if the format of the object allows it, otherwise they are 
removed.

C When a number greater than one is placed in the batch field, the object will not increment until “batch” mark 
cycles have taken place. On the next mark, the object will increment by “increment”.

D Select this option to automatically reset the serial number based on specified conditions.

	

6.3.8.1	 To automatically reset the serial number

XX Select the “Automatically reset serial number” option.

Reset when threshold is reached

A When the threshold is reached, the serial number is reset to this value. The reset value can have leading 
zeros.

B The value at which the serial number is reset.

Reset when specific I/O port is HIGH

A When the I/O port is set, the serial number is reset to this value. The reset value can have leading zeros.
B The input port to check before marking the object. If the port is set, the serial number is reset.

Reset when specific time is reached

A When the specified time is reached, the serial number is reset to this value. The reset value can have leading 
zeros.

B Before the object is marked, the time is checked, and if the PC time is after the specified time, the serial 
number will reset.
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6.3.9	 To configure the Get String from Memory Buffer option

During runtime, the string object will retrieve the string content to mark from an internal memory buffer. There are 
10 buffers available, and these buffers can be filled with string values from outside equipment. The maximum string 
length for each buffer is 3000 characters. To change a string objects string from an external program while the Job 
is running, use this feature. Just before the object is scheduled to mark, the string will be retrieved from the selected 
memory buffer. An external program can simply set any of the ten available memory buffers with a string value, and 
does not need to know about the internal structure of a particular Job file.
 

XX Click on the string Object to be modified. Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Get String from memory buffer”. The memory buffer settings appear.

The Memory Buffer property page

A Changes an index value from 1 to 10, corresponding the 10 memory buffers available.

B
Displays the current contents of the internal memory buffer. The buffers are initialized with a '?' when the 
application starts. To refresh the display, change the buffer index to another value, and then back to the 
desired index.
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6.3.10	 Using the Custom String feature
	
Using a format specifier string, you can build a customized mark string from a list of available format specifiers. To 
change a string objects string to a customized mark string while the marking Job is running, use this feature. Just 
before the object is scheduled to mark, the string will be assembled using the format specifier instructions saved with 
the object.

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Get String from memory buffer”. The memory buffer settings appear.

	

The Custom String property page.

A Customize the mark string using this specifier string. See the following Format Specifier Table for a list of 
available specifiers.
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6.3.10.1	Format Specifier Table

Notes

A

The %G specifier is used to map a string value to the Hour of the day. There are 24 mandatory positions after 
the specifier, and each position corresponds to an Hour of the day value, in 24 hour format.The following is an 
example:  %G,a,b,c,d,e,f,g,h,i,j,k,l,m,n,o,p,q,r,s,t,u,v,w,x In this example, at midnight (hour = 0), an 'a' will be 
inserted, at 01:00, a 'b' will be inserted, and so on.	

B

The text object will mark the start value first, then increment until it reaches the maximum value. The next 
mark will reset to the start value. If leading characters are required, make sure the total number of characters 
is the same for both the start value and maximum value (e.g. 0001 and 9999). Alpha characters are allowed, 
and will be incremented based on the ASCII value of the character. Batch will allow skipping of an increment 
event. For example, if batch = 2, the object will mark the same string two times before incrementing to the 
next value.

C
Time values must be in the 24 hour time format. If the current time is between the begin time and the end 
time, the string between the single quotes will be inserted, otherwise nothing will be inserted. To program a 
shift that goes across 00:00 (midnight), use one shift to 23:59 and another shift from 00:00.

D

The %m specifier is used to map a string value to the current Month. There are 12 mandatory positions 
after the specifier, and each position corresponds to a Month value. The following is an example:  
%m,a,b,c,d,e,f,g,h,i,j,k,l > In this example, in May an 'e' will be inserted, in October a 'j' will be inserted, and 
so on.
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E

The %d specifier is used to map a string value to the current Day. There are 31 mandatory positions after the 
specifier, and each position corresponds to a Day of the month value. The following is an example: %d,1,2,3,
4,5,6,7,8,9,A,B,C,D,E,F,G,H,I,J,K,L,M,N,O,P,Q,R,S,T,U,V > In this example, on the second Day of the month 
a '2' will be inserted, on the fifteenth day an 'F' will be inserted, and so on.	

F

The %I specifier is used to insert a string into a specific position in the current string, using a position and 
justification variable. The position variable starts with an index of 1. The justification variable is defined 
as 0 = left justification, 1 = right justification. For example, if the current string is Lanmark, and we specify 
%I,3,0,’Controls’ the result would be LaControlsnmark. If we specify %I,1,1,’Controls’ the result would be 
LanmarkControls

G

The %i specifier is used to obtain a string from another object using a zero-based index variable, and add an 
integer value to the string using a value variable. The string obtained from the object must be numerical only 
(no alpha chracters). For example, if the string obtained from an object at index 0 is 1000, and we specify 
%i,0,3 the result would be 1003

Example marked on February 24, 2009: 
Format Specifier String:	 %D%X1%M%X1%Y%X1%V'PART#: 100'
Resulting marked string:	 24 02 09 PART#: 100

6.3.11	 Changing text strings from an external controller in Stand-Alone mode

There are a number of ways a Text object can be configured to change it’s text string automatically when in Stand-
Alone mode:

•	 Serialization

•	 AutoDate

•	 Get string from Memory Buffer

If the requirement is to send a new Text string from en external controller such as a PLC or another PC, the text 
object must be configured to allow this capability.

XX Click on the string Object to be modified.
XX Right-mouse click and select “Properties...”. 
XX Click on the Source tab. The Source page displays the Source values.
XX From the String rules drop down list, select “Controlled by Remote API”.
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6.4	 AUTOMATION OBJECTS

Automation Objects provide a means to communicate with external handlers and motion controllers to automate a 
marking process, and to automate a process within cabLase Editor 5 itself. Some Automation objects are valid for 
execution locally on the PC and some can also be executed on the LEC-2 controller card in Stand-Alone mode. 
cabLase Editor 5 supports the following Automation Objects:

•	 Alignment Tool - Provides the ability to transform and objects position scaling and rotation based on data in an 
alignment file, or in a memory buffer location.	  Not available in Stand-Alone mode.

•	 Custom Axis - OMS Controller only. An object used to control an attached motor that can be customized from the 
Motor Controller Properties dialog. Not available in Stand-Alone mode.

•	 Insert Time Delay - Inserts a specified time delay between objects within a job.

•	 Laser Control, which provides direct control of a laser. Not available in Stand-Alone mode.

•	 Linear Motion - Intelligent Motion only. An object used to control an axis configured as linear motion. Not available 
in Stand-Alone mode.

•	 Rotary Indexer - OMS Controller only. An object used to control an attached Rotary Indexer. Not available in 
Stand-Alone mode.

•	 Rotary Motion - Intelligent Motion only. An object used to control an axis configured as rotary motion. Not available 
in Stand-Alone mode.

•	 Run Application - An object used to start an external executable file or an external batch file. Not available in 
Stand-Alone mode.

•	 Serial Communication - An object used to output a single string, or series of strings using a COM port. Not 
available in Stand-Alone mode.

•	 Set I/O Port - Sets a User Out output port HIGH, LOW, or pulses the output.

•	 Show Messagebox - Displays a message box on screen, and the job waits until the message box is closed before 
continuing. Not available in Stand-Alone mode.

•	 Wait for External Signal - An object used to poll The User In inputs and wait until that a programmed input is 
received.

•	 		 XY Table - OMS Controller only. An object used to control an attached XY Table. Not available in Stand-Alone 
mode.

•	 XY Motion - Intelligent Motion only. An object used to control two axes configured as xy motion. Not available in 
Stand-Alone mode.

6.4.1	 Alignment Tool

cabLase Editor 5 supports the use of alignment files during job execution. Alignment files are text based files that 
describe offsets and rotation to be applied to the complete job. The alignment tool object also supports manually 
entered alignment data, as well as the ability to get the alignment data from one of the internal memory buffers. When 
an Alignment Tool object executes, the alignment changes are applied to all objects in the job. Multiple alignment 
tasks can be accomplished by adding as many Alignment Tool objects as required.

i Note!
Not available in Stand-Alone mode



182 1826	 JOB ENTITIES

	 To modify Alignment Tool settings

XX Click on the desired Alignment Tool Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Alignment Tool Properties window appears.

6.4.1.1	 Using settings from object

 The Alignment Tool property page with “Use settings from this object” selected

A The X offset amount to apply to all objects in the job.
B The Y offset amount to apply to all objects in the job.

C The Z offset (de focus) amount to apply to all objects in the job. The scanning hardware must support 3-axis 
scanning for this value to have any affect.

D The amount of rotation to apply to all objects in the job.

E
The X center of rotation used when applying Angle. To rotate an object about the center of the field, the 
center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of 
rotation would be the coordinates of the center of the object.

F
The Y center of rotation used when applying Angle. To rotate an object about the center of the field, the 
center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of 
rotation would be the coordinates of the center of the object.

G Click this button to test the settings.
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6.4.1.2	 Using settings from alignment file

The Alignment Tool property page when “Import settings from alignment file” is selected

A A new Alignment file can be created by clicking the New button and choosing a file name and location. A new 
Alignment file with default settings is created.

B An existing Alignment file that has already been loaded can be edited by clicking the Edit button. When 
editing is complete, the changes can be saved back to the file by clicking Save.

C To load an existing Alignment file, click the Browse button to locate the Alignment file.
D The name of the current alignment file.

	

6.4.1.3	 Using settings from memory buffer
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The Alignment Tool property page when “Get settings from memory buffer” is selected

A Select and index value from 1 to 10, corresponding the 10 memory buffers available.

B Displays the current contents of the internal memory buffer. The buffers are initialized with a '?' when the 
application starts. 

	 Formatting the Buffer string

When sending a string to a memory buffer, it must be formatted in the following way:

<xoffset>,<yoffset>,<zoffset>,<angle>,<xcenter>,<ycenter>
where:
xoffset = millimeters, with 5 decimal places (0.0000)
yoffset = millimeters, with 5 decimal places (0.0000)
zoffset = millimeters, with 5 decimal places (0.0000)
angle = degrees, with 5 decimal places (0.0000)
xcenter = millimeters, with 5 decimal places (0.0000)
ycenter = millimeters, with 5 decimal places (0.0000)

Example: The following string will offset all objects in the job by 10mm in X, 20mm inY and will rotate all objects about 
the center of the field 45 degrees:

10.00000,20.00000,0.00000,45.000,0.00000,0.00000
	

6.4.2	 Custom Axis

The Custom Axis Object provides control over a generic motor axis. The custom axis can be configured for either 
linear or rotary applications. An optional OMS PCIx-004 motor controller card is required to control the external motor 
axis.

i Note!
Not available in Stand-Alone mode

	
	 To modify Custom Axis settings

XX Click on the desired Custom Axis Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Custom Axis Properties window appears.
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The Custom Axis property page

A

The units in which the “Move to” values are displayed, which can be one of the following:
•	 	The units are in mm of travel along the parts surface.
•	 	The units are in inches of travel along the parts surface.
•	 	Displays only if the axis has been set up as a rotary axis. The units are in degrees of motor rotation.
•	 	The units are in steps of motor rotation.

B
The mode of the motor movement, which can be one of the following:
•	 	Absolute - The motor will move to the actual absolute position indicated in “Move to”.
•	 	Relative - The motor will move the amount in “Move to” from the current motor position.

C The current position count of the motor
D Apply the current position value to the “Move to” value

E
The position to move the motor to when the object is executed. If the Moves are setting is Absolute, the motor 
will move to the absolute position indicated in “Move to”. If the Moves are setting is Relative, the motor will 
move the amount in “Move to” from its current position.

F The speed at which the motor will execute the move in steps/s.
G Executes the indicated “Move to” settings immediately on the custom motor axis
H Executes the Home command immediately on the custom motor axis.
I Immediately stops movement of the custom motor axis.
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6.4.3	 Insert Time Delay

The Insert Time Delay objects inserts a specified time delay between objects within a process.

	 To modify Insert Time Delay settings

XX Click on the desired Insert Time Delay Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Insert Time Delay Properties window appears.

The Insert Time Delay property page

A Specifies the delay time in ms.

B If this option is selected, the time delay will execute on the LEC-2 device using the Windows CE timer. 
Otherwise, it will execute on the PC using the PC timer.
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6.4.4	 Laser Control	
	
The Laser Control object provides a way to turn the laser on and off directly within the context of a job.

i Note!
Not available in Stand-Alone mode

	 To modify Laser Control settings

XX Click on the desired Laser Control Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Laser Control Properties window appears.

The Laser Control Settings property page

A

Select from the following control modes:
•	 Turn laser off - Immediately turns the laser off when the object executes, if the laser was turned on by a 

previous Laser Control object. If the laser is already off, this setting will do nothing.
•	 Turn laser on and leave on - Immediately turns the laser on when the object executes. If the laser is 

already on, this setting will do nothing.
•	 Turn laser on for specified time - Turns the laser on for the time specified in “Duration” when the object 

executes, then turns laser off.
B The power the laser will use when it turns on.
C The frequency of the laser control signal when the laser turns on.
D The pulse width of the laser control signal when the laser turns on.
E The duration the laser is on if Mode is set to “Turn laser on for specified time”

		
	
	



188 1886	 JOB ENTITIES

6.4.5	 Linear Motion

The Linear Motion object provides control over a linear motion axis, and is synchronized with marking objects within 
the job.

i Note!
Not available in Stand-Alone mode

	 To modify Linear Motion settings

XX Click on the desired Linear Motion Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Linear Motion Properties window appears.

The Linear Motion Settings property page

A Assign this motion object to a specific hardware axis. There must be the correct motion type configured in the 
Motion Configuration. See Understanding the Motion Types.

B

Select from the following Move modes:
•	 Move to an absolute position - The axis will move to the actual absolute position indicated in “Move” when 

the object executes.
•	 Move a relative amount - The axis will move the amount in “Move” from the current motor position when 

the object executes.
•	 Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis 

when the object executes.
•	 Stop the axis - The axis will be stopped if it was moving as a result of a previous motion object when the 

object executes.
•	 Move continuously in the positive direction - The axis will move towards the positive limit when the object 

executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion 
object.

•	 Move continuously in the negative direction - The axis will move towards the negative limit when the 
object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.
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C

A reset condition can be configured so that after the specified number of cycles, the axis will perform a reset 
function. The reset modes are:
•	 <disabled> - Disable the reset functionality
•	 Move to an absolute position - The axis will move to the actual absolute position indicated in “Reset to” 

when the reset condition is met.
•	 Move a relative amount - The axis will move the amount in “Reset to” from the current motor position 

when the reset condition is met.
•	 Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis 

when the reset condition is met.
•	 Move continuously in the positive direction - The axis will move towards the positive limit when the reset 

condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.

•	 Move continuously in the negative direction - The axis will move towards the negative limit when the reset 
condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.

D The amount to move the axis when performing a reset move
E The initial speed the axis moves at while accelerating to the slew speed
F The acceleration rate of the axis when changing from the initial speed to the slew speed

G The object can be configured to skip execution by setting this parameter greater than 1. For example, to 
execute the object every third job cycle, set this value to 3.

H The amount to move the axis when performing a reset move

I After the axis has completed the preprogrammed motion, wait for an amount of time before executing the 
next object in the job list.

J When the option is selected, all axis movement will be opposite normal movement
K The maximum speed the axis will attain when executing a move.

L The deceleration rate of the axis when changing from the slew speed to a stop at the end of the programmed 
travel.

M The number of cycles the object needs to execute before triggering a reset. When the reset is triggered, the 
axis will perform the action specified in “Reset move mode”.

N Change the display units for all values in the current window.

6.4.6	 Rotary Indexer

The Rotary Indexer Object provides control over an external rotary indexer. An optional OMS PCIx-004 motor 
controller card is required to control the external rotary indexer.

i Note!
Not available in Stand-Alone mode

	 To modify Rotary Indexer settings

XX Click on the desired Rotary Indexer Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Rotary Indexer Properties window appears.
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The Rotary Indexer property page

A The radius of the part being rotated. This value is used to calculate the circumference of the part, and allows 
a distance along the part to be entered in the “Move to” value.

B Enter the amount of process cycles to execute before the rotary indexer executes its move. For example, if 
the cycle is set to 2, the process must complete two complete cycles before the indexer will rotate.

C

The units in which the “Move to” values are displayed, which can be one of the following:
•	 	The units are in mm of travel along the parts surface.
•	 	The units are in inches of travel along the parts surface.
•	 	Displays only if the axis has been set up as a rotary axis. The units are in degrees of motor rotation.
•	 	The units are in steps of motor rotation.

D
The mode of the motor movement, which can be one of the following:
•	 	Absolute - The motor will move to the actual absolute position indicated in “Move to”.
•	 	Relative - The motor will move the amount in “Move to” from the current motor position.

E The current position count of the motor
F Apply the current position value to the “Move to” value

G
The amount to move the motor to when the object is executed. If the Moves are setting is Absolute, the motor 
will move to the absolute position indicated in “Move to”. If the Moves are setting is Relative, the motor will 
move the amount in “Move to” from its current position.

H The speed at which the motor will execute the move in steps/s.
I Executes the indicated “Move to” settings immediately on the axis
J Executes the Home command immediately on the axis.
K Immediately stops movement of the axis.
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6.4.7	 Rotary Motion

The Rotary Motion object provides control over an external rotary indexer axis, and is synchronized with marking 
objects within the job.

i Note!
Not available in Stand-Alone mode

	 To modify Rotary Indexer settings

XX Click on the desired Rotary Motion Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Rotary Motion Properties window appears.

The Rotary Motion Settings property page

A Assign this motion object to a specific hardware axis. There must be the correct motion type configured in the 
Motion Configuration. See Understanding the Motion Types.

B

Select from the following Move modes:
•	 Move to an absolute position - The axis will move to the actual absolute position indicated in “Move” when 

the object executes.
•	 Move a relative amount - The axis will move the amount in “Move” from the current motor position when 

the object executes.
•	 Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis 

when the object executes.
•	 Stop the axis - The axis will be stopped if it was moving as a result of a previous motion object when the 

object executes.
•	 Move continuously in the positive direction - The axis will move towards the positive limit when the object 

executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion 
object.

•	 Move continuously in the negative direction - The axis will move towards the negative limit when the 
object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.
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C

A reset condition can be configured so that after the specified number of cycles, the axis will perform a reset 
function. The reset modes are:
•	 <disabled> - Disable the reset functionality
•	 Move to an absolute position - The axis will move to the actual absolute position indicated in “Reset to” 

when the reset condition is met.
•	 Move a relative amount - The axis will move the amount in “Reset to” from the current motor position 

when the reset condition is met.
•	 Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis 

when the reset condition is met.
•	 Move continuously in the positive direction - The axis will move towards the positive limit when the reset 

condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.

•	 Move continuously in the negative direction - The axis will move towards the negative limit when the reset 
condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.

D The amount to move the axis when performing a normal move
E The initial speed the axis moves at while accelerating to the slew speed
F The acceleration rate of the axis when changing from the initial speed to the slew speed

G The object can be configured to skip execution by setting this parameter greater than 1. For example, to 
execute the object every third job cycle, set this value to 3.

H The amount to move the axis when performing a reset move

I After the axis has completed the preprogrammed motion, wait for an amount of time before executing the 
next object in the job list.

J When the option is selected, all axis movement will be opposite normal movement
K The maximum speed the axis will attain when executing a move.

L The deceleration rate of the axis when changing from the slew speed to a stop at the end of the programmed 
travel.

M The number of cycles the object needs to execute before triggering a reset. When the reset is triggered, the 
axis will perform the action specified in “Reset move mode”.

N The radius of the part being marked. This value is useful to scale distances on the surface of the part.
O Change the display units for all values in the current window.

		
	

6.4.8	 Run Application

The Run Application Object provides a way for the application to start an external program or batch file synchronized 
with the execution of marking objects within a job.

i Note!
Not available in Stand-Alone mode

	 To modify Run Application settings

XX Click on the desired Run Application Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Run Application Properties window appears.
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The Run Application property page

A The default folder location where the program or batch file exists. This setting is optional as the full path to the 
file can be specified in the Program parameter.

B
The program or batch file to run. If the Default path is set to a folder location, then the program or batch file 
must be the filename with extension only. If no Default Path is set, the fully qualified path to the executable or 
batch file must be specified here.

C Optional command line parameters to pass to the program. cabLase Editor 5 will automatically insert the first 
space after the program file name. Any additional spaces required must be specified here.

D Time to wait after application closes before executing the next object in the job list.

E
Select this option to wait for the program or batch file to exit before cabLase Editor 5 continues. If the box is 
not checked, cabLase Editor 5 starts the program or batch file, and then continues to the next object in the 
Object list after the Continue delay

F Select the default path.
G Select the batch file or program to execute.

	 Testing the configuration settings
	

XX After configuring the settings click the test button. The program or batch file you are referencing will run.

6.4.9	 Serial Communication

The Serial Communication Object provides a way for the application to output a string or series of strings using a 
COM port. A valid Windows COM port must be configured for a Serial Communication Object to function.

i Note!
Not available in Stand-Alone mode
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6.4.9.1	 To modify Serial Communication settings

XX Click on the desired Serial Communication Object in Object Manager.
XX Right-mouse click and select “Properties...”. The Serial Communication Properties window appears.

The Serial Communication property page when Transmit a single line of text is selected

A Configures the object to send a single line of text using the COM port when the object executes.
B The string to send when Transmit a single line of text is selected.

C
Select this option if a response is expected from the device cabLase Editor 5 is communicating with. If this 
box is checked, cabLase Editor 5 will generate an error message if the response conditions are not met when 
this object executes. If no response is expected, or to ignore a response, clear this check box.

D The response string expected from the connected device.
E The time to wait for the response back from the connected device.
F The control character \r will be added to the end of all string sent to the COM port.
G The control character \n will be added to the end of all string sent to the COM port.
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The Serial Communication property page when Transmit multiple lines of text using a script file

A Configures the object to send multiple lines of text contained in a script file. See Serial Communication Script 
File Format for details on the script file format.

B The fully qualified path to the script file containing the strings to be transmitted. See Serial Communication 
Script File Format for details on the script file format.

C The control character \r will be added to the end of all string sent to the COM port.
D The control character \n will be added to the end of all string sent to the COM port.
E Create and save a script file by clicking this button.
F Edit an existing script file by clicking this button.
G Locate and insert a script file by clicking this button.

	

6.4.9.2	 Configuring cabLase Editor 5 to allow Serial Communication

XX From the Main menu, select System > Preferences.
XX Click on the COM Ports tab. The COM Ports page appears.
XX Select the Communication Objects line in the list with the mouse. The configuration settings appear.
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The Communication Objects page

A
Selecting this option will make a COM port available to the Communication Objects. When applying this 
change, an attempt to open the COM port is made. De-select the option to disable the COM port for the 
Communication Objects.

B The Windows assigned COM port.
C COM port setting.
D COM port setting.
E COM port setting.
F COM port setting.

G
Click this button to apply any changes made in the Communication Objects page. If cabLase Editor 5 cannot 
open the specified COM port, an error message is displayed. If the COM port was opened successfully, the 
Status is updated to Connected.

6.4.9.3	 Serial Communication Script File Format
	
During execution of a function using a script file, cabLase Editor 5 will transmit the strings found in the file line by line 
in the order found. The following section describes the format of this file.

	 Command Set

The following list describes all the Script file commands and their intended use.

Command delimiter=<delimiter>
Purpose Sets the character to use to separate individual values within a single command string
Parameters delimiter: The delimiter character

Comments
This command must appear in the list before a string that contains a delimiter. If no delimiter 
command is found in the list, the default "," (comma) is used by cabLase Editor 5 to detect 
individual values within the command line.

Example Delimiter=;

Command delay=<time>
Purpose Creates a delay before the next line in the script file is transmitted.
Parameters time: The time, in milliseconds, to delay before processing the next line in the script file
Comments Time must be greater that 0, or it is ignored.
Example ATTN

Command <command>
Purpose A string to be transmitted. No response is expected with this command format.
Parameters command: The actual string to be transmitted.

Comments
This command must appear in the list before a string that contains a delimiter. If no delimiter 
command is found in the list, the default "," (comma) is used by cabLase Editor 5 to detect 
individual values within the command line.

Example Delimiter=;
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Command <command><delimiter><response><delimiter><timeout>
Purpose A string to be transmitted. A response is expected with this command format

Parameters

command: The actual string to be transmitted
delimiter: The delimiter specified with the delimiter command
response: The response string expected
timeout: The period of time, in milliseconds, to wait for the response string

Comments A response is expected with this command format, and an error will be generated by WinLase if 
the expected response is not received within the timeout period.

Example ATTN,ACK,100

	 Script File Example

The following example illustrates how to use all the commands available with the cabLase Editor 5 Script File format.

delimiter=;//Sets the delimiter for the following strings to ;
ATN//Sends the string 'ATN', don't care about response
SQF;ACK;50//Sends the string 'SQF', and waits 50 mS for the response 'ACK'
delay=500//Pauses 500 mS before executing the next line
QUIT//Sends the string 'QUIT'

6.4.10	 Set I/O Port

Set I/O Port objects set the status of the specific output port either high or low depending on the settings.

To modify Set I/O Port settings

XX Click on the desired Set I/O Port Object in the Object Manager.
XX Right-mouse click and select “Properties...”. The Properties window displays the Set I/O Port property values.
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The Set I/O Port property page

A

Specifies one of the following actions:
•	 	Set Port HIGH - The selected port will switch to the HIGH state. The port will stay HIGH until changed by 

another Set Port Object.
•	 	Set Port LOW - The selected port will switch to the LOW state. The port will stay LOW until changed by 

another Set Port Object.
•	 	Pulse Port (LOW-HIGH-LOW) - The selected port starts LOW, will switch to HIGH for the indicated 

duration, and then switch back LOW. Note that the duration value is approximate.
•	 	Set WORD - The WORD value is a 20-bit value, corresponding to the possible 20 output ports on the 

LEC-2 device. Each of the 20 output ports will switch to HIGH if the corresponding bit is set in the Word 
value. After the object executes, all ports will stay at their last signaled states.

B The specific I/O port that is signaled when the object has executed i
C When the Set Word action is selected, Word value appears. Set this to a value from 0-1048576.

		

6.4.11	 Show Messagebox

Use the Show Messagebox Objects to display an on-screen message during the execution of a job. The message 
must be acknowledged and closed before the process will continue.

i Note!
Not available in Stand-Alone mode

To modify Show Messagebox settings

XX Click on the desired Show Messagebox object in Object Manager.
XX Right-mouse click and select “Properties...”. The Show Messagebox Properties window appears.

The Show Messagebox property page

A The text that will appear in the title bar of the Messagebox.
B The string of text that will appear in the Messagebox.
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6.4.12	 Wait for External Signal

The Wait for External Signal Object polls an I/O port for an input and waits until that input is received before the 
process continues.

To modify Wait for External Signal settings

XX Click on the desired Wait for External Signal object in the Object Manager.
XX Right-mouse click and select “Properties...”. The Properties window displays the Wait for External Signal property 

values.

The Wait For External Signal property page

A Select the port to wait for a signal on.
B The window message displayed in cabLase Editor 5 when the object is executing.

C

Select from the following Trigger mode options:
•	 After transition from LOW -> HIGH - The LEC-2 device will trigger only when a transition from LOW to 

HIGH is detected. (Edge Detection)
•	 After transition from HIGH -> LOW - The LEC-2 device will trigger only when a transition from HIGH to 

LOW is detected. (Edge Detection)
•	 If port is LOW - The LEC-2 device will trigger if the port is LOW when checked, or if the port switches from 

HIGH to LOW. (Level Detection)
•	 If port is HIGH - The LEC-2 device will trigger if the port is HIGH when checked, or if the port switches 

from LOW to HIGH. (Level Detection)
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The XY Table Object provides control over an external XY Table. An optional OMS PCIx-004 motor controller card is 
required to control the external XY Table.

i Note!
Not available in Stand-Alone mode

To modify XY Table settings

XX Click on the desired XY Table object in Object Manager.
XX Right-mouse click and select “Properties...”. The XY Table Properties window appears.

The XY Table property page

A

The units in which the “Move to” values are displayed, which can be one of the following:
•	 	The units are in mm of travel along the parts surface.
•	 	The units are in inches of travel along the parts surface.
•	 	Displays only if the axis has been set up as a rotary axis. The units are in degrees of motor rotation.
•	 	The units are in steps of motor rotation.

B
The mode of the motor movement, which can be one of the following:

	 Absolute - The motor will move to the actual absolute position indicated in “Move to”.
	 Relative - The motor will move the amount in “Move to” from the current motor position.

C The current position count of the motor
D Apply the current position value to the “Move to” value

E
The amount to move the motor to when the object is executed. If the Moves are setting is Absolute, the motor 
will move to the absolute position indicated in “Move to”. If the Moves are setting is Relative, the motor will 
move the amount in “Move to” from its current position.

F The speed at which the motor will execute the move in steps/s.
G Executes the indicated “Move to” settings immediately on the axis
H Executes the Home command immediately on the axis.
I Immediately stops movement of the axis.
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6.4.14	 XY Motion

The XY Motion object provides control over an external XY Table, and is synchronized with marking objects within the 
job.

i Note!
Not available in Stand-Alone mode

To modify XY Motion settings

•	 Click on the desired XY Motion Object in Object Manager.

•	 Right-mouse click and select “Properties...”. The XY Motion Properties window appears.

The XY Motion Settings property page

A Assign this motion object to a specific hardware axis. There must be the correct motion type configured in the 
Motion Configuration. See Understanding the Motion Types.

B

Select from the following Move modes:
•	 Move to an absolute position - The axis will move to the actual absolute position indicated in “Move” when 

the object executes.
•	 Move a relative amount - The axis will move the amount in “Move” from the current motor position when 

the object executes.
•	 Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis 

when the object executes.
•	 Stop the axis - The axis will be stopped if it was moving as a result of a previous motion object when the 

object executes.
•	 Move continuously in the positive direction - The axis will move towards the positive limit when the object 

executes. The axis will continue to move until either hitting a limit switch, or if stopped by another motion 
object.

•	 Move continuously in the negative direction - The axis will move towards the negative limit when the 
object executes. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.
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C

A reset condition can be configured so that after the specified number of cycles, the axis will perform a reset 
function. The reset modes are:
•	 <disabled> - Disable the reset functionality
•	 Move to an absolute position - The axis will move to the actual absolute position indicated in “Reset to” 

when the reset condition is met.
•	 Move a relative amount - The axis will move the amount in “Reset to” from the current motor position 

when the reset condition is met.
•	 Perform a homing routine - The axis will perform a homing routine based on the home settings of the axis 

when the reset condition is met.
•	 Move continuously in the positive direction - The axis will move towards the positive limit when the reset 

condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.

•	 Move continuously in the negative direction - The axis will move towards the negative limit when the reset 
condition is met. The axis will continue to move until either hitting a limit switch, or if stopped by another 
motion object.

D The amount to move the axis when performing a normal move
E The initial speed the axis moves at while accelerating to the slew speed
F The acceleration rate of the axis when changing from the initial speed to the slew speed

G The object can be configured to skip execution by setting this parameter greater than 1. For example, to 
execute the object every third job cycle, set this value to 3.

H The amount to move the axis when performing a reset move

I After the axis has completed the preprogrammed motion, wait for an amount of time before executing the 
next object in the job list.

J When the option is selected, all axis movement will be opposite normal movement
K The maximum speed the axis will attain when executing a move.

L The deceleration rate of the axis when changing from the slew speed to a stop at the end of the programmed 
travel.

M The number of cycles the object needs to execute before triggering a reset. When the reset is triggered, the 
axis will perform the action specified in “Reset move mode”.

N The radius of the part being marked. This value is useful to scale distances on the surface of the part.
O Change the display units for all values in the current window.
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6.5	 TEMPLATE OBJECT

A Template Object is a graphic that is displayed in the work area, but is not a marking object. A Template Object is 
created from a Mark Object and once converted, cannot be edited. To edit a Template Object, it must be converted 
back into a Mark Object, edited, and then converted back to a Template Object. Template Objects are useful for 
displaying alignment features, notes, or graphics of the actual part being processed.

6.5.1	 Creating a Template Object

Template objects are mark objects that have been converted to a Template object.

To create a Template Object

XX If the graphic used to make a Template Object is an external file, import the file. See “Importing Graphic files” on 
page 87

XX 	If the graphic used to make a Template Object is a system object, add it to the Job by clicking the appropriate 
system object button. See “Adding a System Entity” on page 86.

XX Edit the position and size of the graphic within the work area.
XX Select the object by clicking it. Note that a group cannot be converted to a Template Object.
XX From the main menu, select Objects > Convert to Template, or right click the object, and select “Convert to 

Template”.

6.5.2	 Editing or Removing the Template Object

To edit the Template Object, it must be converted back to a mark object first. Removing a Template Object follows the 
same steps as editing, except the object is not converted back to a Template.

To edit a Template Object

XX From the Main menu, click Job Manager > Convert Template to Object.
XX The Template Object is removed from the Job Manager and is added to the end of the Object Manager list.
XX If removing the Template, simply delete the mark object from the Object Manager list.
XX If editing, make the desired changes, then follow the process above from Step 4 for creating a Template Object.
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This chapter provides an overview of the laser marking of objects and groups of objects and Jobs. In this context, 
a marking object is any laser markable entity added to an active Job. In cabLase Editor 5, there is a fundamental 
difference between marking objects (Job > QuickMark) and running Jobs (Job > Run). 

•	 When using the Job > QuickMark command, Automation objects do not execute. Any special run-time behavior 
that has been applied to an object, such as TextMerge, serialization, etc. will not be executed when marking the 
object using QuickMark. 

•	 When using the Job > Run command, all Automation objects, as well as any special run-time behavior of marking 
objects, will be executed.

7.1	 USING PREVIEWMARK

When the laser is equipped with a visible pointer and the laser driver file has enabled the visible pointer, PreviewMark 
is enabled. See “Enabling Visible Pointer control” on page 9 -23. The PreviewMark feature provides a method of 
visually indicating the outline of an object or group of objects. This visual feedback is accomplished by rapidly tracing 
the bounding rectangle of the object or group of objects with the visible laser while keeping the marking laser turned 
off. The mark object can be easily moved around the marking field by using the Ctrl+Arrow key combination and 
when properly positioned, moved there with a press of the Enter key. Additionally, using the Alt+Arrow key combi-
nation can dynamically change the size of the object.

7.1.1	 To preview an object

i Note!
There must be an active connection to an LEC-2 device, and the Job containing the object(s) to be previewed must 
be assigned to that device.

XX Select an object or group of objects.
XX To start PreviewMark, do one of the following:
XX 	Right click on the object and select “PreviewMark...”.
XX 	Press the F4 function key.
XX 	From the main menu, select Job > PreviewMark
XX The PreviewMark window opens and the objects outline displays on the marking field.
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7.1.2	 To move the outline while it is displaying

XX To move the outline of the object on the marking field, do one of the following:
XX 	Click on the up/down/left/right arrows with the mouse. A single click moves the outline once. Holding the mouse 

button down on the direction arrow will move the outline across the mark field.
XX 	While holding the Ctrl key down, press the up/down/left/right arrow keys on the keyboard. A single press moves 

the outline once. Holding the arrow key down will move the outline across the mark field.
XX When the outline is in the desired position, press the Enter key on the keyboard or click the Apply button with the 

mouse. The object is repositioned on the screen to the new location.

7.1.3	 To scale the outline while it is displaying

XX 	To scale the outline of the object, do one of the following:
XX 	Click on the scale arrows with the mouse. A single click scales the outline a small amount. Holding the mouse 

button down on the scale arrow will scale the outline continuously.
XX 	While holding the Alt key down, press the up/down/left/right arrow keys on the keyboard. A single press scales the 

outline a small amount. Holding the arrow key down will scale the outline continuously.
XX 	When the outline is scaled to the desired size, press the Enter key on the keyboard or click the Apply button with 

the mouse. The object is resized on the screen.

7.1.4	 To adjust the outline refresh speed

XX Click the Settings button. The PreviewMark window expands to show additional controls.
XX With the mouse pointer, click the Display speed slider bar, and while holding the mouse button down, move the 

bar left or right to adjust the speed.

7.1.5	 To calibrate the Visible Pointer

See “Calibrating the Visible Pointer” on page 246.

7.2	 USING THE QUICKMARK FEATURE

Use the QuickMark feature to laser mark the selected object, or group of objects. QuickMark does not apply any 
special processing to the object such as serialization or TextMerge, etc.

7.2.1	 To QuickMark objects

i Note!
There must be an active connection to an LEC-2 device, and the Job containing the object(s) to be marked must be 
assigned to that device

XX Select the object or group of objects to be laser marked. See “Selecting and Deselecting Objects”.
XX Do one of the following:
XX 	From the Main menu, select Job > QuickMark.
XX 	Press F8 on the keyboard.
XX 	Place the mouse pointer over a marking object, and right-click and select “QuickMark...”. 
XX Click the QuickMark button.
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Button Function

QuickMark tollbar button

!
Warning!
Laser will turn on immediately. Check the beam path before proceeding.

XX Click the Selected button to mark the single object.
XX Click the All button to mark all objects currently in the Job.
XX To mark an object repeatedly, select the “Repeat” option. The object will mark continuously until the Stop button is 

clicked.

To stop the laser while marking, do one of the following:

XX 	Click the Stop button.
XX 	Press the ESC key.

7.2.2	 Checking the Mark Time

When a mark is complete, the status bar at the bottom of the QuickMark window will display the mark time.

The elapsed time to complete the last object marked with the QuickMark feature. If a group of objects are marked, the 
Mark Time is for the last object marked in the group.

7.3	 RUNNING JOBS

When running Jobs, all Automation objects, as well as any special processing applied to an object will be executed. 
The three interface modes available in cabLase Editor 5 also differ in the way a Job is executed. When running jobs, 
the process can be organized into four groups of events:

•	 Events that occur during Job loading

•	 Events that occur before a Job is executed

•	 Events that occur during Job Execution

•	 Events that occur at Job completion
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7.3.1	 The Job Loading Events

The following event fires when a job loads from file:

•	 Show the job Notes. The note can be shown automatically each time the Job is opened. Adding notes to a Job 
may be helpful when the Job first loads, as a reminder to do a task, etc. before running the Job.

To show a Note when the job loads

XX From the Main menu, select Job > Settings, then click the Notes tab. The Job Notes window appears.

XX Type in the desired Note text.
XX Click OK. The Job Notes window closes.
XX From the Main menu, select System > Preferences. The Preferences window opens.
XX Click the Job Files tab. The Job File settings page appears.

XX Select the “Show Job Notes when Job loads” option
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7.3.2	 Before a Job is Executed Events

The following events fire, in the order listed, before a job is executed:

•	 Out of Bounds check event, which will show a warning message box if any marking objects are outside the 
marking field.

•	 Enter Character String event, which prompts the operator to enter a string before the job can continue

•	 Home axes event (intelligent motion only), which will prompt for a motion hardware homing sequence.

7.3.2.1	 To check if any objects are out of bounds

XX From the Main menu, select System > Preferences.
XX Click on the Device tab. The Device page appears

XX Select the “Warn about out of bounds objects before marking” option

7.3.2.2	 To respond to the Enter Character String dialog box

The Enter Character String dialog appears before the job executes if a text object has been programmed to Supply 
string at start.

XX Enter the required value for the requested string, and click the OK button to continue.
XX Click Cancel to abort the current Job.
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7.3.2.3	 To respond to the Home motion axes event

The Home Utility dialog appears before the job executes if the Motion axes have not been homed since the last 
power cycle. Once the axes have been homed once, the Home Utility will not automatically appear again until the 
axes have been power cycled.

The Home Utility page

A The motion axis types that require homing
B When homing a XY motion device, select this option to move both axes at the same time
C Start the homing process

D Stops motor movement. If motor movement is stopped before the homing process completes, the motors will 
require homing at the next job execution cycle.

7.3.3	 Job Execution Events

The are a number of settings that control the behavior of cabLase Editor 5 as it executes a Job and a number of 
events that can happen during the execution of a job:		

•	 Globals settings which provide job-wide control of the laser power, mark speed, and mark object positions. 
cabLase Editor 5 offers the ability to change the laser power, scan speed, and object position of a mark object 
from a single (global) location. This allows operators or engineers to make changes to all Jobs run with cabLase 
Editor 5 from a single location. For example, if the laser power is slowly decreasing because of lamp life, the 
power setting for all marking objects can be slightly increased from the Global settings window.

•	 Repeat Process settings, which controls whether the Job process is run continuously, once, or a specified number 
of times before a message is displayed.

•	 	Step & Repeat settings, which configures options for marking an object across the marking field in an array of 
rows and columns. The number of rows and columns, as well as the spacing can be saved with the job.

•	 	External Start settings, to configure control of Job execution from external equipment. 

•	 Mark on the Fly settings, which provides for the marking of moving parts.

•	 Alignment Files settings, which are text based files that describe offsets and rotation to be applied during the 
execution of the job. The name of the alignment file is saved with the job. Prior to the execution of the job, the 
alignment file is located and the changes within the file are applied to all objects in the job.

•	 String Value required event, which prompts the operator to enter a string before the job can continue

•	 TextMerge file event, which prompts for MergeFile information

•	 An Interlock event, which indicates that a system interlock has been signaled

•	 A System Error event, which indicates that an unexpected error event has occurred



210 2107	 MARKING JOBS

7.3.3.1	 To change the Global settings

XX From the main menu, select System > Globals. The Global Settings window appears.

The Global Settings page

A The percent increase or decrease to apply to the laser power settings of all objects within a Job.
B The percent increase or decrease to apply to the Mark speed settings of all objects within a Job.
C Use these values to “nudge” (offset) all objects within a Job.

D To save these settings from session to session, select this option. If the box is unchecked, the applied 
settings will be used for the current session only and will be lost when the application closes.

7.3.3.2	 To change the Global settings from the Touch screen interface

XX From the Touch screen interface, click the OPTIONS button. The OPTIONS window appears.
XX Click the ADJUST button. The Global Settings window appears.
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The Global Settings page

A The percent increase or decrease to apply to the laser power settings of all objects within a Job
B The percent increase or decrease to apply to the Mark speed settings of all objects within a Job.
C Use these values to “nudge” (offset) all objects within a Job.
D Enter numerical values with these buttons
E Click these buttons to edit a field.

7.3.3.3	 To control how a job cycle repeats

XX From the Main menu, select Job > Settings, then click the Repeat Process tab.
XX 	The Repeat Process Properties window appears.
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The Repeat Process property page

A After the operator clicks Go, the Job will execute the objects in the Object Manager list once. The operator 
must click Go to execute the list again. This process will go on indefinitely.

B After the operator clicks Go, the Job will execute the objects in the Object Manager list once. The operator 
must click Go to execute the list again. This process will stop after # cycles.

C The number of cycles used in B

D
After the operator clicks the Go button, the Job will execute the objects in the Object Manager list repetitively. 
This option is usually used with an external start signal (Start Mark), otherwise the object list will execute 
continuously, with no break between successive cycles of the list.

E
After the operator clicks Go, the Job will execute the objects in the Object Manager list repetitively. This 
option is usually used with an external start signal, otherwise the object list will execute continuously, with no 
break between successive cycles of the list. The process will stop after # cycles and display a message.

7.3.3.4	 To continuously save Dynamic string changes

During job execution, barcode and text objects may be changing their strings through automatic serialization. These 
changes can be saved to the job file automatically as the job is executing. The next time the job is loaded, text or 
barcode objects will use the last string value.

XX From the Main menu, select Job > Settings, then click the Repeat Process tab.
XX 	The Repeat Process Properties window appears.

The Repeat Process property page

A After every job cycle completes, the job is saved to disk. This is useful, for example, when there is serialized 
text objects in a job and the job needs to be saved with the last used serial number.
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7.3.3.5	 To use Step and Repeat
	

XX From the Main menu, select Job > Settings, then click the Step & Repeat tab.
XX The Step & Repeat Properties window appears.

	

The Step and Repeat property page

A Enables/disables step and repeat.
B The number of columns in the pattern.
C The spacing between each column of marks.
D The number of rows in the pattern.
E The spacing between each row of marks.

F The Pattern offset X Axis and Y-axis will translate all objects in the rows and columns by the amount entered 
into the field.

G The pattern preview
H Updates the preview to show recent changes to the step and repeat parameters.
I Resets all settings to default values.

7.3.3.6	 To control the job with External I/O

XX 	From the Main menu, select Job > Settings, then click the External Start tab.
XX The External Start Properties window appears.
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The External Start property page

A
If this option is selected, cabLase Editor 5 will start a marking job immediately after the Go button is clicked 
in the Run Process dialog box. Note that if a job is being saved to the LEC-2 device to run in Stand-Alone 
mode, this option is not allowed.

B

If this option is selected, an external hardware signal (Start Mark) controls the start of a marking sequence. In 
the Run Process dialog, the Go button is clicked to start the process, and then cabLase Editor 5 immediately 
streams the job to the LEC-2 device. The LEC-2 device will then wait for the Start Mark signal, and when 
received, will execute the job. Note that if a job is being saved to the LEC-2 device to run in Stand-Alone 
mode, this option MUST be selected.

C The default port on the LEC-2 device is the Start Mark input.

D Enter the message displayed in the Run Process dialog box while the LEC-2 device is waiting for the Start 
Mark signal.

E

Select from the following Trigger mode options:
•	 After transition from LOW -> HIGH - The LEC-2 device will trigger only when a transition from LOW to 

HIGH is detected. (Edge Detection)
•	 After transition from HIGH -> LOW - The LEC-2 device will trigger only when a transition from HIGH to 

LOW is detected. (Edge Detection)
•	 If port is LOW - The LEC-2 device will trigger if the port is LOW when checked, or if the port switches from 

HIGH to LOW. (Level Detection)
•	 If port is HIGH - The LEC-2 device will trigger if the port is HIGH when checked, or if the port switches 

from LOW to HIGH. (Level Detection)

F Enter a timeout value in minutes to wait for the Start Mark signal. If the timeout expires before an external 
start signal is received, an error message is displayed. A value of 0 (zero) will wait indefinitely.

	
	

7.3.3.7	 To enable marking on moving parts (Mark on the Fly)	

i Note!
Mark on the Fly is only available in Stand-Alone mode.

XX From the Main menu, select Job > Settings, then click the Mark on the Fly tab.
XX The Mark on the Fly Properties window appears.
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The Mark on the Fly property page

A Enable/disable mark on the fly for the current job.

B

This option will add a specified delay, in distance, between when the Start Mark signal is received and 
when the LEC-2 device executes the marking vectors. Because this delay is based on distance in the part 
movement direction, as the part speed changes, the spacing stays constant. Enter 0 to disable the distance 
delay.

7.3.3.8	 To dynamically control marking object alignment	
	

XX From the Main menu, select Job > Settings, then click the Alignment tab. The Alignment page appears.
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The Alignment property page

A Check this option to select and configure an Alignment file
B The alignment file
C The X offset amount to apply to all objects in the job.
D The Y offset amount to apply to all objects in the job.

E The Z offset (defocus) amount to apply to all objects in the job. The scanning hardware must support 3-axis 
scanning for this value to have any effect.

F A new Alignment file can be created by clicking the New button and choosing a file name and location. A new 
Alignment file with default settings is created.

G An existing Alignment file that has already been loaded can be edited by clicking the Edit button. When 
editing is complete, the changes can be saved back to the file by clicking Save.

H To load an existing Alignment file, click the Browse button to locate the Alignment file.
I The amount of rotation to apply to all objects in the job.

J
The X center of rotation used when applying Angle. To rotate an object about the center of the field, the 
center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of 
rotation would be the coordinates of the center of the object.

K
The Y center of rotation used when applying Angle. To rotate an object about the center of the field, the 
center of rotation would be X center = 0, Y center = 0. To rotate the object about its center, the center of 
rotation would be the coordinates of the center of the object.

7.3.3.9	 To respond to the Enter Character String dialog box

The Enter Character String dialog appears at run-time if a text object has been programmed to Supply string every 
mark.

XX Enter the required value for the requested string, and click the OK button to continue.
XX Click Cancel to abort the current Job.

7.3.3.10	To respond to the TextMerge Event dialog box

If a text object has been programmed to use the TextMerge feature, the TextMerge Event window appears when the 
Job is run. This window is used to control the start position in the merge file for the current marking session.
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The TextMerge event dialog page

A The text object will start retrieving strings from the top of the file. Any group # and start line # settings will be 
preserved. 

B The text object will start retrieving strings from the line number entered. The available line numbers are visible 
to the right of the line number edit box. 

C
When a previous TextMerge Job is run, the last position in the merge file is automatically saved. When 
selecting this option, the text object will retrieve strings from the bookmark location. Note that this option is 
grayed out if there was no previous Job which used the merge file.

D Click this button to view the TextMerge file
. 
	

7.3.3.11	To view the current MergeFile	
	

XX Click the View TextMerge file button. The TextMerge viewer appears.
XX 	To see the Bookmark line location, click the Go to Bookmark button.
XX Click the X to close the viewer and resume the Job.

Job Completion Events

The following events fire, in the order listed, after a job has completed execution:

•	 The Beam Home event, which provides a means of controlling the position the laser spot takes at the end of a 
mark sequence. By default, the spot (mirror positions) remains at the end of the last vector that was marked.

•	 Laser saver event, which provides a means of shutting down the laser and/or reducing its power settings after a 
timeout period has elapsed. An optional error flag can be set as well.

7.3.3.12	To change the Beam Home settings

XX From the Main menu, select System > Preferences.
XX Click on the Beam Home tab. The Beam Home page appears.



218 2187	 MARKING JOBS

The Beam Home page

A If this option is selected, at the end of a Run Process sequence, the laser beam will go to the home position.
B If this option is selected, at the end of a QuickMark sequence, the laser beam will go to the home position.
C The home position.
D The speed the spot will move from its current position to the home position.

7.3.3.13	To change the LaserSaver settings
	

XX From the Main menu, select System > Preferences.
XX Click on LaserSaver tab. The LaserSaver page appears.

The LaserSaver page

A Enables/disables the LaserSaver feature.

B If this option is selected, after the specified timeout period has elapsed, the power ports, which control the 
laser power, are set to their minimum settings.

C If this option is selected, after the specified timeout period has elapsed, a custom de-initialize script is sent to 
the laser via the RS-232 port.

D This feature is not available on the LEC-2 device.
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7.3.4	 Running From the Workspace

There must be at least one executable object in the Object Manager list and an active connection to an LEC-2 in 
order to run a Job.

7.3.4.1	 To run a Job from the Job Editing Workspace or Operator Interface

i Note!
There must be an active connection to an LEC-2 device, and the Job to be run must be assigned to that device.

Do one of the following:

XX 	From the Main menu, select Job > Run
XX 	Press F12 on the keyboard.
XX Click the Run button.

Button Function

Run Process toolbar button
	

!
Warning!
Laser will turn on immediately. Check beam path before proceeding.

XX Click Go. The Job begins execution.

7.3.4.2	 To stop the Job

To stop a running Job, do one of the following:
XX 	Click the Stop button.
XX 	Press ESC on the keyboard.
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7.3.4.3	 To run a Job from the Touch Screen Interface

To run a Job from the Touch Screen Interface, a Job must be loaded. To load a Job in the Touch Screen Interface, 
see Section 6.2.2 Loading Jobs in the Touch Screen Interface.

!
Warning!
Laser will turn on immediately. Check beam path before proceeding.

XX From the Touch Screen Interface, click the RUN button. The system immediately starts the run Job process.

7.3.4.4	 To stop the Job

XX To stop a running Job, click the STOP button.

Saving the Job Settings as Default

Whenever the New button on the tool bar is clicked, or the File > New menu item is selected, a new Job is created, 
and the Default Job Settings are applied. To customize the defaults, set all the Job parameters to desired values, 
then click the Save Settings as Default button. The current settings are saved as the default.

7.3.4.5	 To set the default Job Settings

Do one of the following:

XX 	Select Job > Settings.
XX 	Click on the Settings icon in Job tool bar. The Job Settings Properties window appears.
XX Set all the values in the Job Settings pages to the desired settings.
XX Click the Save Settings as Default button. The current settings are immediately saved, and is confirmed by the 

following message.

                            	            
			               The Save Settings as Default Button
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7.3	 RUNNING STAND-ALONE JOBS	

Stand-Alone jobs can be executed on an LEC-2 device by using a Pendant, or interacting with the LEC-2 using the 
Remote API over Ethernet or RS-232. Additionally, cabLase Editor 5 can be used to interact with an LEC-2 in Stand-
Alone mode. This feature allows the design and debug of Stand-Alone jobs to be done completely within the cabLase 
Editor 5 user interface. Stand-Alone jobs can also be run from the cabLase Editor 5 interface in production situations 
as well. Behind the scenes, cabLase Editor 5 uses the Remote API command set exposed by the LEC-2 device to 
enable this functionality.

7.4.1	 To remotely run the current Job

i Note!
There must be an active connection to an LEC-2 device, and the Job to be run remotely must be assigned to that 
device.

XX Do one of the following:
XX 	From the Main menu, select Job > Run Remotely.
XX 	Press F9 on the keyboard.
XX Right-click the Job in the Laser System Viewer and select “Run Remotely...”. 

Click the Upload button to copy the current Job to the LEC-2, load it into RAM and make it the Active Job. The Job 
is copied to a special folder used only for this purpose and is not stored permanently. To copy the file into permanent 
memory, see “Saving Stand-Alone (LEC binary) Job files” on page 78.
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The Remote Job Control page

A

Select from the following Trigger mode options:
•	 After transition from LOW -> HIGH - The LEC-2 device will trigger only when a transition from LOW to 

HIGH is detected. (Edge Detection)
•	 After transition from HIGH -> LOW - The LEC-2 device will trigger only when a transition from HIGH to 

LOW is detected. (Edge Detection)
•	 If port is LOW - The LEC-2 device will trigger if the port is LOW when checked, or if the port switches from 

HIGH to LOW. (Level Detection)
•	 If port is HIGH - The LEC-2 device will trigger if the port is HIGH when checked, or if the port switches 

from LOW to HIGH. (Level Detection)
B Select this option to run the Job repeatedly.
C Instructs the LEC-2 device to run the job in cache mode.
D Enable Mark on the Fly (only available on LEC-2 devices with an Advanced license).
E Click the Go button to initiate Job execution.
F Stop job execution with this button.

7.4.2	 To configure Mark on the Fly parameters for the current Job	

i Note!
Mark on the Fly parameters are only available when connected to an LEC-2 device with an Advanced license.

i Note!
Changes to Mark on the Fly parameters are not saved to the LEC-2 device or the Job, and are active only while the 
Run Remotely window is open.

XX From the Run Job page, select the “Enable Mark on the Fly” option. The Mark on the Fly tab appears.

The Mark on the Fly parameter page

A The number of counts the encoder outputs for every millimeter of part movement. When the LEC-2 device is 
in Simulate encoder mode, this control is disabled.

B Enter the actual part speed in mm/s. The system assumes a constant part speed during the marking process. 
When the LEC-2 device is in Encoder mode, this control is disabled.

C

This option will add a specified delay, in distance, between when the Start Mark signal is received and 
when the LEC-2 device executes the marking vectors. Because this delay is based on distance in the part 
movement direction, as the part speed changes, the spacing stays constant. Enter 0 to disable the distance 
delay.

D Indicates the currently configured encoder mode of the LEC-2 device. The encoder mode cannot be changed 
from this tool. To change the encoder mode, see “To configure the Mark on the Fly settings” on page 65.
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7.4.3	 To remotely run a Job stored on a LEC-2	

XX Right-click the LEC-2 device in the Laser System Viewer and select “Interactive...”. 

The Remote Job Control page	

A Select the location on the LEC-2 to search for jobs

B Select the job to run. When the job is changed, the Load button becomes active and must be clicked to load 
the job into RAM.

C

Select from the following Trigger mode options:
•	 After transition from LOW -> HIGH - The LEC-2 device will trigger only when a transition from LOW to 

HIGH is detected. (Edge Detection)
•	 After transition from HIGH -> LOW - The LEC-2 device will trigger only when a transition from HIGH to 

LOW is detected. (Edge Detection)
•	 If port is LOW - The LEC-2 device will trigger if the port is LOW when checked, or if the port switches from 

HIGH to LOW. (Level Detection)
•	 If port is HIGH - The LEC-2 device will trigger if the port is HIGH when checked, or if the port switches 

from LOW to HIGH. (Level Detection)
D Select this option to run the Job repeatedly.
E Instructs the LEC-2 device to run the job in cache mode.
F Load the job into RAM	
G Click the Go button to initiate Job execution.
H Stop job execution with this button.
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7.5	 CONTROLLING cabLase Editor 5 REMOTELY

7.5.1	 The Host Interface

cabLase Editor 5 was designed to be a full-featured laser marker user interface, with capabilities for editing, saving, 
opening and running “jobs” directly from the cabLase Editor 5 interface. Although this interface is extremely powerful, 
it may not be desirable in all circumstances.
For this reason, cabLase Editor 5 offers the Host Interface service. This service provides a remote program, written 
by the customer, the ability to take control of cabLase Editor 5. In addition, the Fieldbus interface provides a means 
for controlling cabLase Editor 5, and reading status back from cabLase Editor 5 to the Master controller.
Although TCP/IP, RS-232 and Fieldbus interfaces are supported, only one may be active at a time for remote control.
Please refer to the Cab Produkttechnik GmbH & Co KG document Remote Interface Manual for complete details on 
how to use this powerful interfacing technique.

7.5.1.1	 RS232 and TCP/IP Interface Concepts

When using the RS-232 or TCP/IP interfaces, a remote program can load jobs, dynamically change the content of 
marking objects, run jobs, and receive status back from cabLase Editor 5 after every command. While the remote 
program has control, the cabLase Editor 5 User Interface is locked out, preventing the operator from making any 
changes to the running process. Although jobs that contain Motor Control objects can be loaded, the Remote 
Interface does not support executing motor control objects within the job.
In operation, the external program takes control of cabLase Editor 5, but does not initiate the actual marking cycle. 
This is done through the Start Mark input on the LEC-2. Once the Start Mark input is toggled, the mark cycle begins, 
the mark completes, and then cabLase Editor 5 returns to wait for the Start Mark input to toggle again.
In addition to the control commands available, there are a number of status query commands that can be used to 
retrieve the current status of cabLase Editor 5. These queries can be made even if the remote computer has not 
taken control of cabLase Editor 5.

7.5.1.2	 Fieldbus Interface Concepts

Using the Fieldbus interface, a remote Master controller can load jobs by Index number, change the contents of 
two fixed memory buffers, run jobs, and receive status back from cabLase Editor 5 after every command. While the 
remote Master has control, the cabLase Editor 5 User Interface is locked out, preventing the operator from making 
any changes to the running process. Although jobs that contain Motor Control objects can be loaded, the Remote 
Interface does not support executing motor control objects within the job.
In operation, the external Master initializes cabLase Editor 5 with a startup sequence, and then can go on to take 
control and load jobs. Once a job is loaded, the Master initiates the actual marking cycle. This is done through the 
StartMark input bit.
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Image field correction capability is provided to compensate for optical errors induced by all two-mirror laser beam 
systems. These optical distortions are caused by a number of factors, including the distance between each mirror, 
the distance between the mirrors and the image field, and the type of lens used in the laser system for focusing the 
laser beam. This section describes the issues encountered with flat field (f-theta) laser scanning and methods for 
correcting distortions inherent in this focusing technique. The issues are:

•	 	Understanding and correcting Induced Field Distortions

•	 	Correcting for Mechanical Alignment Tolerances by calibrating the marking field

8.1	 Understanding Field Distortions

Image field distortions are comprised primarily of:

•	 Mirror induced distortions

•	 F-theta Objective induced distortions

The following figure illustrates the geometrical relationship between the galvos, mirrors and work surface.

			    Projection system layout

8.1.1	 Mirror Induced Distortion

Projection of a laser beam via an X-Y mirror set controlled by galvanometers induces distortion in the X axis propor-
tional to the tangent of the angle of the Y axis mirror and the distance from the focal plane to the center of the Y axis 
mirror. This distortion is also known as "pincushion" distortion. 

				           Pincushion distortion caused by X-Y mirror set
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8.1.2	 F-Theta Objective Induced Distortion

The addition of an F-theta objective in the laser field provides direct proportionality between the scan angle and 
the distance in the image field, as well as ensures that the focus lies on a flat surface. F-theta objective lenses, like 
all optical lenses, are not perfect and induce their own projection field distortions. This distortion, illustrated in the 
following figure, is called “barrel” distortion for what it does to a square image. Many projection lens vendors will 
provide these model coefficients, or measurement data from which these coefficients can be derived. For many appli-
cations, however, this distortion is negligible.

					   
				             Barrel distortion caused by F-theta lens

8.1.3	 Distortion Correction

The two distortion components described previously combine to create a distorted image field similar to that shown in 
the following figure:

				            Composite Image Field Distortion

This distortion is automatically compensated for by the LEC-2 through the use of correction tables. Correction tables 
represent a 65x65 element grid covering the full addressable projection range of the system. Each grid element 
contains three correction components: one each for the X, Y and Z axes. The components represent an offset that 
if added to an ideal position command for that point, would alter the galvo positions such that the resulting projected 
point would fall onto a “perfect” grid, i.e. the point would be “corrected”.

During the micro-vectoring process at each update interval, the LEC-2 calculates the ideal position of the mirrors 
along the path. It compares this value to the correction table grid and accesses the four grid points that immediately 
surround the calculated point. The corrections at these four points are proportionally averaged depending on how 
close the ideal point is to each grid point. This process, called bi-linear interpolation, produces a correction that is 
applied to the ideal point, and the result is then sent to the system D/A converters and serial digital command outputs.
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Using Correction Tables

Most scan head manufacturers provide correction tables for specific scan heads they manufacture. Most of these 
correction files are either already provided by CabLase Editor 5 in the library of lens correction files, or are available 
from the scan head manufacturer. CabLase Editor 5 provides a lens correction file conversion feature, which allows 
the use of any lens correction file from the major scan head vendors. See “To copy a Lens Correction file from the 
PC to the LEC-2” on page 4 -19 and “To add a new Lens Correction file to CabLase Editor 5” on page 4 -22 for more 
information on using correction tables. In some cases, however, a custom correction table must be created from scan 
head design data. CabLase Editor 5 provides the capability to create a new table “from scratch” using only the design 
data of the target scan head.

8.1.3.1	 To create a new Lens Correction file using scan head design data

XX From the menu bar, select System > Preferences.
XX Click on the Hardware tab. The Hardware page appears.
XX Click on any installed lens in the tree view.
XX Click the Change button. The Select Correction File window appears.
XX Click the Install New File button. The Install New Correction File Wizard appears.

i Note!
The Install New File button will be disabled if a hardlock license key is not detected

XX Click the Next button to start the Wizard. The Correction File page appears.

XX Select the “Create new file” option and enter a filename (without extension) for the new correction file.
XX Click Next. The Lens Correction File Description page appears.
XX Enter a descriptive name for the new lens. This is the name that appears in the available lens list. Note that the 

name is truncated to 25 characters in length. 
XX Click Next. The Lens Focus Type page appears. CabLase Editor 5 can create correction tables only for f-theta 

lens systems, so f-theta is pre-selected. 
XX Click Next. The Scan Head Parameters page appears.
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XX Enter the maximum optical angle that the mirror will rotate for full field deflection. Enter the focal length of the lens 
system to be used with the scan head.

XX Click Next. The Maximum Field Size page appears.

XX The wizard calculates and displays the theoretical maximum field size that can be attained given the galva-
nometer maximum angle and the focal length of the f-theta lens. If desired, a smaller field size can be specified to 
account for optical considerations. Enter the desired field size.

XX Click Next. The Scan head Clear Aperture page appears.
XX Enter the clear aperture of the Scan Head. This value is the maximum beam diameter that can be passed through 

the scan head without optical clipping.
XX Click the Next button. The final page appears confirming the changes. Click the Done button to close the Wizard.

8.1.3.2	 To add a Lens Correction file supplied by a scan head vendor to cabLase Editor 5

XX From the menu bar, select System > Preferences.
XX Click on the Hardware tab. The Hardware page appears.
XX Click on any installed lens in the tree view.
XX Click the Change button. The Select Correction File window appears.
XX Click the Install New File button. The Install New Correction File Wizard appears.

i Note!
The Install New File button will be disabled if a hardlock license key is not detected
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XX Click the Next button to start the Wizard. The Correction File page appears.
XX Select the “Existing file” option and then click the the browse button. The Locate Correction file window opens. 

Select the correction file to be added to the list. The file name is entered in the file name edit box. If the lens 
already exists, a message similar to the following will appear:

XX Click Next. The Lens Correction File Description page appears. 
XX Enter a descriptive name for the new lens. This is the name that appears in the available lens list. Note that the 

name is truncated to 25 characters in length. 
XX Click Next. The Lens Focus Type window appears.
XX Select the “f-theta” option. Most new lenses will be of the f-theta variety. If the lens system has an automatic 

z-axis, select “3-axis”.
XX Click Next. The Calibration Factor page appears.
XX Enter the calibration factor for the lens. This value is important, as it sets the scaling for all dimensions throughout 

cabLase Editor 5. The calibration factor is available from the manufacturer of the Scan Head and lens assembly. 
Note that the units are always in bits/millimeter (mm) regardless of the Units setting of cabLase Editor 5.

XX Click Next. The Focal Length page appears.
XX Enter the focal length of the lens being added. Note the units are always in millimeters (mm).
XX Click Next. The Scan head Clear Aperture page appears.
XX Enter the clear aperture of the Scan Head. This value is available from the Scan Head manufacturer.
XX Click the Next button. The final page appears confirming the changes. Click the Done button to close the Wizard.

Using Grid Correction

All correction files included with cabLase Editor 5 or supplied by scan head vendors have all the information 
necessary for scanning within a flat working area, and the field distortion caused by the two-mirror system is compen-
sated. However, this compensation is based on an “ideal lens” and ignores two phenomena:

•	 	All lenses differ slightly due to manufacturing tolerances, causing a distortion from the “ideal lens”.

•	 	The galvanometer scanners, which rotate the mirrors, have a non-linearity in their positions resulting from 
manufacturing tolerances.

Usually, these errors are so small they can be ignored in most applications. There are some situations, however, 
where the errors are significant, and need to be corrected. A method is needed to manipulate the values in the 
standard lens correction file, compensating for the aforementioned errors. The method is called Grid Correction, and 
a program is available from Cab Produkttechnik GmbH & Co KG to accomplish this task.
The Grid Correction algorithm allows calibrating a field at 9, 25, or 81 points. The Grid Correction Program changes 
the standard lens correction file, producing a new one, calibrated for the current mechanical and lens combination. 
Please consult the factory regarding Grid Correction tools.
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8.2	 Correcting for Mechanical Alignment Tolerances

Although inherent distortions in the lens can be corrected with a lens correction file, errors or tolerances in the 
mechanical fixturing of the Scan Head to its mounting surface may produce additional scanning errors. In order 
to correct for these mechanical alignment errors, cabLase Editor 5 provides the following features in the Lens 
Calibration Wizard:

•	 	Adjustment of X and Y position of scan field.

•	 	Adjustment of X and Y scale of scan field.

•	 	Adjustment of Rotation of the scan field.

cabLase Editor 5 maintains separate calibrations for each unique lens correction file. When switching between 
correction tables, the appropriate calibrations are applied. If calibrations have been applied to a correction table, 
cabLase Editor 5 indicates this by prepending ‘(*)’ to the lens correction table name in the Hardware manager.

				     cabLase Editor 5 indicating a calibrated file

8.2.1	 To adjust the X and Y Field Scaling

cabLase Editor 5 must have an active connection to an LEC-2 device

XX From the Main menu, select System > Preferences. The System Preferences window appears.
XX Click on the Hardware Tab. The Hardware configuration page appears.
XX From the Hardware tree view, highlight the lens underneath the LEC-2 being adjusted. If the lens is not visible, 

click on the + next to the LEC-2, then select the lens.
XX Click the Calibrate button. The confirmation window appears to verify the selection.
XX Click OK. The Calibration Wizard appears.
XX Click the Next button to start the Calibration Wizard. The Scale marking field page appears.
XX In the Scale Marking field page, select the “Yes” option.
XX Click the Next button. The Place your sample page appears.
XX Follow the on screen instructions for placing the marking sample.
XX Click the Next button. The Mark test pattern page appears.

!
Warning!
Laser will turn on when the Mark test pattern button is clicked. Check the beam path before proceeding.

	
XX 	Click the Mark test pattern button. The sample will mark with the test pattern square.
XX Click the Next button. The Measure the results page appears.
XX Measure the test sample with a precision measuring device, noting the orientation of the X and Y axes. Enter the 

measurements in the appropriate edit boxes.
XX Click the Next button. The Remark new sample page appears.

!
Warning!
Laser will turn on when the Mark test pattern button is clicked. Check the beam path before proceeding.
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XX Place a clean sample in the center of the marking field. Click the Mark test sample button. The sample is marked 
with the laser.

XX Click the Next button. The Verify the calibration page appears.
XX If the newly marked test sample measurements agree with the value stated on the Verify the calibration page, 

select the “Yes” option. If the measurements do not agree, select the “No” option.
XX If Yes is selected, click the Next button until the Wizard completes.

8.2.2	 To adjust the X and Y Field Offset

cabLase Editor 5 must have an active connection to an LEC-2 device

XX From the menu bar, select System > Preferences. The System Preferences window appears.
XX Click on the Hardware Tab. The Hardware configuration page appears.
XX From the Scan Card tree view, highlight the lens correction file attached to the Scan Head being adjusted. If the 

lens is not visible, click on the + next to the Scan Head, then select the lens.
XX Click the Calibrate button. The confirmation window appears to verify the selection.
XX Click OK. The Calibration Wizard appears.
XX Click the Next button until the Offset marking field page appears.
XX In the Offset Marking field page, click the “Yes” option, and then click the Next button. The Enter field offsets page 

appears.
XX Enter the amount to offset the marking field in the appropriate edit boxes.
XX Click the Next until the Wizard completes.

8.2.3	 To adjust the Scan Field Rotation

XX From the menu bar, select System > Preferences. The System Preferences window appears.
XX Click on the Hardware Tab. The Hardware configuration page appears.
XX From the Hardware tree view, highlight the lens correction file attached to the LEC-2 being adjusted. If the lens is 

not visible, click on the + next to the LEC-2, then select the lens.
XX Click the Calibrate button. The confirmation window appears to verify the selection.
XX Click OK. The Calibration Wizard appears.
XX Click the Next button until the Rotate marking field page appears.
XX In the Rotate field page, click the “Yes” option, and then click the Next button. The Mark rotation test sample page 

appears. 
XX 	To verify the settings, click the Mark test pattern button. Repeat the process until the marking field is correctly 

aligned.
XX Click the Next button until the Wizard completes.

8.2.4	 To manually enter calibration values

cabLase Editor 5 must have an active connection to an LEC-2 device

XX From the menu bar, select System > Preferences. The System Preferences window appears.
XX Click on the Hardware Tab. The Hardware configuration page appears.
XX From the Scan Card tree view, highlight the lens correction file attached to the Scan Head being adjusted. If the 

lens is not visible, click on the + next to the Scan Head, then select the lens.
XX Click the Calibrate button. The confirmation window appears to verify the selection.
XX Click OK. The Calibration Wizard appears.
XX Click the Next button until the Calibration Method page appears.
XX Select Manually and click Next. The Enter Calibration Data page appears.
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The Analog servo page

A Amount to change the X axis scaling, in percent. Maximum range is ± 20.00%.
B Amount to change the Y axis scaling, in percent. Maximum range is ± 20.00%.
C Amount to offset the X axis.
D Amount to offset the Y axis.
E Amount to rotate the entire field, in degrees. A positive value will rotate the field counter-clockwise.
F Click this button to restore the calibrations to factory defaults.
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The LEC-2 provides very flexible laser control capability that is synchronized with galvo motion control. Six dedicated 
TTL compatible signals are provided at all times whose timing relationships are defined by the Laser Driver file. Not 
all signals may be required for a given customer laser configuration. An integrator need only select an appropriate 
subset of these signals, and configure them via the cabLase Editor 5 laser configuration Wizard with appropriate 
timing parameters. 

9.1	 Working with the Laser Driver Wizard

When modifying an existing Laser Driver, or to create a new one, cabLase Editor 5 provides a Laser Driver Wizard.

9.1.1	 To configure an existing Laser Driver file

XX From the menu bar, select System > Preferences.
XX Click on the Hardware tab. The Hardware page appears.
XX Click on the laser in the tree view to be configured.
XX Click the Configure button. The Configure Laser Driver File confirmation window appears, verifying the request to 

change the current laser driver.
XX Refer to the sections that follow for details on configuring specific laser signals.

9.1.2	 To add a new Laser Driver file

XX From the menu bar, select System > Preferences.
XX Click on the Hardware tab. The Hardware page appears.
XX Click on any laser in the tree view.
XX Click the Change button. The Select Laser Driver window appears.
XX Click the Install New Laser button. The Laser Configuration Wizard appears.

i Note!
The Install New Laser button will not be available if a hard lock license key is not detected

XX Click the Next button to start the Laser Configuration Wizard. The Laser Description page appears.

XX Enter a unique descriptive name in the edit box. This name will appear in the list of available laser drivers.
XX Refer to the sections that follow for details on configuring specific laser signals.
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9.2	 Understanding the Laser Control Signals

cabLase Editor 5 uses a Laser Driver file, which controls the timing relationship between all of the laser control 
signals on the LEC-2. cabLase Editor 5 ships with several pre-defined Laser Driver files and new Laser Driver files 
can be created as well.

Timing Diagram

The LEC-2 provides the following laser control signals:

•	 Laser Modulation 1 - Provides a variable frequency and pulse width signal.

•	 Laser Modulation 2 - Provides a variable frequency and pulse width signal that is phase shifted 180 degrees from 
Laser Modulation 1.

•	 Laser On 1 - Provides a gate signal that switches HIGH at the start of a marking vector, and then LOW at the end 
of the marking vector.

•	 Laser FPK - Provides a pulse that is triggered at the beginning of a marking vector to provide a means of 
suppressing the first pulses on certain laser types.

•	 Laser Enable - Switched HIGH before a marking vector starts, and then switched LOW after a timeout has 
expired. This signal is used to allow certain lasers to enable their control circuitry.

•	 Visible Pointer - Provides a dedicated signal to control a guide laser

•	 Laser Power Data 0 to 7 - An 8-bit (or optionally 7-bit with latch) signal which can be used to control the laser 
power, or for waveform control.

•	 Laser Analog Power - An analog signal, with a maximum range of 0 - 10 VDC, which can be used to control the 
laser power.

The following diagram illustrates the digital laser control signals and their relationship to one another.

	            Digital laser signal timing relationships
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Configuring the Laser Power Control Signals

Generally speaking, there are two ways in which the output power of a laser is controlled:

•	 Pulse Width Modulation (PWM) control, where the power of the laser is controlled by a single laser modulation 
signal. The frequency and pulse width of the drive signal is variable, and the Duty Cycle of the signal controls the 
power of the laser. CO2 lasers are typical of the PWM type. The following partial screen shot of an Object Profile 
illustrates the Laser power and the Frequency parameters. When either the Laser power value, or the Frequency 
value is changed, the Pulse Width (which is not shown) is calculated automatically. For lasers that require a 
limited range of duty cycles, the maximum and minimum Duty Cycle can be configured in the Laser Driver file.

	           The Laser power and Frequency fields control power in a PWM laser

•	 Discrete control, where individual signals for power (analog or digital), laser gate and modulation may all be 
required to control different aspects of the lasers output. Additional signals, such as first pulse suppression, 
and an enable signal may be required as well. When using this type of control, cabLase Editor 5 offers a Power 
Change Delay, which automatically compensates for the time it takes the laser to change from one power setting 
to the next. The following partial screen shot of an Object Profile illustrates the Laser power, Frequency and Pulse 
width parameters. The Laser Power parameter controls both the Laser Power Analog signal and the 8-bit Digital 
power signals. The Frequency and Pulse width signals control the Laser Modulation 1 signal.

	            Laser power is controlled independently of Frequency and Pulse width in a Discrete input laser

9.2.1	 To configure the Laser Power Type

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Laser Type” page appears.

Selecting what type of laser to configure

A Configure the Laser Driver for a PWM type laser
B Configure the Laser Driver for a Discrete power control type laser
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9.2.2	 To select analog or digital power control

i Note!
These settings only apply to lasers with discrete laser power control.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Power control interface” page appears.

Selecting analog or digital power control

A The laser requires an analog signal to control the power
B The laser requires a digital signal to control the laser power

C In some lasers, both the analog and digital outputs are controlled separately. Select this option to have 
independent control over the analog and digital outputs

9.2.3	 To configure the analog drive voltage range

i Note!
These settings only apply if the laser uses an analog input to control the laser power.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Analog drive voltage” page appears.
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Configuring the analog drive voltage range

A Specify the voltage input required to achieve maximum laser power. When any Laser power field in cabLase 
Editor 5 is set to 100%, the analog output will be at this level.

B Specify the voltage input required to achieve minimum laser power. When any Laser power field in cabLase 
Editor 5 is set to 0%, the analog output will be at this level.

9.2.4	 To configure the digital (8-bit) control range

i Note!
These settings only apply if the laser uses an 8-bit digital input to control the laser power.

XX Open the Laser Driver Wizard. “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Digital power control range” page appears.

Configuring the digital power control range

A Specify the 8-bit value required to achieve maximum laser power. When any Laser power field in cabLase 
Editor 5 is set to 100%, the 8-bit Laser Power Data outputs will be at this level.

B Specify the 8-bit value required to achieve minimum laser power. When any Laser power field in cabLase 
Editor 5 is set to 0%, the 8-bit Laser Power Data outputs will be at this level.

C Specify the 8-bit value that the Laser Power Data outputs will be set to when the LEC-2 device powers up.

D Some lasers require a signal to latch the Laser Power Data bits. Selecting this option will configure the LSB 
(Laser Power Data 1) to produce a pulse (LOW-HIGH-LOW) whenever the power has changed.

9.2.5	 To set the Duty Cycle range

i Note!
These settings only apply if the laser is a PWM type.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Modulation Duty cycle” page appears.
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Configuring the duty cycle range for PWM laser types

A Specify the maximum duty cycle that is allowed on the laser. When any Laser power field in cabLase Editor 5 
is changed, this maximum will be validated.

B Specify the minimum duty cycle that is allowed on the laser. When any Laser power field in cabLase Editor 5, 
this minimum will be validated.

9.2.6	 Overriding the power settings with the laser controller

i Note!
These settings only apply if the laser uses an 8-bit digital input to control the laser power.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Manual laser power control” page appears.

Configuring the manual override feature

A To use a panel control to manually control the laser power, select the Yes option.
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9.2.7	 To configure the Power Change Delay

i Note!
This setting only applies to lasers with discrete laser power control.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Power Change Delay” page appears.

Configuring the power change delay

A
When the Laser power changes during marking, a delay can be specified to allow the laser to reach the new 
power value. This delay is inserted after the Laser power command has changed, but before any marking 
vectors are processed.

9.2.8	 To control how the laser power is delayed in cabLase Editor 5

i Note!
This setting only applies to lasers with discrete laser power control.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Laser power display units” page appears.
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Configuring the power display units

A The Laser power field in the Object Profile is displayed as a percentage of total available power.
B The Laser power field in the Object Profile is displayed in watts.

9.2.9	 Configuring the Laser Modulation Signal

The Laser Modulation signal provides a programmable pulse stream where both frequency and pulse width can be 
controlled. Two Hardware frequency ranges are available to suit most laser types. The Laser Modulation signal has 
two modes:

•	 Stand-By - Also known as a tickle signal. Provides a programmable frequency and pulse width stream when the 
laser is OFF. The Stand-By settings are configured in the Laser Driver file.

•	 Active - Provides a programmable frequency and pulse width stream when the laser is ON. The Frequency and 
Pulse width are configured in the Object Profile, as shown in the following screen shot. Either or both of these 
fields can be hidden in the Object Profile page if the laser does not support them.

9.2.10	 To select the Hardware frequency range

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Hardware Frequency Range” page appears.

Setting the LEC-2 hardware frequency range

A Configure the LEC-2 device to output a frequency range of 20 Hz to 900 kHz. The pulse width resolution will 
be 1 µs in this mode, and all laser signal parameters will have their full range available.

B Configure the LEC-2 device to output a frequency range of 200 Hz to 5 MHz. The pulse width resolution will 
be 100 ns in this mode, but reduces the range of the laser signal parameters by a factor of 10.
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9.2.11	 To configure the polarity of the Laser Modulation signal

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Laser Modulation delay and polarity” page appears.

Configuring the polarity

A When set to High Active, the Laser Modulation output switches to TTL +5VDC when the laser is ON.
B When set to Low Active, the Laser Modulation output switches to TTL GND when the laser is ON. 

9.2.12	 To show or hide the Frequency and Pulse width fields

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Frequency and Pulse Width control” page appears.

Controlling the visibility of the frequency and pulse width fields

A Select Yes to show the Frequency field in the Object Profile, select No to hide the field.
B Select Yes to show the Pulse width field in the Object Profile, select No to hide the field.

	           The Pulse width field is hidden
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	           The Pulse width field is available

9.2.13	 To set the allowable range of frequencies

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Laser Modulation Frequency Range” page appears.

Controlling the frequency range

A Specify the maximum frequency that can be used to control the laser. When any Frequency field in cabLase 
Editor 5 is changed, this value is used to validate the change.

B Specify the minimum frequency that can be used to control the laser. When any Frequency field in cabLase 
Editor 5 is changed, this value is used to validate the change.

9.2.14	 To set the allowable range of pulse widths

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Pulse Width Range” page appears.

Controlling the pulse width range

A Specify the maximum pulse width that can be used to control the laser. When any Pulse width field in 
cabLase Editor 5 is changed, this value is used to validate the change.

B Specify the minimum pulse width that can be used to control the laser. When any Pulse width field in cabLase 
Editor 5 is changed, this value is used to validate the change.
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9.2.15	 To set the Stand-by frequency and pulse width

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Standby (Tickle) signal” page appears.

The Standby signal page

A Select Yes to enable a Stand-By pulse stream. Select No to disable.
B Specify the pulse width of the Stand-By pulse stream.
C Specify the frequency of the Stand-By pulse stream.

9.2.16	 To configure the polarity of the Laser On (Gate) signal

i Note!
Configuring the Laser On Signal:
The Laser On (Gate) signal is asserted when the laser is ON.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Laser Modulation delay and polarity” page appears.

Configuring the polarity

A When set to High Active, the Laser On (Gate) output switches to TTL +5VDC when the laser is ON.
B When set to Low Active, the Laser On (Gate) output switches to TTL GND when the laser is ON.
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9.2.17	 To modify Laser Enable signal settings

i
Note!
Configuring the Laser Enable Signal:
The Laser Enable signal is asserted a programmable time before the Laser On (Gate) signal, and is de-asserted 
after a programmable period of laser inactivity.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Laser Enable signal” page appears.

The Laser Enable signal page

A Specify the amount of time before the Laser Modulation 1 signal to turn ON the Laser Enable signal. 

B Specify the Enable Timeout. After the Laser Modulation 1 signal has been inactive for longer than the Laser 
Enable Timeout, the Laser Enable signal is turned OFF.

C When set to High Active, the Laser Enable output switches to TTL +5VDC when ON.
D When set to Low Active, the Laser Enable output switches to TTL GND when ON.

9.2.18	 To modify Laser FPK (First Pulse Killer) signal settings

i Note!
These settings only apply to lasers with discrete laser power control.

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “First Pulse Suppression signal” page appears.



245 2459	 CONNECTING TO LASERS

The FPK signal page

A
Specify the start position of the FPK signal. The start position of the FPK signal is measured from the leading 
edge of the Laser On (Gate) signal. For the FPK signal to start before the Laser On (Gate) signal, use a 
negative value.

B Specify the pulse width of the FPK signal.
C When set to High Active, the Laser FPK output switches to TTL +5VDC when ON.
D When set to Low Active, the Laser FPK output switches to TTL GND when ON.

9.3	 Using a Visible Pointer

cabLase Editor 5 provides features for controlling a visible (Guide beam) laser to assist in aligning object marking to 
the actual part. 

9.3.1	 Enabling Visible Pointer control

cabLase Editor 5 supports the integration of a visible pointer laser (sometimes referred to as a Guide beam). The 
Visible Pointer option is turned on in the Laser Driver file, which then enables the Visible Pointer controls in cabLase 
Editor 5.

Left Visible Pointer item in the Hardware viewer
Right PreviewMark menu item available in the Object context menu popup

To enable the Visible Pointer option

XX Open the Laser Driver Wizard. See “Working with the Laser Driver Wizard” for details on how to open the Wizard.
XX Press the Next button until the “Visible pointer” page appears.
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Enabling the Visible Pointer option

A Select Yes to enable the Visible Pointer controls in cabLase Editor 5, select No to disable them.

9.3.2	 Calibrating the Visible Pointer

Because of the difference in the wavelengths between the Visible Pointer laser and the marking laser, the Visible 
Pointer beam will not always indicate the true position of the marking beam. cabLase Editor 5 provides a calibration 
routine to align the Visible Pointer laser with the marking laser. The Laser Driver file must have the Visible Pointer 
option enabled.

To calibrate the Visible Pointer

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Visible pointer item in the Hardware list. The Calibrate button becomes enabled.
XX Click the Calibrate button. The Visible Pointer Calibration Wizard appears.
XX Click the Next button to start the Wizard. The Place your sample page appears.
XX Place a marking sample in the marking area and click the Next button. The Mark test pattern page appears. 

!
Warning!
Laser will turn on when the Mark test pattern button is clicked. Check the beam path before proceeding.

XX The test pattern is a square centered in the field. The size of the test square can be set with the Test pattern size 
value. Enter a value, or accept the default.

XX Click the Mark test pattern button to mark the sample. After the sample is marked, click the Next button. The Align 
visible pointer page appears.
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XX Using the Object position arrow buttons and the Object size arrow buttons, move the visible pointer beam until it 
lies exactly on top of the laser mark. After the visible pointer beam is aligned correctly with the laser mark, click 
the Next button until the Wizard completes.

9.4	 Laser Diagnostics

cabLase Editor 5 provides a tool window to turn the laser on and off from the user interface. Scan Head beam 
position can be selected, laser parameters can be set, and the laser manually fired, for example, in alignment 
operations.

To use the Laser Diagnostics Tool

XX From the Main menu, select Tools > Laser Diagnostics. The Laser Diagnostics window appears.

The Laser Diagnostics window

A The X and Y coordinates of the beam position in the current units.
B The power at which the laser will be set when the Fire button is pressed.
C The frequency of the laser modulation signal, in kHz.
D The pulse width of the laser modulation signal, in µs.
E On some laser types, the laser power can be controlled from the front panel of the laser controller
F Turns the laser ON immediately.

G
Turns the laser OFF immediately. The following operations also stop the laser:
•	 Clicking the Done button
•	 Pressing the ESC key on the keyboard
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Marking systems are often required to control one or more motors or actuators to execute complex production 
sequences. Typical uses of motion in a laser marking environment are:

•	 Adjust XY table to implement step and repeat marking or locate parts with respect to the marker lens.

•	 Adjust rotary axis to locate parts with respect to the marker lens

•	 Adjust height of marker head to pre-programmed static positions to accommodate marking surfaces at different 
heights above the tooling plane.

•	 Rotate a circular cylindrical part while marking to ensure mark completely wraps around part with no distortion or 
areas out of focus. This feature can be used with a basic 1 to 1 gearing, or more advanced implementations which 
includes a stage with gearing and index (home) sensor.

cabLase Editor 5 provides two methods for motion control:

•	 Using Intelligent motion motors with integrated controller/drivers

•	 Using a Prodex OMS dedicated motion controller card that installs in the PC.

Both solutions cannot be used simultaneously. If cabLase Editor 5 detects an OMS card, it will disable the Intelligent 
motion solution. Likewise, if no OMS card is detected, the Intelligent motion solution will be available.

10.1	 Intelligent Motion Control

Using a supported intelligent motion solution, cabLase Editor 5 allows the user to control up to 32 individual motion 
axes, with any combination of linear, rotary and XY motion devices. The intelligent motion devices are characterized 
by their ability to daisy chain multiple devices connected to a single RS-232 COM port. The solution consists of two 
major components - cabLase Editor 5, which is responsible for issuing serial commands to the individual motors, the 
motors themselves with integrated serial communication hardware, encoders, cabling and sensor inputs, and the 
motor power supply. The motors selected are from the Schneider Electric MDrivePlus family, and communication 
between motors and cabLase Editor 5 is conducted using the MDrivePlus communication protocol. CabLase Editor 5 
supports the concept of Motion Configurations, where combinations of different motion axes are saved in a configu-
ration file. 

10.2	 Quick Start Guide

In general, use the following steps to set up your motion hardware:

XX Connect the motion hardware to the LEC-2 device using the appropriate cabling. See “Connecting the Motion 
Hardware”.

XX Create a new Motion Configuration in cabLase Editor 5. In a Motion Configuration, you add individual motion 
axes, which are then made available to cabLase Editor 5 when programming motion Automation objects. See 
“Working with Motion Configurations” on page 249.

XX Program each individual axis contained in the Motion Configuration. See “Programming a motion axis”.
XX Configure the individual axis parameters, such as accelerations and speeds, homing and limit parameters, etc. 

within the Motion Configuration to adapt the axis to the specific hardware. See “Configuring the Axis Types”.
XX Test the configuration using the Motion Manager. See “Motion Manager” on page 34.
XX Add motion based Automation objects to a job to automate the use of the Motion Configuration. See “Linear 

Motion” on page 188.
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10.3	 Connecting the Motion Hardware

In most applications, the motion hardware will be connected through the appropriate cabling to one of the available 
RS-232 COM ports on the LEC-2 device. Since some motion hardware uses RS-485 communication, it may be 
necessary to provide an adapter between the LEC-2 device and the motion hardware. Please refer to the documen-
tation supplied with the motion hardware for instructions on proper cabling, etc. The communications settings for the 
LEC-2 COM port can be configured for proper communication with the motion hardware.

To configure the LEC-2 COM port

XX Create a connection to the LEC-2 device to configure. See “Making a Connection” on page 47.
XX In the Laser System Viewer, right-click on the connected LEC-2 device, and select Settings.
XX Click the COM Ports tab. The COM ports page appears.

The LEC-2 COM Ports settings page

A Configure which COM port to use on the LEC-2 device for motion control.
B Configure the port speed (default = 9600).

10.4	 Working with Motion Configurations

Similar to the laser and lens configuration files, a Motion Configuration describes the particular hardware setup so 
CabLase Editor 5 can properly interact with the hardware. Additionally, since intelligent motion devices communicate 
on a common bus, each device needs to have a unique name so that CabLase Editor 5 can identify and send instruc-
tions to the device. Part of the process of creating a new motion configuration involves programming each motion 
device with a unique name.
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10.4.1	 To create a new Motion Configuration

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select a current Motion Configuration, either under the “Offline Configuration”, or under an LEC-2 device.

XX Click the Change button. The Select Motion Configuration dialog appears.

XX Click the Install New Motion button. The Motion Configuration dialog appears. See Adding an axis type.

10.4.2	 To modify an existing Motion Configuration

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Motion Configuration to modify under an LEC-2 device.



251 25110	 MOTION CONFIGURATION

XX Click the Configure button. The Motion Configuration dialog appears. See “To add a Motion type to a Motion 
Configuration”.

Understanding the Motion Types

When a motion type is added to a Motion Configuration, a logical connection is made to a specific motion device. 
Adding a motion type to the list tells CabLase Editor 5 that a particular motion hardware device is available for use in 
a corresponding Automation object. For example, to use a Linear motion Automation object, there must be at least 
one Linear motion type in the Motion Configuration. See Linear Motion, Rotary Motion or XY Motion for details on 
configuring motion Automation objects.

Configuring the polarity

Left A Linear motion type as it appears in the Motion Configuration
Right The same motion type is now available in a Linear motion Automation object

Configuring the polarity

Left Only a Linear motion type available in the Motion Configuration
Right No Rotary motion type available in a Rotary motion Automation object
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10.4.3	 To add a Motion type to a Motion Configuration

XX From the Motion Configuration tool, select a Motion type from the Available Motion types list.
XX Click the Add button. The Motion type is added to the Motion Configuration.

10.4.4	 To remove a Motion type from a Motion Configuration

XX From the Motion Configuration tool, select a Motion type in the Current Configuration list.
XX Click the Remove button. The Motion type is removed from the Current configuration.

10.5	 Configuring Axis Parameters

Each Motion type in the Motion Configuration must be logically linked to an actual hardware device. This linking is 
done by giving the each motion axis within the Motion type a unique name, and linking it to a specific hardware driver 
type.

Programming a motion axis

Each axis must be programmed before use. Once the motion configuration is completed, use the “Program Axis” 
button from the Provisioning window to store the configuration to the motors. Each motor will receive a letter name 
(A-Z) during this process.

Motors MUST be programmed individually, using a primary communication cable with only a single motor connected 
at a time. It is not possible to program correctly with multiple motors connected with a “daisy chain” cable. 

Because a unique name is generated for each motion axis, all of the Motion types should be added to the Motion 
configuration before the axes programming process is started.

10.5.1	 To program a Motion axis

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Motion Configuration to be modified.
XX Click the Configure button. The Motion Configuration tool appears.
XX From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis 

settings panel appears.
XX Click the Provisioning tab. The Provisioning page appears.
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The Motion Configuration Programming page

A The current configuration to program

B This button starts the hardware programming wizard used to download configuration data into IMS Mdrive 
motors.

XX After selecting the Hardware driver and display name, click the Program Hardware... button. The Program Axis 
Controller Wizard appears. Follow the Wizard instructions to complete the programming of the axis.

i Note!
Configuring axis settings: Each axis has speed, acceleration, limits, homing and encoder settings that need to be 
configured.

10.5.2	 To change the Provisioning settings

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Motion Configuration to be modified.
XX Click the Configure button. The Motion Configuration tool appears.
XX From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis 

settings panel appears.
XX Click the Provisioning tab. The Provisioning page appears.
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The Motion Configuration Provisioning page

A

The number of microsteps per motor revolution is displayed. This value is calculated differently based on the 
motor's encoder setting. If the encoders are disabled (open loop mode) the microsteps per revolution are 
the (Microstep Resolution)*200 steps / rotation. This gives 52,100 microsteps per revolution at the highest 
microstep resolution setting. If the encoders are disabled there is a fixed value of 2048 microsteps/rev based 
on the encoder resolution.

B

This value selects the level of microstepping in open loop mode. Acceptable values are 2, 4, 5, 8, 10, 16, 25, 
32, 50, 64, 100, 128, 200, 250, 256. Other special values are: 
•	 	18 = .01 degrees / µstep 
•	 	108 = 1 arc minute / µstep

C

This parameter selects the number of microsteps per unit distance at the part. It will be in units of µsteps/
degree, µsteps/mm, µsteps/inch, etc. This multiplier is used to accommodate for any gearing changes and 
calibrate the system to the specific motion stage setup. For a typical 1:1 rotary stage, for example, this value 
will be the same as the number of microsteps/revolution divided by 360, or 142.2 µsteps/degree. A 20:1 
high-precision stage would require this value to be multiplied by 20 to get the correct calibration factor. Verify 
the calibration factor is correct by moving the stage a given distance and measuring the actual traveled 
distance.

D

This parameter sets the motor hold current as a percentage of total current. Hold current is the amount of 
current that the motor uses to keep the motor static between movements. A stage which loads the motor at 
idle (like a Z-axis stage with a marker head attached) requires more current to maintain its current position, 
and thus a higher hold current value than a stage with lower load. A higher hold current uses more electricity 
and causes the motor to heat up, so it is important to balance the need for a stiff motor against the additional 
heat introduced into the system and the movement duty cycle. At high hold current values the motor can 
become hot to the touch.

E

This parameter sets the motor run current as a percentage of total current. Run current is the amount of 
current the motor uses during movements. Faster movements, higher accelerations, and high stage loads 
increase the necessary run current. Set the run current to a setting that allows the desired speeds and accel-
erations to run without stalling, but do not set the run current higher than is necessary to prevent the motor 
from becoming unnecessarily hot. It is important to balance the speeds and accelerations with the run current 
and duty cycle to find the optimal setting.

F This parameter reverses the direction the motor traverses with respect to the positive axis of the CabLase 
Editor 5 mark field. This setting is determined by the stage configuration.
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10.5.3	 To change the Encoder settings

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Motion Configuration to be modified.
XX Click the Configure button. The Motion Configuration tool appears.
XX From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis 

settings panel appears.
XX Click the Encoder tab. The Encoder page appears.

The Motion Configuration Encoder page

A Enables the built-in encoders on equipped drives. Choose drives with the “-EQ” option to get the built-in 2048 
line encoder.

B

This parameter sets the number of counts that determine the width of the “dead band”. In closed loop 
feedback mode the motor will compare the requested position with the encoder position and automatically 
make adjustments to ensure that the motor is in the correct place. The dead band is the zone around the 
requested point at which the motor considers it “close enough”. It is important to balance the desire for a tight 
tolerance against the physical parameters of the stage and the extra current required to maintain a location 
against static load. This value is only meaningful when “Enable position maintenance” is checked.

C

The stall factor sets the number of counts required for a stall error to be reported to the laser marker. If the 
motor's current position is different from the current requested position by greater than the number of counts 
set in this stall factor the motor will error out and stop moving. This is useful to minimize damage in the case 
of motor crashes, part jams, or other issues. It is also useful in position maintenance mode because it causes 
a fault if the maintenance is unable to maintain the desired position.

D

Select this option to enable the closed-loop position maintenance algorithm. The motor will compare the 
requested position with the current position reported by the encoders and make any movements necessary 
to correct errors within the tolerance of the dead band. If the position errors are so great that they exceed the 
stall factor an error will be reported and the motor will stop moving if Stop on Stall is checked. When position 
maintenance is enabled it is important to properly set the dead band and stall factor to reasonable values, 
and ensure that the run current is high enough to allow the stage to move if position maintenance is required.

E This option causes detected stalls to stop the motor from moving until the motor is reset. Use this option to 
protect the system from damage in the case of stage crashes or part jams.
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10.5.4	 To change the Homing settings

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Motion Configuration to be modified.
XX Click the Configure button. The Motion Configuration tool appears.
XX From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis 

settings panel appears.
XX Click the Homing tab. The Homing page appears.

The Motion Configuration Homing page in slew mode

A

The Homing style pull down menu selects the homing behavior from a number of different options as 
described below. In all cases, if the high or low limit is reached before the home limit is reached the slew 
direction will reverse, but the creep direction will remain the same.
•	 Slew in Minus direction, then creep in Minus direction - The stage will slew in the negative direction until 

the limit switch is found, then creep in the minus direction across the length of the switch until the edge of 
the switch is found

•	 Slew in Plus direction, then creep in Minus direction
•	 The stage will slew in the positive direction until the limit switch is reached, then creep in the negative 

direction until the edge of the limit switch is found. 
•	 Slew in Plus direction, then creep in Plus direction - The stage will slew in the positive direction until the 

limit switch is found, then creep in the positive direction across the length of the switch until the edge of 
the switch is found.

•	 Run to Plus Limit Switch - The stage will run to the positive limit switch, then set the home position
•	 Run to Minus Limit Switch - The stage will run to the negative limit switch, then set the home position
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B

Select from the following options:
•	 Home input is floating - This selection causes the system to interpret the I/O pin entering a floating state 

as activation. This option is available in both sinking and sourcing modes.
•	 Home input is pulled HIGH (or LOW) - This selection causes the system to interpret the limit input as 

transitioning from Low to High (sourcing) or High to Low (sinking) as activation. This is the most common 
setting when using solid state optical limits.

•	 On Encoder Index Mark - This selection causes the system to determine it has reached its home when 
the motor encoder reaches a built-in index mark. This is very useful for direct drive rotary systems without 
limit switches. It is important not to use this setting on systems with alternative gearing since there is one 
home index every motor revolution, which may not correspond to the same home location every time on 
an arbitrary system

C
This parameter sets the “creep” velocity in steps/seconds. The homing stage first slews until it finds the 
appropriate limit, then creeps in a manner determined by the setting of the “Homing Style” pull down menu. 
Set this value to a low setting for accurate homing.

D

This parameter sets the offset position from the home flag in steps. This value can be positive or negative. 
When the stage has reached home it will move the desired number of steps at the home creep speed. 
This function is particularly useful when trying to execute the same CabLase Editor 5 job on two different 
machines. Each machine will have a different necessary home offset, which can be corrected using this 
parameter.

E

The sensor debounce is a time in milliseconds required from when a limit switch is activated until the homing 
routine continues to the next phase. This is intended to compensate for switches with a lot of electrical 
“bounce” or instability on transition. Most mechanical switch systems require a debounce. 0 ms is a typical 
setting for solid state optical sensors.

F

This parameter sets the “slew” velocity in steps/seconds. The homing stage first slews until it finds the appro-
priate limit, then creeps in a manner determined by the setting of the “Homing Style” pull down menu. Set this 
value to a slow to medium setting for accurate homing. Slower home slews slow homing time, while longer 
home slews require increased creep distances due to stage inertia.

G
This parameter sets the deceleration rate of the stage during the homing process in units of steps/s2. This is 
the rate at which the stage will decelerate when it finishes its slew and creep movements. Select a high value 
for accurate and quick homing.

H

This pull down menu is where the wiring style of the limit sensors is configured. Changing this option will 
change some choices in the “At home when” pull down menu to accommodate the differing polarity of sinking 
and sourcing modes. Select the following options:
•	 Sinking - where the limit I/O pin at 24V is pulled down to 0V to activate,
•	 Sourcing - where the limit I/O pin at 0V is pulled up to 24V to activate.
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The Motion Configuration Homing page in Run to limit mode

A
This parameter sets the acceleration rate of the stage during the homing process in units of steps/s2. This is 
the rate at which the stage will start it’s move to the limit switch. Select a high value for accurate and quick 
homing.

10.5.5	 To change the Limits settings

XX From the Main menu, select System > Preferences.
XX Click the Hardware tab. The Hardware page appears.
XX Select the Motion Configuration to be modified.
XX Click the Configure button. The Motion Configuration tool appears.
XX From the Motion Configuration tool, select the Motion type from the Current configuration list. The motion axis 

settings panel appears.
XX Click the Limits tab. The Limits page appears.
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The Motion Configuration Limits page

A

Select from the following options:
•	 Limit is floating - This selection causes the system to interpret the I/O pin entering a floating state as 

activation. This option is available in both sinking and sourcing modes.
•	 Home input is pulled HIGH (or LOW) - This selection causes the system to interpret the limit input as 

transitioning from Low to High (sourcing) or High to Low (sinking) as activation. This is the most common 
setting when using solid state optical limits.

•	 Ignore limits - Ignores limit switches. Commonly used for direct drive rotary stages with no limit switches.

B

Soft limit of hardware travel in the negative direction. This value can be set precisely by moving the hardware 
to the minus limit switch and noting the value of the position counter. Enter a value greater than the position 
counter for CabLase Editor 5 to limit the travel. For the limit switch to limit the travel, enter a value less than 
the position counter.

C

Soft limit of hardware travel in the positive direction. This value can be set precisely by moving the hardware 
to the plus limit switch and noting the value of the position counter. Enter a value less than the position 
counter for CabLase Editor 5 to limit the travel. For the limit switch to limit the travel, enter a value greater 
than the position counter.

D

The sensor debounce is a time in milliseconds required from when a limit switch is activated until the limit is 
considered activated. This is intended to compensate for switches with a lot of electrical “bounce” or instability 
on transition. Most mechanical switch systems require a debounce. 0ms is a typical setting for solid state 
optical sensors.

E Use this option to decelerate the motor using a ramp profile instead of a constant profile. This setting is used 
for stages with high inertia that do not respond well to rapid deceleration.

F

This pull down menu is where the wiring style of the limit sensors is configured. Changing this option will 
change some choices in the “At home when” pull down menu to accommodate the differing polarity of sinking 
and sourcing modes. Select the following options:
•	 Sinking - where the limit I/O pin at 24V is pulled down to 0V to activate,
•	 Sourcing - where the limit I/O pin at 0V is pulled up to 24V to activate.
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10.6	 Pro-Dex OMS motion controller

Using the OMS PCIx series motion controller, CabLase Editor 5 provides a full 4-axis motor controller capability. With 
this controller, cabLase Editor 5 can interface to 4 individual motor axes, for applications such as rotary indexers, XY 
tables, linear slides, etc.

10.6.1	 Installing the Motor Controller Card

i Note!
Not supported on Windows Vista or Windows 7.

Before using the motor controller card, it must be properly installed and configured. Make sure that CabLase Editor 
5 is already installed on the target machine before installing the motor controller card. If cabLase Editor 5 is not 
installed, see Getting Started > Software Installation.

10.6.1.1	To install the Motor Controller Card

!
Warning!
Turn OFF the power to the computer and disconnect the power cord.

XX Discharge any static electricity build-up before handling the Motor Controller Card by touching a grounded metal 
object (like the exposed metal parts on the back of the computer).

XX Remove the cover from the computer. (Refer to the computer manual for instructions on removing the cover).
XX Locate an unused PCI slot. Remove the expansion slot cover. Save the slot cover screw for use in Step 5.
XX Remove the motor controller card from its antistatic packaging. Always handle the card by its edges.
XX Insert the motor controller card into the PCI expansion slot. Press down firmly until the card clicks into place and 

then replace the slot cover screw. The motor controller card installed in a PCI slot is shown below.
XX Replace the computer cover.
XX 	Reconnect the power cables to the computer.

10.6.1.2	To install with Plug and Play

XX Power up the computer. After logging in, Windows will detect the new hardware and show the Files Needed dialog 
(Windows 2000).

XX Click the Browse button, and browse to the \marker\oms folder. Click OK to close the browse dialog.
XX Click OK to close the Files Needed dialog. Windows completes the installation of the OMS drivers.

10.6.2	 Configuring the Motor Controller Settings

10.6.2.1	To configure the Motor Controller Settings

XX From the menu bar, select System > Preferences.
XX Click on the Motor Control tab. The Motor Control page appears.
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XX Click the Configure button. The OMS Motor Controller setup appears.
XX Click the Controller Settings tab. The Controller Settings page appears.

	

The Controller Settings page

A Select the current axis to edit.

B Set the base velocity for the current axis. Note that setting a nonzero base velocity provides a means to 
accelerate through resonance as fast as possible.

C Set the maximum velocity the user will be allowed to enter throughout the cabLase Editor 5 application.
D Enter the minimum velocity the user will be allowed to enter throughout the cabLase Editor 5 application.
E Changes the direction the motor turns when given a move command.
F Define the switch contact state when at the limit position.

G This feature is always enabled. The motor controller will monitor the forward and reverse limit switches while 
executing moves.

H This feature is always enabled. The motor controller will stop an axis after a limit switch is signaled using a 
deceleration profile.



262 26210	 MOTION CONFIGURATION

I
Select from the following options:
•	 Absolute
•	 Relative

J Select the acceleration ramp for the current axis.
K Set the maximum acceleration rate for the current axis.
L Select the number of steps in the acceleration ramp.
M Define the switch contact state when at the home position.
N When homing, approach the home switch moving in the direction selected in this control.

Learning the Home and Limit Positions

Before using your motor controller card, the Home, Forward and Reverse limits must be learned so cabLase Editor 5 
knows what the mechanical limits for each axis are. The setup of the Home and Limits are in the XY Table, Custom 
Axis or Rotary pages.

i
Note!
The Controller Settings should be set up before setting the Home And Limits. In the Controller Settings page, the 
Direction selection should be based on how this axis is generally moved. If you usually leave the motor on the 
positive side of home then you should use the negative edge (direction) for detection.

10.6.2.2	Homing the axis

Homing is performed at 90 percent of the maximum speed for the axis. This value is set in the Controller Settings 
page for each axis. Start at the highest practical axis speed and adjust down until homing and carriage movement 
is acceptable. To offset the Home position (for example so that Home equals 1000 steps), enter 1000 in the edit box 
next to the Home button. Click the Apply button then click the Home Button for this offset to take effect. Changing 
the Sensor Direction or Home Position Offset probably requires changes to axis position values in currently saved 
jobs. Therefore it is suggested that home be established and kept with the same parameters once installed. It is also 
suggested that upon starting CabLase Editor 5 the motor position(s) should be between the limit sensors for best 
results. 
A Motor Home Menu is called upon entering CabLase Editor 5. This window (see below) is used to force all axes to 
home when CabLase Editor 5 is first started.

		                
			      The Home axes dialog

It is also available from an axis automation object's Properties menu. In addition, the Motor Manager also allows 
homing of the selected axis. If a job is selected to run and an axis has not been homed then the operator will enter 
the Motor Home Menu. If one finds that they need to home continually then they may consider how to better use the 
axis automation functions in their jobs. If they believe the correct position is being lost then they need to consider 
having their machine serviced because this is not normal functioning of the device.
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10.6.2.3	Finding the forward and reverse limits

It is suggested that the home position is found before setting the limits. It is not possible to set a limit when on the 
limit switch. If an axis is in this condition, then click Stop and either click Home or Move Relative to move to a position 
where the motor is off the sensor. Note that when automatic Forward or Reverse Limit sensing is accomplished (by 
clicking the appropriate buttons), the current position will not equal the limit value because WinLase will move the 
motor off the limit switch, in case you want to perform another limit movement. The limit movement speed is based 
on the value in the Motor Properties window. The limit value changes slightly due to speed. One may want to find the 
limit and maximum speed then find the limit a second time at a slightly slower speed such as half of the maximum or 
what the person typically uses in their jobs. This is a very minor difference and most designs allow a margin between 
the limit switch and maximum travel needed for normal operation. In all cases the OK button must be used to save 
settings. Once the limits are set then only upon changing the Home position should the limits need to be reset.

10.6.2.4	Configuring the Axis Types

To edit the XY Table Settings

XX From the menu bar, select System > Preferences.
XX Click on the Motor Control tab. The Motor Control page appears.
XX Click the Properties button. The OMS Motor Controller setup appears.
XX Click the XY Table tab. The XY Table page appears.

	

The XY Table page

A Enables/disables the axis. When an axis is disabled, it is not accessible from the CabLase Editor 5 user 
interface.

B The name CabLase Editor 5 displays within dialogs and controls to represent the axis.

C
Click this button to home the axis. In the edit box to the right of the Home button, enter the step count to 
assign to the home position. When an axis is homed, it will have this position value at home. The units are in 
motor steps.

D
Use this button to find the forward limit stop switch. After the axis has found the forward limit stop, the position 
count is saved and displayed in the edit box to the right of the Fwd button. The forward limit is used to warn 
the user of the physical limits of the axis.

E The calibration factor for the axis, in steps/millimeter (mm).
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F
Use this button to find the reverse limit stop switch. After the axis has found the reverse limit stop, the position 
count is saved and displayed in the edit box to the right of the Rev button. The reverse limit is used to warn 
the user of the physical limits of the axis.

G Immediately stops execution of a motor move.
H The current position count of the motor.

I
The position to move the motor to when the Go button is clicked. If the Moves are setting is Absolute, the 
motor will move to the absolute position indicated in Move To. If the Moves are setting is Relative, the motor 
will move the amount in Move from its current position.

J The speed at which the motor will execute the move, in steps/Sec.
K Executes a motor move based on the value in Move to. 

10.6.2.5	To edit the Custom Axis Settings

The Custom Axis is provided to allow configuring a motor axis to be either linear or rotary, depending on the 
application.

XX From the menu bar, select System > Preferences.
XX Click on the Motor Control tab. The Motor Control page appears.
XX Click the Properties button. The OMS Motor Controller setup appears.
XX Click the Custom Axis tab. The Custom Axis page appears.

	

The Custom Axis page

A Enables/disables the axis. When an axis is disabled, it is not accessible from the cabLase Editor 5 user 
interface.

B The name cabLase Editor 5 displays within dialogs and controls to represent the axis.

C
Click this button to home the axis. In the edit box to the right of the Home button, enter the step count to 
assign to the home position. When an axis is homed, it will have this position value at home. The units are in 
motor steps.

D
Use this button to find the forward limit stop switch. After the axis has found the forward limit stop, the position 
count is saved and displayed in the edit box to the right of the Fwd button. The forward limit is used to warn 
the user of the physical limits of the axis.
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E
Select the type of motion device:
•	 Rotary - Select this radio button to represent the axis within CabLase Editor 5 as a rotary device.
•	 	Linear - Select this radio button to represent the axis within CabLase Editor 5 as a linear device.

F The calibration factor for the axis, in steps/millimeter (mm).

G
Use this button to find the reverse limit stop switch. After the axis has found the reverse limit stop, the position 
count is saved and displayed in the edit box to the right of the Rev button. The reverse limit is used to warn 
the user of the physical limits of the axis.

H Immediately stops execution of a motor move.
I Current motor position counter

J
The position to move the motor to when the Go button is clicked. If the Moves are setting is Absolute, the 
motor will move to the absolute position indicated in Move To. If the Moves are setting is Relative, the motor 
will move the amount in Move from its current position.

K The speed at which the motor will execute the move, in steps/Sec.
L Executes a motor move based on the value in Move to. 

	

10.6.2.6	To edit the Rotary Axis Settings	

XX From the menu bar, select System > Preferences.
XX Click on the Motor Control tab. The Motor Control page appears.
XX Click the Properties button. The OMS Motor Controller setup appears.
XX Click the Rotary tab. The Rotary page appears.

	

The Rotary page

A Enables/disables the axis. When an axis is disabled, it is not accessible from the CabLase Editor 5 user 
interface.

B The name CabLase Editor 5 displays within dialogs and controls to represent the axis.

C
Click this button to home the axis. In the edit box to the right of the Home button, enter the step count to 
assign to the home position. When an axis is homed, it will have this position value at home. The units are in 
motor steps.

D
Use this button to find the forward limit stop switch. After the axis has found the forward limit stop, the position 
count is saved and displayed in the edit box to the right of the Fwd button. The forward limit is used to warn 
the user of the physical limits of the axis.

E The calibration factor for the axis, in steps/degree.
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F
Use this button to find the reverse limit stop switch. After the axis has found the reverse limit stop, the position 
count is saved and displayed in the edit box to the right of the Rev button. The reverse limit is used to warn 
the user of the physical limits of the axis.

G Immediately stops execution of a motor move.
H The current position count of the motor.

I
The position to move the motor to when the Go button is clicked. If the Moves are setting is Absolute, the 
motor will move to the absolute position indicated in Move To. If the Moves are setting is Relative, the motor 
will move the amount in Move from its current position.

J The speed at which the motor will execute the move, in steps/Sec.
K Executes a motor move based on the value in Move to. 

	

10.6.2.7	To view the OMS Card Properties

XX From the menu bar, select System > Preferences.
XX Click on the Motor Control tab. The Motor Control page appears.
XX Click the Properties button. The OMS Motor Controller setup appears.
XX Click the Card Properties tab. The Card Properties page appears.
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cab Produkttechnik GmbH & Co KG warrants to the Customer that the product is free from defects in workmanship 
and materials for a period of 12 months from the delivery date.

cab Produkttechnik GmbH & Co KG' obligation under this warranty is limited to repair, replacement or service, at its 
option, of any part of the product, which within the warranty period and upon cab Produkttechnik GmbH & Co KG' 
examination shall disclose to its satisfaction not to have conformed to this Agreement or to have been defective. 
Defective parts or products are to be returned to cab Produkttechnik GmbH & Co KG place of shipment.

The above warranties do not apply (i) to defects or failure of product or parts caused by accident, alteration, abuse, 
misuse, corrosion or improper installation or operation, or (ii) to alterations or modifications made by Customer in any 
way so as in cab Produkttechnik GmbH & Co KG' judgment to affect the products reliability, or (iii) to installation not 
performed pursuant to cab Produkttechnik GmbH & Co KG' factory authorized protocol, or (iv) in the case of custom 
software designed to interact with other Customer-supplied software, in the event of any change, upgrade or repro-
gramming of such Customer-supplied software so as to create an incompatibility with cab Produkttechnik GmbH & Co 
KG software.

Authorization to return products purchased from cab Produkttechnik GmbH & Co KG must be obtained by Customer. 
Returns should always be carefully packed and sent freight prepaid. Unless otherwise agreed, return shipment freight 
and duty charges shall be borne by Customer. Customer shall bear all charges for freight and handling of products 
returned which are not defective.

THIS WARRANTY IS EXPRESSLY MADE IN LIEU OF ANY AND ALL OTHER WARRANTIES EXPRESSED 
OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE, EXPRESSED OR IMPLIED.
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Revision Date Changes from previous revision
1.0 11/04/09 Original release
1.1 12/20/09 Corrections throughout
1.2 02/04/10 Added details on Mark on the Fly when using Run Job Remote tool
1.3 04/05/10 Added %i Custom String specifier, typo corrections
1.4 06/18/10 Added %F Custom String specifier
1.5 08/12/10 Added new configuration file feature changes. Added details on 

manually entered calibration data. Improved section on optimizing 
object profiles



269 269

1
2

3

4

5

6

7

Taiwan
cab Technology Co., Ltd. 

16F-1, No. 700, Jhong Jheng Rd
Junghe, Taipei 23552
phone +886 (02) 8227 3966
fax	 +886 (02) 8227 3566
info.asia@cab.de
www.cab.de/tw

China
cab (Shanghai) Trading Co., Ltd. 

A507, No. 268, Tong Xie Rd
Shanghai 200335
phone +86 (021) 6236 3161
fax	 +86 (021) 6236 3162
info.cn@cab.de
www.cab.de/cn

cab (Shanghai) Trading Co., Ltd. 

Room 39, 10F, 8 Lin He Zhong Rd 
Tian He District, Guangzhou 510610
phone +86 (020) 2831 7358
info.cn@cab.de
www.cab.de/cn

Europe

Germany
cab Produkttechnik  
GmbH & Co KG
Wilhelm-Schickard-Str. 14
76131 Karlsruhe
phone +49 721 6626 0
fax +49 721 6626 129
info@cab.de 
www.cab.de

cab Produkttechnik  
Sömmerda GmbH
Am Unterwege 18-20
99610 Sömmerda
phone +49 3634 6860 0
fax +49 3634 6860 129
info@cab.de 
www.cab.de

France
cab Technologies S.à.r.l.
2a Rue de la Moder
Z.A. Nord du Val de Moder
67350 Niedermodern
phone +33 388 722501
fax +33 388 722502 
info.fr@cab.de
www.cab.de/fr

America

USA
cab Technology, Inc.
87 Progress Avenue Unit 1
Tyngsboro, MA 01879
phone +1 978 649 0293
fax +1 978 649 0294
info.us@cab.de
www.cab.de/us

Latin America
Alejandro Balmaceda
Hacienda Jurica Pte 1615
Colonial de Valle
32553 Ciudad Juárez
phone +52 656 682 3745
fax +52 656 682 4301
a.balmaceda@cab.de
www.cab.de/es

South Africa
cab Technology (Pty) Ltd.
14 Republic Street
Bordeaux
2125 Randburg
phone +27 11 886 3580
fax	 +27 11 789 3913
info.za@cab.de
www.cab.de/za

Asia

	 Headquarter and fabrication 	
	 in Germany 

       to       International
	 subsidiaries

There are furthermore 820  
distribution partners in more  
than 80 countries.
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